EVE Launcher for Linux


(Ravow) #63

my custom command point to a custom sh script I made, you can just simply put “wine” in there. you also need to click on another field once before you click on OK else it often don’t save.

If you want to know what’s my script, there it is:
#!/bin/sh
ssr-glinject wine $@

ssr-inject is part of simple screen recorder and it allow me to record my EVE session. if you don’t use that you can omit. you can put any envvar you want before wine and the $@ just put all parameters that the evelauncher started the script with.

Also, the first time you run it, you may want to put “winecfg” as the wine command so you can setup some staging parameters.


(Elassus Herron) #64

huh. Nope, that doesn’t start the client: clicking the “start” icon next to my character results in the progress bar filling partway, then stopping and reverting back to inactive. Are there any mods/changes I need to make to wine or the launcher?


(Ravow) #65

You did use a sh script or wine for the wine command?


(Elassus Herron) #66

just “wine” in the field for the custom wine path.


(Ravow) #67

I did not make any other change…


(Elassus Herron) #68

that’s bizarre. But for some reason, my wine client won’t start. It works fine if I use ccp-master, but not the local.

I wonder if there’s some winetricks or something I forgot about. I’ll look around, I guess.

Cheers,

EH


(Ravow) #69

Did you try to replace the wine command for winecfg, to check if it work and configure wine?

Also what’s your ABI_X86? in the make.conf, wine need 32 bits support.

ABI_X86=“32 64”!!!


(Ravow) #70

you can use emerge -va wine-staging:2.16 to see if ABI_X86 have 32 in it.


(Elassus Herron) #71

yup, I checked. It has support for both 32 and 64-bit. winecfg also starts, though I get an error about missing the .net runtime.

I did uninstall winetricks. Do you need that for anything?


(Ravow) #72

No need for winetricks, It did work directly on my side…

You can try to run the logserver first, you might get some insight.


(Ravow) #73

Here my wine USE=“X alsa cups custom-cflags fontconfig gecko gphoto2 gsm jpeg lcms mono mp3 ncurses nls openal opencl opengl perl png realtime run-exes s3tc samba ssl (staging) threads truetype udisks vaapi xcomposite xml”

Also be sure to eselect wine list, then eselect wine set ThatCorrectWine


(Elassus Herron) #74

ok, I looked at the launcherlog file, and it has this at the end:

2017-09-14T23:54:34.162Z        default debug   "wine client error:0: version mismatch 533/536."
2017-09-14T23:54:34.162Z        default debug   "Your wineserver binary was not upgraded correctly,"
2017-09-14T23:54:34.162Z        default debug   "or you have an older one somewhere in your PATH."
2017-09-14T23:54:34.162Z        default debug   "Or maybe the wrong wineserver is still running?"
2017-09-14T23:54:34.163Z        default debug   Process 19056 finished with exit code 1
2017-09-14T23:54:48.511Z        default debug   Closing main window

So, something’s wrong with my PATH. eselect wine has 2.16 correctly set, but maybe the launcher is pulling the wineserver from its internal? I don’t appear to have any other wineserver running.

I’ll look into it tomorrow. It’s too late for me here and my brain is mush :frowning:


(Ravow) #75

Reboot or do a ps -A & kill party. (kill all wine related stuff)

you can also try wineboot.


(Ravow) #76

Finally I’m back to the old Gallium Nine (Native DX9).

I did test in an combat anomaly with interval immediate, all to max and a resolution of 3840x2160…

DX11 : 25FPS
DX9(nine) : 125FPS (it allow me to set Interval one to have a stable and constant 60 fps)

Also my estimation are right, not only DX11 harvest 1/5 of the performance, but when i’m using Interval one (dx11 25fps vs dx9 60fps), DX11 still eat an extra 50W (up to 100W extra in station). With translate to 3$ more of electricity per month for abyssal performance.

That will not get better, DX emulation is costly, at least,not until we get real multi threading for the D3D-> OpenGL layer (CSMT is not sufficient), or until someone make a DX11 state tracker (like nine, but for DX11).


(Elassus Herron) #77

‘ps -ax | grep wine’ returns nothing, so I’m not sure there’s a wine or wineserver process running. Maybe the second part of the error is the culprit, that I have EVE’s internal wine somewhere in the path?

I’ll keep digging around. Though, from your last message it looks like DX11 is still not ready for primetime anyway.

Cheers


(Merkwurkdigliebe) #78

Put this in a file, say evelog.sh and make chmod u+x evelog.sh, then point your launcher to that.

#!/bin/bash
export PATH=/opt/wine-staging/bin:$PATH

export WINEARCH=win32
export WINEPREFIX=/home/user/.eve/wineenv
#export WINEDEBUG=fixme-all, warn-all # Speeds up wine

/opt/wine-staging/bin/wineserver
/opt/wine-staging/bin/wine $@ &> wineloger.txt


(Elassus Herron) #79

Pointed my launcher to that file, and the only thing the log shows is that the process “exited with code 1”.

I modified the path for wine-staging and /home appropriately. Still, the client never starts. It shows this in the file /home/user/.local/CCP/EVE/Launcher/launcherlog:

2017-09-17T09:56:59.146Z	default	debug	handleCommand: "launcheve"
2017-09-17T09:56:59.394Z	default	debug	"/home/user/carrier0/evelog.sh" ("/home/user/.eve//wineenv/drive_c/tq/bin/exefile.exe", "/noconsole", "/server:tranquility", "/remotefilecachefolder=Z:/home/user/.eve//ResFiles")
2017-09-17T09:56:59.394Z	default	debug	Preparing wineenv
2017-09-17T09:57:00.165Z	default	debug	wineenv exists
2017-09-17T09:57:00.165Z	default	debug	Copying Arial font
2017-09-17T09:57:00.166Z	default	debug	("QTDIR=/home/user/carrier0/launcher/evelauncher", "fvwm_term=/usr/bin/aterm", "VDPAU_NVIDIA_NO_OVERLAY=1", "LESS=-R -M --shift 5", "JAVAC=/etc/java-config-2/current-system-vm/bin/javac", "XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0", "OPENGL_PROFILE=nvidia", "INFOPATH=/usr/share/gcc-data/x86_64-pc-linux-gnu/6.3.0/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.27/info:/usr/share/info", "QT_QPA_PLATFORMTHEME=qt5ct", "PRELINK_PATH_MASK=/usr/lib64/klibc",  "QT_GRAPHICSSYSTEM=raster", "LC_MEASUREMENT=de_DE.UTF-8",  "XDG_VTNR=7", "USER=user", "ANT_HOME=/usr/share/ant", "GDM_LANG=en_US.utf8", "fvwm_webbrowser=/usr/bin/opera -style liquid", "LC_TIME=de_DE.UTF-8", "WINEDLLOVERRIDES=mscoree,mshtml=", "GTK_MODULES=canberra-gtk-module", "OPENCL_PROFILE=nvidia", "WINEDEBUG=", "XAUTHORITY=/home/user/.Xauthority", "PAGER=/usr/bin/less", "LC_NUMERIC=de_DE.UTF-8", "XDG_SESSION_TYPE=x11", "EDITOR=/bin/nano", "XDG_SESSION_DESKTOP=Xsession", "fvwm_icons=/usr/share/icons/wm-icons", "LESSOPEN=|lesspipe %s", "LD_LIBRARY_PATH=/home/user/launcher/evelauncher:", "DYLD_FALLBACK_LIBRARY_PATH=/usr/X11/lib", "LC_MONETARY=de_DE.UTF-8", "LC_COLLATE=de_DE.UTF-8", "fvwm_mail=/usr/kde/3.3/bin/kmail", "LC_PAPER=de_DE.UTF-8", "FVWM_USERDIR=/home/user/.fvwm", "XDG_CONFIG_DIRS=/etc/xdg", "MANPATH=/etc/java-config-2/current-system-vm/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/6.3.0/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.27/man:/usr/lib/llvm/5/share/man:/usr/lib/llvm/4/share/man:/etc/java-config-2/current-system-vm/man/:/usr/local/share/man:/usr/share/man:/usr/share/rust-1.19.0/man", "TZ=TZ", "GDMSESSION=Xsession", "WINEPREFIX=/home/user/.eve//wineenv", "SHLVL=1", "HOSTDISPLAY=domo-kun:0", "JDK_HOME=/etc/java-config-2/current-system-vm", "CONFIG_PROTECT_MASK=/etc/sandbox.d /etc/fonts/fonts.conf /etc/gentoo-release /etc/gconf /etc/terminfo /etc/dconf /etc/ca-certificates.conf /etc/texmf/web2c /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/revdep-rebuild /etc/splash", "XDG_RUNTIME_DIR=/var/run/user/1000", "FVWM_MODULEDIR=/usr/lib/fvwm/2.6.5", "QT_PLUGIN_PATH=/home/user/carrier0/launcher/evelauncher/plugins", "GCC_SPECS=", "DESKTOP_SESSION=Xsession", "DISPLAY=:0", "XDG_SEAT=seat0", "LANG=en_US.UTF-8", "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt /usr/share/config /usr/lib64/libreoffice/program/sofficerc", "XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0", "SHELL=/bin/bash", "_=/home/user/launcher/evelauncher/evelauncher", "force_s3tc_enable=true", "XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/user", "JAVA_HOME=/etc/java-config-2/current-system-vm", "PATH=/usr/x86_64-pc-linux-gnu/gcc-bin/6.3.0:/usr/lib/llvm/5/bin:/usr/lib/llvm/4/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/games/bin", "DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-kJO2BRQ82q,guid=de38a5c16636ef560cb098e759bacdc2", "XDG_DATA_DIRS=/usr/local/share:/usr/share")
2017-09-17T09:57:00.177Z	default	debug	Process 2055 finished with exit code 1

(username changed because paranoia)
Any idea what I’m doing wrong here? also, where would the file “wineloger.txt” show up?

Thanks for the help!


(Merkwurkdigliebe) #80

In the same directory as the file, likely ~/evelauncher but you went with ~/ so there probably…

find /home | grep wineloger.txt

Also… ~/launcher/evelauncher ? Probably shouldn’t matter but I’ve never seen anyone go w/ something other then ~/evelauncher … if there was a relative path that assumed cache was in …/ that’d be an issue but I dont see anything like that. We need more debug, find that file!


(Elassus Herron) #81

found it! It was, in fact, in ~/.

Uh … it gives exactly the same error about a mismatched wineserver. So now what?


(Merkwurkdigliebe) #82

So your running a wine server. Somewhere.

I had this issue too, but rebooting and stating the wineserver explicitly fixed it. Yet now when I check which wineserver:

/usr/bin/wineserver -> /opt/wine-staging/bin/wineserver

Its a symlink. Which may have happened after the fact, since I later removed wine2.0.2.

If your sure you didnt move some files around wine/bin probably an old version of either is in the path somewhere. Thats why I put $PATH at the end but maybe it didnt work? Backup the /usr/bin/wineserver you have and make a symlink to the one you want. Reboot and try.

Good luck,
-M