EVE Launcher for Linux


(Elassus Herron) #83

rebooted. /usr/bin/wineserver is a symlink to /usr/bin/wineserver-staging-2.16. My superuser only has a couple paths in the $PATH variable, but my regular user has the following:

$echo $PATH
/usr/x86_64-pc-linux-gnu/gcc-bin/6.3.0:/usr/lib/llvm/5/bin:/usr/lib/llvm/4/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/games/bin:/home/user/usr/lib64/qt5/bin

(that last one is an error in a PATH variable I set up in .bashrc, which I have now corrected).

I don’t see anywhere in that path where another wineserver could be hiding. Does the launcher do anything itself to set the wineserver prefix?


(Merkwurkdigliebe) #84

cp -f /usr/bin/wineserver /home/user/launcher/.eve/wine/bin/wineserver?

Looks like it does call wineserver some why, my .eve/wine is infact a copy of wine-staging forgot about that :slight_smile:


(Elassus Herron) #85

ZOMG. Yes, that was the issue, and copying the system wineserver to the ~/.eve subdirectory fixed it. Everything looks so pretty!

But yes, antialiasing has to be turned off or I get some kind of wild pixellated acid flashback. Planet shadows also look badly pixellated, probably from turning off AA.

But everything else works: secondary lighting, station sprites, gas cloud effects, etc… It’s nice enough I think I’ll stick with it for a while and see how fps does.

Thanks so much for helping me!


(Merkwurkdigliebe) #86

No problem glad that worked out… I suppose I could be less lazy and test this but giving it a second look there is a wineserver env variable but doesn’t look like the launcher is setting it… here is a diff between my default env and the env wine is launched with… no wineserver but what I want to know is where did the dlloverides come from because they aren’t mine:

4a5
> declare -x DYLD_FALLBACK_LIBRARY_PATH="/usr/X11/lib"
11a13,14
> declare -x LD_LIBRARY_PATH="/home/user/evelauncher/.:"
> declare -x LIBGL_ALWAYS_SOFTWARE="1"
15c18
< declare -x PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
---
> declare -x PATH="/opt/wine-staging/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
16a20
> declare -x QTDIR="/home/user/evelauncher/."
17a22
> declare -x QT_PLUGIN_PATH="/home/user/evelauncher/./plugins"
20c25
< declare -x SHLVL="1"
---
> declare -x SHLVL="2"
26c31,35
< declare -x WINDOWID="27275137"
---
> declare -x WINDOWID="27272212"
> declare -x WINEARCH="win32"
> declare -x WINEDEBUG=""
> declare -x WINEDLLOVERRIDES="mscoree,mshtml="
> declare -x WINEPREFIX="/home/nomadx/.eve/wineenv"
40a50
> declare -x force_s3tc_enable="true"

(Tom Schlong) #87

Downloaded latest evelauncher for Linux (version 1156239) and ran the evelauncher shell script via terminal, it went fine, updated itself, updated the client. About halfway through I got an error, it stopped updating and referred to an error log file.

Inside the Evelauncher top-right is a settings menu, I deselected the check for Duality, then the Launcher would resume updating automatically and it finished without incidents. Client runs fine with dx9 so far on Solus3.

After logging into a character, there is a black screen for like 20 seconds, the only visual hint that the launcher is still working and didn’t crash is the little ‘resource loading’ circle in the bottom left corner.

Great new intro video btw. Much better than the one called ‘this is eve’. =)


(Glokaya Kuzdra) #88

I had a similar problem, the solution was this
https://forums-archive.eveonline.com/default.aspx?g=posts&m=6747082
Check the logs at ~/.local/share/CCP/EVE/Launcher to see what’s your problem


(Sreal Artwa) #89

I have been trying to install EVE on Ubuntu all day. I have successfully installed it before a few months ago but its not working now and it has me wondering if something has changed that stopped the launcher from working.


(Luperco Garsk) #90

Hi, thank you for the port in Linux.

I’ve installed it on my laptop with Linux Mint 18.2,
The machine is quite old with an NVidia GTX 460M

Everything is working well even if I need to reduce the graphics a bit to have smooth rendering.

I’ve tried to post the application to the Wine AppDB. Anyway it has been rejected as the launcher download a custom version of Wine.

It is possible to know which version of Wine has been used to run the game?

Thanks,


(Furor Crendraven) #91

Anyone is experiencing stuttering in the new Ubuntu 17.10 variants with Nvidia? Since I upgraded my Kubuntu yesterday I have stuttering in Eve each 2 seconds aprox during 0,5-2 seconds.

SOLVED: meanwhile the official launcher don’t reach Directx 11 functionality/bug free, I am playing EVE Online like this:

  • Used Playonlinux to create a 32 bits virtual unit with Wine 2.19-staging
  • Configured Eve Online in DirectX 11 with Antialiasing and Postprocessing off

Now I enjoy DirectX 11 and the stuttering is gone, only mouse inside stations lags a little bit
The only glitch that remains is some flickering with distant suns when a GUI graphic is blocking it.

My specs:

  • Kubuntu 17.10 64 bits
  • Nvidia driver 384
  • Nvidia 765 GTX M

(Frejasa Momaki) #92

I’ve found it to run quite well on opensuse with gnome, xfce and mate desktops (and suspect it will probably work on most environments suse normally works well with). I launch it from a user directory in a shell with no special priveleges each time. Doesn’t seem to be any need to formally install it or give it any special priveleges. With low graphics it gets playable performance on some laughably underpowered machines, and beautiful powerful performance on powerful machines. Can’t say much else really, I’m just a windows refugee still learning how to use a keyboard :slight_smile:

But if you can get opensuse running well then it seems to like eve, if anyone wondering about a good distro to try it on.


(Osamo Kazumoto) #93

on 17.10 ubuntu eve lags when I move mouse and freezes till mouse stopped moving. that’s pisses me off…

but the most awful is that after latest launcher update i cannot start eve at all.


(Deleted Graviton) #95

Hey everybody.

I use Debian 9. EVE does not start. In the terminal I receive no error message. Does anyone have the same problem?


(Samwise Dagordae) #96

I had the same issue with lag.

Dropping the Linux kernel to 4.9 fixed it. Something about 4.12+ changed how USB is handled.


(Guss Nebrak) #97

I´ve Linux Suse

That´s my error massage:

error 2017-11-16T13:28:51 39 C:\tq\bin\exefile.exe linux-wagi ExeFile Main Exefile STARTUP
warning 2017-11-16T13:28:52 39 C:\tq\bin\exefile.exe linux-wagi blue TaskletTimer !! timeslice {“time”: 254, “order”: 1, “what”: “switching to”, “new”: “None”, “old”: “None”}
error 2017-11-16T13:28:52 4754 /home/xxx/evelauncher/evelauncher linux-wagi evelauncher wine “err:module:load_builtin_dll failed to load .so lib for builtin L"winex11.drv”: libXext.so.6: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden"
error 2017-11-16T13:28:53 4754 /home/xxx/evelauncher/evelauncher linux-wagi evelauncher wine “err:module:load_builtin_dll failed to load .so lib for builtin L"winemp3.acm”: libmpg123.so.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden"
error 2017-11-16T13:28:54 4754 /home/xxx/evelauncher/evelauncher linux-wagi evelauncher wine "err:setupapi:do_file_copyW Unsupported style(s) 0x144"
warning 2017-11-16T13:28:54 39 C:\tq\bin\exefile.exe linux-wagi trinity General Invalid Trinity platform dx9
error 2017-11-16T13:28:54 39 C:\tq\bin\exefile.exe linux-wagi client General Writing out stacktrace at C:/tq/logs/#stacktrace b1211512 2017.28.16 12.28.51.txt

What I´ve to do?


(Ardes Atavuli) #98

Running Debian Sid. The instructions provided above to replace the CCP provider libQT with native ones worked (otherwise I was getting symbol versioning issues with libluicene). Thanks for the tip, @Charles_BawngBlower.

Unfortunately, we now have a stricter libpng in Debian unstable (and testing), so I am now getting the errors:

libpng warning: iCCP: known incorrect sRGB profile
Aborted

And the launcher fails to launch.

Ardes Atavuli


(Punctator) #99


eve lancher memory leak detected - debian jessie
it keep using more and more memory ultimatly it will crash completly.


(Pestoya) #100

Perfectly working for me in 16.04.1-Ubuntu. Big thx


(Yasique Gautier) #101

Hello!
Is anybody would be so kind to quick answer or advice where the problem might be?
It is third day I’m trying to start the game, and I think I’m very close.

Launcher starts, but pressing “PLAY” button does nothing; starting from terminal using “./evelauncher.sh”.

[root@yas evelauncher]# ./evelauncher.sh
Qt: Session management error: None of the authentication protocols specified are supported
[0108/204400:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/yas/EVE/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/yas/EVE/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
[0108/204400:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.

[root@yas evelauncher]# uname -a
Linux yas 3.10.0-693.11.6.el7.x86_64 #1 SMP Thu Jan 4 01:06:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

CentOS 7 x64 / MATE Desktop

What are next steps to troubleshoot and fix?
Thanks in advance!


(Swizzles Saissore) #102

Also getting the problems where I click PLAY and nothing happens.

These are the errors I get from loglite

error 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher wine “err:module:load_builtin_dll failed to load .so lib for builtin L"WLDAP32.dll”: libldap_r-2.4.so.2: cannot open shared object file: No such file or directory"
error 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher wine “err:module:import_dll Loading library WLDAP32.dll (which is needed by L"C:\\tq\\bin\\blue.dll”) failed (error c000007a)."
error 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher wine “err:module:import_dll Library blue.dll (which is needed by L"C:\\tq\\bin\\exefile.exe”) not found"
error 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher wine “err:module:load_builtin_dll failed to load .so lib for builtin L"WININET.dll”: libz.so.1: cannot open shared object file: No such file or directory"
error 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher wine “err:module:import_dll Loading library WININET.dll (which is needed by L"C:\\tq\\bin\\exefile.exe”) failed (error c000007a)."
error 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher wine “err:module:LdrInitializeThunk Main exe initialization for L"C:\\tq\\bin\\exefile.exe” failed, status c0000135"
info 2018-01-09T20:15:55 5213 /opt/EveOnline/EveLauncher/evelauncher lappy evelauncher default Process 5434 finished with exit code 53


(Hendrik Tiberius) #103

Hello,

I thought perhaps this might be of interested to add to the first post. How to get the latest version.

In the old forum thread it is mentioned somewhere that the latest release version number can be found in the JSON file at this location http://binaries.eveonline.com/evelauncher_linux_release.json

Just now for example the above mentioned file containts this { “version”: “1225328” }.

I was able to download the client like this https://binaries.eveonline.com/evelauncher-1225328.tar.gz which I assume is the newest version, haven’t gotten further than this yet, wanted to post this before I forgot.