EVE Launcher version 1222103


(Nektor Toff) #1

Does this launcher version work for other people?

I played Eve on this computer yesterday, but after I clicked OK on the update it doesn’t work. I’ve also attempted to reinstall the launcher and deleted .eve and .local/share/CCP

I’m in Arch Linux and have tried both the evelauncher AUR package (which worked fine yesterday) as well as downloading and running the launcher standalone.


Evelaunsher.sh fails w/o any logs
(Rolf Rollardo) #2

Related log entries are:

2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve CRYPTO_num_locks
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve CRYPTO_set_id_callback
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve CRYPTO_set_locking_callback
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve ERR_free_strings
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve EVP_CIPHER_CTX_init
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve sk_new_null
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve sk_push
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve sk_free
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve sk_num
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve sk_pop_free
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve sk_value
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve SSL_library_init
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve SSL_load_error_strings
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve SSL_get_ex_new_index
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLv2_client_method
2017-12-19T19:45:52.310Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLv3_client_method
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLv23_client_method
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLv2_server_method
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLv3_server_method
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLv23_server_method
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve X509_STORE_CTX_get_chain
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLeay
2017-12-19T19:45:52.311Z        qt.network.ssl  warning QSslSocket: cannot resolve SSLeay_version

Something wrong with ssl again?


(Lucius Kalkoken) #3

Yes, SSL broken again. My fixer script:

#!/bin/sh

cd /home/mynamehere/local/evelauncher
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 libssl.so
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0 libssl.so.1.0.0
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 libcrypto.so
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 libcrypto.so.1.0.0

(Zuatar) #4

For Archlinux this didn’t work for me since the libs are somewhere else i use:

#!/bin/sh

cd /home/mynamehere/local/evelauncher
ln -s /usr/lib64/libssl.so.1.0.0 libssl.so
ln -s /usr/lib64/libssl.so.1.0.0 libssl.so.1.0.0
ln -s /usr/lib64/libcrypto.so.1.0.0 libcrypto.so
ln -s /usr/lib64/libcrypto.so.1.0.0 libcrypto.so.1.0.0

(Rhyme Bittern) #5

Launcher is broken on my current ubuntu 17.10. Here is what I get in the laucher log:

|2017-12-20T02:37:59.371Z|qt.network.ssl|warning|QSslSocket: cannot resolve SSLv2_client_method|
|2017-12-20T02:37:59.371Z|qt.network.ssl|warning|QSslSocket: cannot resolve SSLv2_server_method|
|2017-12-20T02:37:59.447Z|default|warning|Installed Qt WebEngine locales directory not found at location /home/yotam/הורדות/evelauncher/translations/qtwebengine_locales. Trying application directory…|
|2017-12-20T02:37:59.448Z|default|warning|Qt WebEngine locales directory not found at location /home/yotam/הורדות/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.|
|2017-12-20T02:38:02.295Z|default|error|Couldn’t open index file “/home/yotam/.eve//ResFiles/56/5610a6eb8b5a4975_2d75e946e3d61224690c0fd3f80d5966”|
|2017-12-20T02:38:02.406Z|default|warning|Update failed for Tranquility with error: 5|
|2017-12-20T02:38:02.789Z|default|error|Couldn’t open index file “/home/yotam/.eve//ResFiles/56/5610a6eb8b5a4975_1a90d14a174be46336f04c5d8fa1b7c8”|
|2017-12-20T02:38:02.887Z|default|warning|Update failed for Singularity with error: 5|


(Isabella Eszorra) #6

Hi everybody,

I also have the same problem since this morning, under Debian 9, After update eve launcher.

I run the launcher and it does not run, does not work


(Debian Severasse) #7

Interesting—I was having the same log entries a couple of weeks ago when I reinstalled----try downloading/installing the current resfiles— Just coming back & have a hosts issue (SOLVED) & Qt.network.ssl warning QSslSocket: cannot resolve SSLv2_client_method


(Rhyme Bittern) #8

Downloading the resfiles did the trick :slight_smile:


(Isabella Eszorra) #9

sorry, to disappoint you, but the solution proposed in the other post, does not work.


(Debian Severasse) #10

What do your logs look like?


(Isabella Eszorra) #11

I reinstall the old launcher, he asked to do the update, I click OK
and nothing, just some lines in the terminal

Citation
./evelauncher.sh
[1223/101949:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/username/evelauncher/translations/qtwebengine_locales. Trying application directory…
Qt WebEngine locales directory not found at location /home/username/evelauncher/qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.
[1223/101949:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
ATTENTION: default value of option force_s3tc_enable overridden by environment.

and it stays stuck there


(Isabella Eszorra) #12

here, the log after a new installation, and trying what is said in the other post

Citation
2017-12-23T16:13:05.331Z qt.network.ssl warning QSslSocket: cannot resolve CRYPTO_num_locks
2017-12-23T16:13:05.331Z qt.network.ssl warning QSslSocket: cannot resolve CRYPTO_set_id_callback
2017-12-23T16:13:05.331Z qt.network.ssl warning QSslSocket: cannot resolve CRYPTO_set_locking_callback
2017-12-23T16:13:05.332Z qt.network.ssl warning QSslSocket: cannot resolve ERR_free_strings
2017-12-23T16:13:05.332Z qt.network.ssl warning QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
2017-12-23T16:13:05.332Z qt.network.ssl warning QSslSocket: cannot resolve EVP_CIPHER_CTX_init
2017-12-23T16:13:05.332Z qt.network.ssl warning QSslSocket: cannot resolve sk_new_null
2017-12-23T16:13:05.333Z qt.network.ssl warning QSslSocket: cannot resolve sk_push
2017-12-23T16:13:05.333Z qt.network.ssl warning QSslSocket: cannot resolve sk_free
2017-12-23T16:13:05.333Z qt.network.ssl warning QSslSocket: cannot resolve sk_num
2017-12-23T16:13:05.334Z qt.network.ssl warning QSslSocket: cannot resolve sk_pop_free
2017-12-23T16:13:05.334Z qt.network.ssl warning QSslSocket: cannot resolve sk_value
2017-12-23T16:13:05.334Z qt.network.ssl warning QSslSocket: cannot resolve SSL_library_init
2017-12-23T16:13:05.334Z qt.network.ssl warning QSslSocket: cannot resolve SSL_load_error_strings
2017-12-23T16:13:05.335Z qt.network.ssl warning QSslSocket: cannot resolve SSL_get_ex_new_index
2017-12-23T16:13:05.335Z qt.network.ssl warning QSslSocket: cannot resolve SSLv2_client_method
2017-12-23T16:13:05.335Z qt.network.ssl warning QSslSocket: cannot resolve SSLv3_client_method
2017-12-23T16:13:05.335Z qt.network.ssl warning QSslSocket: cannot resolve SSLv23_client_method
2017-12-23T16:13:05.336Z qt.network.ssl warning QSslSocket: cannot resolve SSLv2_server_method
2017-12-23T16:13:05.336Z qt.network.ssl warning QSslSocket: cannot resolve SSLv3_server_method
2017-12-23T16:13:05.336Z qt.network.ssl warning QSslSocket: cannot resolve SSLv23_server_method
2017-12-23T16:13:05.336Z qt.network.ssl warning QSslSocket: cannot resolve X509_STORE_CTX_get_chain
2017-12-23T16:13:05.337Z qt.network.ssl warning QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
2017-12-23T16:13:05.337Z qt.network.ssl warning QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
2017-12-23T16:13:05.337Z qt.network.ssl warning QSslSocket: cannot resolve SSLeay
2017-12-23T16:13:05.338Z qt.network.ssl warning QSslSocket: cannot resolve SSLeay_version


(Isabella Eszorra) #13

Solved for me


(Debian Severasse) #14

Was the SSL fix above the answer?


(Hey Youguyz) #15

Hmm, that’s odd. So I’m an Arch user. To fix the launcher I had to copy “lib{ssl,crypto}-compat.so.1.0.0” over to the launcher directory, then it worked fine. But the “compat” packages aren’t in the AUR anymore. Is the libqtnetwork the launcher uses old or something?

EDIT: No, wait, it works with version “1.0.0”, compat or no.


(Mr M) #16

As long as the EVE Launcher don’t come with the libs it would be nice if it didn’t delete libssl.so.1.0.0 and libcrypto.so.1.0.0 when it’s updating.


(system) #17

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.