EVE Luncher collapses after I update macOS to Ventura(version 13.0)

After I update my macOS to Ventura, the Luncher slash back every time.
I tried to reinstall the Luncher but it doesn’t work.
Many other apps on macOS face the same problem, but it can be solved by reinstalling.

report is too long( with 90k words ,can not reply here totally), so, if needed, I can send it to GM.

I get same issue here, the launcher crashes.
Some of the error messages:

Crashed Thread:        0  CrBrowserMain  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called
...
Thread 0 Crashed:: CrBrowserMain Dispatch queue: com.apple.main-thread
0   ???                           	    0x7ff8925929a8 ???
1   libsystem_kernel.dylib        	    0x7ff8032d330e __pthread_kill + 10
2   libsystem_pthread.dylib       	    0x7ff80330af7b pthread_kill + 263
3   libsystem_c.dylib             	    0x7ff803254ca5 abort + 123
4   libc++abi.dylib               	    0x7ff8032c5082 abort_message + 241
5   libc++abi.dylib               	    0x7ff8032b623d demangling_terminate_handler() + 266
6   libobjc.A.dylib               	    0x7ff802fb5250 _objc_terminate() + 96
7   libc++abi.dylib               	    0x7ff8032c44a5 std::__terminate(void (*)()) + 8
8   libc++abi.dylib               	    0x7ff8032c6d05 __cxxabiv1::failed_throw(__cxxabiv1::__cxa_exception*) + 27
9   libc++abi.dylib               	    0x7ff8032c6ccc __cxa_throw + 116
10  libobjc.A.dylib               	    0x7ff802fae208 objc_exception_throw + 302
11  Foundation                    	    0x7ff804121a7f +[NSPropertyListSerialization propertyListWithData:options:format:error:] + 128
12  evelauncher                   	       0x1029e3910 0x10236b000 + 6785296
13  evelauncher                   	       0x1029f6aa8 0x10236b000 + 6863528
14  evelauncher                   	       0x102439545 EventLogger::EventLogger() + 2069
15  evelauncher                   	       0x102439eca EventLogger::instance() + 58
16  evelauncher                   	       0x1023e8b5c Settings::logStartup(QDateTime&) + 2860
17  evelauncher                   	       0x10237493d main + 2285
18  dyld                          	       0x203137310 start + 2432

The PC is
Macbook Pro 13-inch, M1, 2020, 16GB
OS is Ventura 13.0 (22A380)

I re-downloaded the luncher from website, and replace it, tried again, same crash.

here is my crash report.
and my Mac is 2021 MacBook Pro with M1 Pro, 16G RAM.

I think the crash is highly related to the new version of macOS.

I send mail to ccp support, and have to reinstall the whole eve( including the 30GB+ files).
will try it later.

I have no issues with Ventura and M1 8GB.

No issues for me with Venture 13.0, M1 Max 14" MBP 32GB

thanks for you lucky guys’ reply.
It still can not be solved yet for me.

I found. the solution, just because your system language, change it to English and reboot, will probably solve it

3 Likes

Wow this solution is really working!
Thanks a lot.
There is EVE launcher’s crash issue too after I updated to Ventura
And it was solved after I changed my mac’s system language to English(Korean → English)
Now I can play eve finally. thank you!

2 Likes

oh!! it works !! cool man!!
I’ll tell this to GM via support mail, this problem has to be solved in next update.

reload the whole eve files. So big >_<

Hey,

A new version of the launcher was just released. If you download the launcher then install it the issue should be resolved.

If you have already switched your systems language then simply start the launcher, let it patch. This should resolve the issue and you are free to switch back your OS language.