Https://support.eveonline.com/ Login Failure

I am currently unable to login to https://support.eveonline.com/ in Edge, Chrome or Firefox and I have also tried on multiple computers and phones.
I keep getting the following error:

This page isn’t working

login.eveonline.com redirected you too many times.

ERR_TOO_MANY_REDIRECTS

I have cleared browsing history, cookies etc and also disabled all extensions and still getting the same error.
I actually installed Firefox newly on my PC and get a similar issue:

The page isn’t redirecting properly

An error occurred during a connection to www.eveonlinesupport.com.

This problem can sometimes be caused by disabling or refusing to accept cookies.

Is anyone else having the same problem?

Regards,

JC

just tried it. except for eveonlinesupport.com, cause i have no idea where the hell that is supposed to redirect to,

the others work fine.

Yes, I can log in to https://www.eveonline.com/ and ESI logins are fine as well. It is just https://support.eveonline.com/ that is causing problems.
I’m not sure what that Firefox-reported URL is, but I can see the browser trying to access that URL when I click on the “Click Here to Login” button so, perhaps that’s part of the problem.

I have also flushed my DNS cache, which hasn’t helped either.

idk, like i said support.eveonline.com works fine for me, i just checked on the two bug reports I recently put in. I’m using chrome btw.

I was able to raise a ticket using the anonymous “I can’t log in” type of issue and a GM has emailed me back to say that there is an issue with some small number of accounts that are having issues logging in for some reason.
I’ll update this thread when I hear more back.

2 Likes

I didn’t get a specific update on this issue from the GMs, but I was able to log in to the Support site successfully this morning, so it looks like they have resolved the problem.

2 Likes