Issue with GESI: characters not authorize anymore

Hi everyone,

i managed last year to create a google sheet, thx to the GESI add-on, to keep track of the items i’m selling in Sobaseki.

I connected myself back a few days ago on the game and i see that i now have an issue: my sheet is not linked anymore to my characters and i have an error message (see the attachement below).

I tried to authorize my character again through the GESI app, but it not working anymore. I deleted the app, and tried again, with no success.

Anybody can help ?

“invalid audience” suggests that the wrong token is in use somehow, could an old one maybe be saved in the sheet?

What does it mean and how could i check that ? Thx for your answer.

“audience” in this context is data inside the token, specifying who’s allowed to use the token. in this case its probably supposed to be

It’s an implementation detail and i would not expect users to worry about it.

I’m wondering if they added or removed a requirement for that piece of data since you created your token.
I wouldn’t assume sheets is using the token you expect. If possible I’d set up a new sheet and see if it has the same issue, if not it’s something specific to your old sheet.

I’m gonna try that and keep you in touch.

1 Like

And… it’s working. Thx a lot :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.