[January] Ammunition re-loading and other minor changes from Five 0


We in Team Five 0 have worked on a bunch of fixes and smaller changes for the January release, and we would love if you could help us with testing them on Singularity!

Changes to loading and unloading of ammunition
The code for loading and unloading of ammunition (and other charges) has been rewritten in an effort to fix a bunch of long-standing bugs with it (like the dreaded “lost charges when jumping while a reload was ongoing”).

These were mostly just code changes, but we made also a few minor player-facing changes for this:

  • All inventory operations (moving of ammunition) are now done at the beginning of reloading and the reload timer is behaving like a reactivation timer on the module.
  • After the inventory operations have completed the reloading will no longer be interrupted by anything (but other things can be blocked until the timer has finished).
  • Cloaking after reloading will no longer interfere with reloading (but a cloaked ship can still not start to reload ammunition) - we are aware that this is a minor buff for probing. :smiley:
  • It is no longer possible to group or ungroup weapons, while the weapons are reloading.
  • A whole bunch of minor bugs around reloading ammunition have been fixed.

The duration of the reload timer should have not changed, but several issues where the default reload timer was not handled correctly have already been identified and fixed- please send bug reports if you find any modules where the reload timer changed in comparison to TQ.
We have already completed internal testing and fixed a bunch of new bugs and edge cases, but as these changes were quite extensive we would really appreciate it if you could help us out by testing this yourself. If you find any bugs with it, then please write a bug report through the client (F12 - Report Bug). Please reply to this post, if anything is unclear or if anything changed, where you think that this might be not an intentional change.

Vulnerability settings for Upwell Structures
In preparation for the upcoming changes to Upwell Structure vulnerability (still scheduled for Q1 2018) we are adding the ability to set the preferred hour and day for your structures to finish their reinforcement when attacked. While this setting will do nothing in this release, it is important that it works so your structures can transition correctly to the new system. This setting can be found in the right click menu of a structure in the structure browser, and is available to corp members with the station manager role.

Full support for setting the home station remotely for Upwell structures
Several fixes have been made to make sure that the feature of setting the home station remotely (which has a cooldown timer of one year) is properly supported for structures.

Potential bug fix for missing “Warp-to” option for structures
We made a potential fix for a bug which caused the “Warp-to” option to be missing from Upwell structures in some cases after a session change (and other options like “Dock” did not work properly). Unfortunately we could never reproduce this bug reliably (though it happened to us in the past), so we are not 100% sure if the fix worked. It would be great, if you could keep your eyes open if you are on Singularity.

Improvements to clone jump warning
The warning you get when your clone jump will result in the loss of a clone with implants has been improved. It will now list the implants in the clone, and we’d appreciate it if you could double check that info is accurate next time you clone jump.

CCP Lebowski and CCP Habakuk for Team Five 0


Does this include things like gate-jumping and docking?


Gate-jumping and docking will not be blocked by reloading and will not interrupt reloading. :slight_smile:


Firstly: Good to see some fixes and useful improvements.

Like for instance the really weird grouping of certain charges? In other words: When “Sort by Type” is selected for a hangar, why are the Armor, Skirmish, Information and Siege warfare charges spread all over the hangar and not in one place grouped together? I know the reason but I don’t think it’s acceptable.

Or why is this still a thing and not better cleaned up:

Hybrid charges all over the place, crystals all over the place, projectile ammo spread so randomly it’s unbelievable. And have I mentioned missiles?

But why only in the Structure Browser and not in the right click menu in the Corporation window’s Asset tab?


And just to be clear, his applies to all modules that use charges? Especially the long reload ones like interdictor bubbles, command bursts, ancillary modules?

This is not anything to do with our current changes, I’ll amend the OP to indicate that the bug fixes and changes are all related to reloading ammunition. I’d suggest you submit a bug report for any issues you see related to sorting and inventories.

That is correct, all reloading!


Oh man, this is gonna be great!

1 Like

This is quite a buff for dictors in regards to reloading while bubbling both sides of a gate and cloaking on grid while doing a reload.


Cool stuff!

This is a HUGE buff to Interdictors and any ship that relies on an ancillary booster/repper and has the ability to crash a gate.

Interdictors that are bubbling a gate can no longer be forced off to reload, and with bubbles lasting longer than the reload timer, it’s possible that interdictors may be able to stay on a gate or a tackled supercapital indefinitely, or at least for far longer than they could previously.

I don’t know whether this is a good or a bad thing, though.

1 Like

It’s alphabetical by type so I wouldn’t really say it’s a bug, but it might make sense to change the types so the orders make sense. Currently everything is in the ammo & charges type and then t2 ammo is Advanced weapon type charge so they go first then Bombs, Cap charges, Cruise missiles, and so on.

It could be resorted like it has been in the market window which is sorted by weapon type, advanced/faction/standard, and size. I’d do it just a little different and sort it by weapon type charge as the main type, and then you could have size as the secondary, and then t2/faction/standard as the third type. That way all your hybrid ammo is together, and then it’s sorted by large/medium/small/XL, and those are sorted by advanced/faction/standard. not sure how hard that would be to do, but it would probably look nicer.


I think I can tell you how to reproduce some of the “not able to warp to upwell structure” bug.

  1. Start in an adjacent system.
  2. Set overview to not show a type of upwell structure, e.g. Refinery
  3. Activate Stargate and enter the target system
  4. Right click in space, navigate through the structures menu and attempt to warp to or dock at the structure. You’ll know that it is broken before you click because “Approach” will be visible at the top of the action menu.

Now repeat but in step 2 make sure the overview includes the target structure. The bug won’t activate (or at least not reliably)

This makes me moist…

Citadels better be able to scramble at all times (outside reinforced) when the change to citadel vulnerability goes live.

These steps were given in several bug reports and I tested them quite a few times, but unfortunately they do not lead to the problem for me on test servers. Maybe I was missing some other condition (like some setting) or (more likely) the problem depends on timing, like it could be possible that it only happens with a slower connection to the server.

That’s why it would be great, if you could test your steps on Singularity and check if you are still experiencing the problem.

Uh, so you’re aware of the minor buff for probing, but not of the rather massive buff to Interdictors this presents?

Not that I particularly mind the buff to either Dictors or Probers, and not having minute-long reloads that don’t do anything because you hit cloak or jump a second too early is a nice improvement in QOL, but Dictors seem like something you should have considered, and your post makes it seem like they didn’t even come up.

This would be my guess. If I hang around in the system long enough eventually I am able to warp to every structure.

i just tried it again… when there is a bracket OR overview active, that has structures not set, you cant warp to them… it most have something to do with overviewsettings… dont know if you already knew that…

Did you try this on Singularity? If yes: Please send a bug report directly after you tried this directly from the client (F12 - Report Bug), best to also include a screenshot with the wrong menu entries (hint: you can create a screenshot with open menu entries by pressing CTRL+ALT+SHIFT+P while the bug reporting window is open and you are navigating through the right-click menu).
If you did not try on Singularity: Please try it out - it would help quite a bit!

1 Like