Launcher broken

(Megan Maynard) #1

Anyone else getting this error as of this morning?

1 Like
(Old Man Chamemi) #2

I am getting the same error too.

:frowning:

added ---- however, I am using Manjaro on 2 computers now. On the desktop which already had everything installed and just logged in to play eve, everything is perfect.

On the laptop, I had to do a fresh reinstall of distro therefore had to download EVE all over again and on the lappy, im getting the same error you are getting.

In LogLite only getting warning about QT WebEngine and the translations, could that be the case?

(Sincetta) #3

Same here :confused:

(CCP Avalon) #4

X-post from Devblog: New Launcher Changes Coming!

Since we don’t have official support for Linux, the launcher backend may not yet have been updated on release. Switching to beta, and receiving the launcher app update there, should solve the issue for the time being.

(Megan Maynard) #5

That worked.

Steps to resolve:
Go to menu settings, under version type select beta and restart launcher.

Boots up fine after that.

1 Like
(Terak Romaller) #6

New launcher downloaded and started first time sweet as a nut.
Debian 9, Wine 4.0.

(CCP Bartender) #7

Hey guys, I’ve just hit the release button on the new qt build, it should trickle down to you guys any second and resolve these issues. However, I have kinda yolo’d it and pushed it to beta and prod at the same time, so let me know if you hit issues, I’ll keep an eye on this thread.

1 Like
(Sincetta) #8

Thank You! It works perfectly right now.

(Old Man Chamemi) #9

— update: downloaded binaries, had the GLX error, deleted all libxcb files, had pulseaudio error, fixed that, runs on Release. Laptop locks up after 20 mins. Updated pacman, switched from CCP-master to Winehq master, does not lock up anymore. Also for some reason had to update samba as well, not really sure why, but meh, cant do no harm with a samba update.

Using Arch/Manjaro/Arco, runs on all three now without issues

1 Like
(Jibril Olerie) #10

Thanks for mentioning this. I was getting the GLX error and the launcher never launched. After doing an rm libxcb* in my /home/user/.local/lib/EVE/Launcher directory, it all works again!

P.S. I am using this AUR package to install EVE.

1 Like
(Gharim Turen) #11

@CCP_Bartender The new version 1456645 works so far, works also with my scripts. I become only a new message displayed by launching:

QObject::startTimer: Timers can only be used with threads started with QThread

System: Debian Stable, Gnome Desktop, Kernel 4.9.0-8-amd64, Wine 4.0 with DXVK 0.96

(system) closed #12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.