Launcher (Linux) update fail

When tried to switch to beta version (v1385477) launcher closes with following error in terminal:
/home/user/.eve//updater: /usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.21’ not found (required by /home/user/.eve//updater)
UPD: now the same problem on stable version. Launcher itself works if hit “cancel” on update request, but can’t login due to white screen after logging in (see

$ strings /usr/lib/x86_64-linux-gnu/ | grep GLIBCXX


Linux Mint 17

Also on Mint 17 and I have the same issue.

What about making a test install (perhaps on different media) with a newer version of Mint, which might come with a newer version of the lib, I don’t use it but it’s at 19 now.

If that is not appropriate I have found various fixes searching GLIBCXX not found errors, suggestions include statically linking or updating the toolchain; but I am not 100% on them as I haven’t tried Mint yet.

If all else fails I’d just use the same distro and version the dev is using for the beta as stated on a separate partition lol.

Same issue/error as OP–I’m running Mint 17.3. Ran into it when the launcher tried to update today. If I accept the update, (hit ok), the launcher immediately closes. If I hit cancel, the launcher seems to function normally (albeit not updated).

1 Like

Anyone managed to fix this yet ?

For me: not yet :frowning:

It’s now doing the download of the update every time I run the launcher, and if I cancel the download it never gets to ‘Ready’ (The blue bar never appears). Does anyone know of a way to stop this, a setting somewhere perhaps ?

Haven’t found a fix yet, but on my system if you let the download complete to 100% and then cancel when it asks to apply the update or cancel and stay on the current version it works ok.

it keeps asking to install with a 30 sec timer when you start the launcher, but so far the client then launches fine after hitting cancel

Mine’s the same, but it’s a fair sized download and I’m not sure what my ISP’s monthly limit is…

Just discovered I can’t add a new account to the launcher either, it just puts up an empty white box when you add one. A bit annoying when you’ve just created a new account and subbed Omega for 3 months…

I’m beginning to understand why the sarcastic comments about CCP’s coding expertise appear in these forums, but I think perhaps it’s more to do with their QA-testing expertise…

No updates to this thread recently - have previous posters found fixes, or just given-up on Eve ?

Finally fixed it by switching to the windows version of Eve-launcher under Wine - thanks largely to a great deal of help and guidance from Whitehound, to whom I am extremely grateful.

More than month later… problem still persists…

Did you try running the Windows version under WINE ? It’s been working for me ever since my last post, provided I remember to kill the launcher once the clients are up and running.

I prefer Linux version for Linux.

So do I, when it works - when it doesn’t I’d rather play under Wine than not play at all…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.