My Google Sheets

Im learning how this all works… Ive read this guide and with success might I add, I got the application made and verified.

Scroll down to Getting Your Character Assets … I copied the guide as is, and in a1 entered the following


and I get back some data, just like in the flash video shown in the guide. Only in mine, the columns are arranged different. Which leads me to why I am here. I tried to do the last steps on this guide,

=HLOOKUP(“name”, universe_types_type(“en-us”, INDIRECT(ADDRESS(ROW(), 1)), True), 2, FALSE)


=HLOOKUP(“description”, universe_types_type(“en-us”, INDIRECT(ADDRESS(ROW(), 1)), True), 2, FALSE)

but I get an error

HLOOKUP evaluates to an out of bounds range.

Is this because my columns are different? I didnt edit anything differently from the guide. I used the guide to copy text from, and pasted into the sheets. I used the same cells as well.

Thanks for any help provided. :slight_smile: cheers.

You need to specify the column for the type ID, which is 1 or A in the example given in the guide, in my case it’s column G wich is equal to 7

=HLOOKUP(“name”, universe_types_type(“en-us”, INDIRECT(ADDRESS(ROW(), 7)), True), 2, FALSE)

I hope this helps you out, i’m realy bad at explaining stuff lol :slight_smile:

1 Like

That was explained perfectly actually… And now I think I get this issue here, relating to the command, or formula/function.

So as I opened my sheets I see that mine has a 1 placed after ROW … so I have to ensure that this call sends the request to the correct cell, thus enabling the function. I think I get that now. Thank you!! I changed the 1 to a 7 and both name and description works perfectly! yea!!! :smiley:

This is prolly very remedial but I have no training with spreadsheets or anything. I have watched a few videos and read a few guides mind you that wont call for experience, knowing what to do… where to do it.

I can move on to the next part. which Im not sure what that is yet. Im attempting to learn and make a corporation spreadsheet so, cheers for the help, its really appreciated!


I guess my only question at this moment would be, how to tell that is what was wrong and where it needs to go?

So I moved on to making a new application, my second application, and intended to get my character to see the corp assets. Kinda like what I did for the first application? So I selected a different scope, and came back with an error when validating. I will explain. Any help is greatly appreciated. cheers

This is what I selected in the application - corporationAssetsRead

so I see in the sources list in the script editor > gesi file, and selected this to match the application.


I saved all script files and attempt to reload the sheet and then authorize under gesi section and I get this once I click the Eve SSO link

{“error”:“invalid_scope”,“error_description”:“The requested scopes either don’t exist, or are not valid for this client”}

I did this with the CEO of the corp, counter to the first application I did with my industrial main character… To add I did replicate first application with the CEO to ensure the CEO works and all works like the first application, as expected, just with a different character.

This stuff is pretty cool, I am interested, but I really have no idea how this all works yet.

So I wanted to see the corp assets, I did try this with the industrial main and got the same error, thus tried the CEO but same error.

Any help is again, greatly appreciated. I dont know what to select for and why… is there an explanation as to what each source request does? and when I should use said source?

cheers again.

I get “Parse error” when i enter it in H2 :
=HLOOKUP(“name”, universe_types_type(“en-us”, INDIRECT(ADDRESS(ROW(), 7)), True), 2, FALSE)

Help would be apreciated … Followed the Tutorial like OP


OK Found the Error. Formating from the Official “Tutorial” is faulty.
If you get the “Parse error” change
, to ;
“ to "

line schould look like this then :
=HLOOKUP(“name”; universe_types_type(“en-us”; INDIRECT(ADDRESS(ROW(); 7)); TRUE); 2; FALSE)

1 Like

That is interesting. I need to make some progress this week on my sheet… and learning how to use spreadsheets etc…

I really cant get past the last question I posted and without any help IDK what to do… :confused:
Other than pay someone to make a sheet for me, I have one appraisal of a basic trade sheet and addons for manufacturing for around 500 mil base price… ?

I’m having the same exact issue but my type_id is column 8. So my code looks like :
=HLOOKUP(“name”, universe_types_type(“en-us”, INDIRECT(ADDRESS(ROW(), 8)), True), 2, FALSE)

I also seem to have something different in column A that isn’t shown in the video. It says “is_blueprint_copy” but when I hover over it is says “=characters_character_assets()”.

Any ideas?

Try to change commas “,” to semicolons “;” in the formulas.

Thanks for the response Elliath. I tried that but it didnt work. Actually, when I change the ‘,’ to ‘;’ and hit return, the semicolons auto change back to commas.

Try to look at universe_types_type function definition. Mine had switched language and type input parameter. So I just switched them in formula and it worked.

Thanks again. But unfortunately I am too novice to understand that. any chance you can share what worked for you?

Hm, I looked again at your formula. I do not know what is that “I5” value in INDIRECT() function. Try to remove it, so it looks like this:
=HLOOKUP(“name”, universe_types_type(“en-us”, INDIRECT(ADDRESS(ROW(), 8)), True), 2, FALSE)

If it will not work, try to use this:
=HLOOKUP(“name”, universe_types_type(INDIRECT(ADDRESS(ROW(), 8)), “en-us”, True), 2, FALSE)

The second one has switched values for type and language.

I tried both codes; neither work. The I5 was an attempt to get it to work but not in the original code. I’m totally lost now. I also looked at the swagger page [here]( but I don’t really understand it well enough to know how to use it.

The swagger page says mentions the “is_blueprint_copy” which I get on my return of “=characters_character_assets()” in cell A1. It works to pull my data. But after that nothing. The original tutorial does not show that.

Try to insert this formula in empty cell, just to see what it returns:

If it returns data, then insert it into main formula instead of existing universe_types_type function.

I tried it and it does return data in a cell but does not work in the formula :frowning:

Can you make a copy of the sheet and share it? It would make it much easier.

I made a copy of your sheet and this formula works for me:
=HLOOKUP(“name”, universe_types_type(INDIRECT(ADDRESS(ROW(), 8)), “en-us”, True), 2, FALSE)

OMG! It finally works. Thank you for your help. You’re a spreadsheet genius.