Steam Play Beta. All Games are available for Download to Linux Steam Client


(Erasmus Grant) #1

I will download EVE Online on Steam soon to see if there will be Direct X 11 support. I got Skyrim playing audio issues, Fallout 4 playing audio issues. New Vegas no problem. Star Wars Battle Front 2 (2005) no problem.


The like and get likes thread II
Linux Launcher Settings On Low Resolution Screens
(Whitehound) #2

Some of us already use DXVK together with WINE, which is what Steam now does and calls it Proton. So, yes, it should work with EVE and DirectX11 setting. You may perhaps notice a bit of flickering on the HUD, but nothing to be worried about. If you have an Nvidia card then you should get the latest driver, 396.54 or at least 396.51, because they fix some Vulkan issues.

The latest Nvidia driver 396.54 also fixes a regression and as a result offers some significant performance boosts.

And one more tidbit of info. If you’ve been using CUDA with an Nvidia card, i.e. ffmpeg and hardware encoding, and noticed that it no longer works, then it’s because of a bug in the latest drivers, which unintentionally require a NUMA-enabled Linux kernel. It should get fixed soon hopefully as it’s already been confirmed as a bug by Nvidia.


(Gharim Turen) #3

After doing the necessary steps on wine (set wine-version to Windows XP with winecfg, install corefonts with winetricks) it works with Proton-3.7 on Pop!_OS. Used nvidia-driver are version 396.24 from System76 repo. Make sure, that you use the right wine installation and the right wine prefix when you setup Proton’s wine for EVE Online.


(Ima Wreckyou) #4

This is absolutely huge! I have a seperate wine-steam Installation for playing steam titles with wine, and every time I used it I prayed to THE GABEN that he would simply integrate wine into the native steam.

And THE GABEN not even did he listen, but he went beyond what I could have dreamed!

Now it is clear why there was such a incredible drive behind wine suddenly. Valve was teaming up with Codewavers, the company behind wine and they played the guy who developed DXVK, sponsored esync patches etc.

Best thing ever!!


(Erasmus Grant) #5

https://docs.google.com/spreadsheets/d/1DcZZQ4HL_Ol969UbXJmFG8TzOHNnHoj8Q1f8DIFe8-8/htmlview#

sharing is caring


(Erasmus Grant) #6

I have it working on Pop. i have not done any Proton stuff far as I know. How does that work?


(Gharim Turen) #7

There are some ways how does it work. If you have Steam Beta activated, then you have Proton which comes with the Beta Client. Without the Beta Client it works, when you have a file called steam_appid.txt in the launcher directory and have a running steam client when you start the eve launcher application. The Eve Launcher looks always after an running steam client and call him, when he found him, for the steam sso. Or you add Eve directlly to your Steam App as a No-Steam Game.


(Gharim Turen) #8

Oh wait, now i understand, wat do you mean with have not doing stuff with proton. Hmm, the first time, as i have launched eve with proton yesterday, it crashes two times. After i have done the settings which i has described before it works here. Interesting, i will check it again without any preliminary settings.


(Erasmus Grant) #9

More interested in getting Fallout 4 working and Skyrim SE. I have audio issue with music and voice on both.

Fallout 4 has a super sensitive cam and Skyrim has bugged guards


(Sir Constantin) #10

I tried running Eve in a VM (Ubuntu 18.04 x86) by just opting into steam beta and enabling steam play for all titles and compatibility tool Proton 3.7 but didn’t worked.
The launcher would not show up. I could see the icon in systray for a few seconds then disappear/crash.

The log looked like this:

[0823/205948:ERROR:resource_bundle.cc(720)] Failed to load Z:\home\jack.steam\steam\steamapps\common\Eve Online\Launcher\resources\qtwebengine_devtools_resources.pak
Some features may not be available.
[0823/210033:ERROR:resource_bundle.cc(720)] Failed to load Z:\home\jack.steam\steam\steamapps\common\Eve Online\Launcher\resources\qtwebengine_devtools_resources.pak
Some features may not be available.

And there wasn’t any qtwebengine_devtools_resources.pak in the folder, only
qtwebengine_resources.pak
qtwebengine_resources_100p.pak
qtwebengine_resources_200p.pak
icudtl.dat

Later Edit:
I tried replacing qtwebengine_devtools_resources.pak with one from my qt 5.9.5 installation but didn’t work. maybe i need qt4 or?

[0824/035509:ERROR:data_pack.cc(123)] Bad data pack version: got 5, expected 4

For now i gave up debugging this.

Installing using Lutris worked: https://lutris.net/games/eve-online/
Installing using Installer Packages worked as well: http://pasq.org/gharim/

Would be nice if CCP could make it to just work when installing using Steam Play.


(Gharim Turen) #11

After crippling my Pop!_OS installation by trying to install a newer nvidia-driver from the ubuntu ppa and reinstalling the whole mess i have tested again the EVE installation with Steam Play. It doesn’t work without some changes which i have described before. This time i have used these scripts for that, to made this easier for other Steam Play installations

cat ./wine_sp

#!/bin/sh

set -e

# use Proton's wine installation to handle all internal wine commands
export WINE="$HOME/.local/share/Steam/steamapps/common/Proton 3.7/dist/bin/wine"

# insert steam_appid in WINEPREFIX here from "EVE Online" as 8500
export WINEPREFIX="$HOME/.local/share/Steam/steamapps/compatdata/8500/pfx"

env WINEPREFIX=$WINEPREFIX WINEDEBUG=fixme-all "$WINE" "$@"

cat ./winetricks_sp

#!/bin/sh

set -e

# use Proton's wine installation to handle all internal wine commands
export WINE="$HOME/.local/share/Steam/steamapps/common/Proton 3.7/dist/bin/wine"

# insert steam_appid in WINEPREFIX here from "EVE Online" as 8500
export WINEPREFIX="$HOME/.local/share/Steam/steamapps/compatdata/8500/pfx"

env WINEPREFIX=$WINEPREFIX WINEDEBUG=fixme-all winetricks "$@"

After i have executed ./wine_sp winecfg to set windowsversion to “Windows XP” and ./winetricks_sp corefonts to install corefonts, Eve Online works with Steam Play as expected. But after all i prefer the linux launcher from @CCP_Snorlax, it was only a test for me, if Steam Play works with Eve Online.

hth

Addendum
Used Steam version was the original downloaded from Valve’s website not these from the repo, so the steam path may be different.


(Sir Constantin) #12

@Gharim_Turen Thanks for the scripts, it worked. :smiley:
Using the Steam from the repo the path was:

$HOME/.steam/steam/steamapps/common/Proton 3.7/dist/bin/wine

Also Steam play doesn’t come with winetricks!? So i had to install winetricks (~ 500MB ) to be able to execute the second script and install corefonts.

Overall feels slower than the Linux launcher and there are some small bugs.


(Gharim Turen) #13

Nice to hear that. The huge part from winetricks are a complete wine environment which it has as a dependency. Maybe you are interested to check it again without these dependencies. Remove winetricks and wine, download winetricks from Winetricks and from the repo install binutils, cabextract, p7zip, unzip and wget. The wine environment comes from Steam Play. In the 2nd script you must insert the complete path to the downloaded winetricks script like so

env WINEPREFIX=$WINEPREFIX WINEDEBUG=fixme-all \
    <path-to-winetricks>/winetricks "$@"

Happy fiddling :slight_smile:


(Mechnom) #14

Interesting way.

I adjusted the wine installation after the installer of @CCP_Snorlax stoped working on linux mint 19

1. Install Game via Steam

  • Set Up Proton Support
  • Install Eve Online
  • Start once

2. Install winetricks

sudo apt install winetricks

3. Get to your game folder

This looks something like this:
cd ‘~/.steam/steam/steamapps/compatdata/8500/pfx’
Depending on your steam folder settings

And run the follwoing commands:

WINEPREFIX="`pwd`" winecfg

Set the windows version to XP and hit apply

Then install the dependencies:

WINEPREFIX="`pwd`" winetricks corefonts vcrun2005 vcrun2008 vcrun2010

EVE Launcher for Linux
(Gharim Turen) #15

Should work on this way. But if you install winetricks from the repo, you get wine as dependency or you have it always installed before. When you call then winecfg and winetricks, the installed wine from the distribution will overwrite the wine installation in your wineprefix which was the version from Proton before. That was not this, wat i want in my post, it should work with Steam’s wine not them from the distribution.

Btw. why does the linux installer from @CCP_Snorlax dont work anymore? Using him the whole time on different distributions without errors.


(Erasmus Grant) #16

Could y’all make a video or picture by picture tutorial please? My PoL EVE Install quit working.


(Ravow) #17

Want to test that Proton, but on my side, running anything Proton make Steam to segfault when it display the confirmation after pressing “Play” on a Windows game (I even brought two games to support them when then made the move…)


(Whitehound) #18

I only use Debian and there I don’t need winetricks or any other work-around. It just works with the latest WINE version and the Windows installer+launcher for EVE.


(Whitehound) #19

I’ve now downloaded Steam for Linux and tested it myself. It works.

The steps I needed to do to get it working with Debian 10 “Buster” were these:

  1. Download Steam for Linux. You’ll get a file called steam_latest.deb.

  2. Install Steam. I’ve used dpkg -i steam_latest.deb in a root shell. Any missing dependecies such as curl or python need to be met before it will install. You’ll have to consult your distro on how to install .deb packages if you’re not familiar with it. Note: You’ll also need to have any i386-specific driver files install, such as for MESA, Vulkan and your graphics card.

  3. Run Steam. As I use Xfce4 was it only a matter of locating it in the menu under Games and selecting Steam.

  4. Connect to your Steam account and let Steam update itself.

  5. Open Steam Settings and select under Account the beta participation to get the latest software. Let Steam update itself again.
    image

  6. Open Steam Settings again and select under Steam Play to enable Steam Play for all titles. Steam will restart again. Here you can choose to use the latest Beta of Proton, too:
    SteamSettings

  7. Install EVE Online as you would normally do in your games library.

  8. Run EVE Online. It will briefly show the system tray icon of the launcher, but then quit quietly. This is due to the missing “Windows XP”-mode of Proton/WINE. However, this will have created a /tmp/proton_run file with a few details we need in the next step.

  9. Look at the content of the /tmp/proton_run file. It will tell you which WINEPREFIX the game was installed under and where to find Proton itself. For example:

$ cat /tmp/proton_run
...
	WINEPREFIX="/home/user/.local/share/Steam/steamapps/compatdata/8500/pfx/" \
...
	"/home/user/.local/share/Steam/steamapps/common/Proton 3.7/dist/bin//wine64" "${@:-${DEF_CMD[@]}}"
...

Note: The file /tmp/proton_run may or may not appear. It seems it no longer does for recent versions of Steam / Proton. If it doesn’t then see if you can find the directories on your own using the above as example.

  1. Start winecfg and change the compatibility mode to Windows XP:
$ export WINEPREFIX="/home/user/.local/share/Steam/steamapps/compatdata/8500/pfx/"
$ "/home/user/.local/share/Steam/steamapps/common/Proton 3.7/dist/bin/wine" winecfg
  1. Now you can try again to start the game with Steam. It should now open the EVE launcher and download the first game files. You can enter your account name and password. Once the last files have been downloaded can you start EVE.

Note that Proton 3.7 is based on WINE 3.7. For reasons unknown does it produce cracking sound for me. I don’t have this problem with WINE 3.15/DXVK 0.71. I suppose this may be a problem with Proton itself and could possible find a fix in the future. However the game runs with DX11 and all settings at high as expected. No winetricks were required for Debian. The Nvidia driver I’ve used was 396.54.02.


So what's about Vulkan?
EVE Launcher build 1385477 beta release for linux
Not able to login with linux launcher
(Lynn Ahashion) #20

So I just ran into a fix for your audio issue yesterday - https://youtu.be/UQ-Ml78kiEE