Problem to laucher start on steam with proton

Hello everyone,
hello I have fresh install linux, proton and eve online but when I push button play launcher not open or immediately close. if you have some ideas to fix it ;_)
o7 my friends and thanks

Which linux distribution are you using? That we we have a frame of reference to start from to help you, as some linux distributions need more effort to get EVE to work than others.

Barring any further communication from you, it sounds like you are at least running through Steam. The first thing I would try, before adding cl flags or messing with anything funky, is just altering the proton version. I have had to run through several different proton versions over the last couple years. Go through them in the game’s properties menu, from experimental down to 5.0, and try to run the game with each one.

ubuntu lts

I will assume you mean Ubuntu 22.04.4 LTS and document what is needed.

Alright. Downloaded ubuntu-22.04.4-desktop-amd64.iso.

dd if=~/Downloads/ubuntu-22.04.4-desktop-amd64.iso of=/dev/sdx ← where X is the usb drive you wish to sacrifice
sync

Reboot, boot from USB.

Select “Install Ubuntu”
Select keyboard layer, “Continue”

Change to minimal install ( if a package is needed I will note it later )
Ddownload updates is ticked and install third party software is ticked also. “Continue”

Erase Disk and Install Ubuntu ( this may be different if your drive is brand new, but in case this is being followed verbatim, this option will nuke your data ) and select “Install Now”

A warning will display if the disk already has a partition on it, select “Continue” to confirm its destruction.

Side note here. LVM is possibly the worst default partitioning scheme to employ on a home computer who’s drive is unlikely to change during its life. I am looking at you RHEL and RHEL clones. Shame on you.

Select where you live for the “Where are you window” prompt and select “Continue”.

The personalisation screen. Your name, your computers name. Password, though I tick the box for logging in automatically when doing testing I do not recommend it for a home computer unless people break into your house and try to use your computer for watching cat videos.

Select “Continue” again.

Ubuntu showing a welcome screen. Progress bar. Looks like it downloads some updates before the install kicks off, about 147 for me. Now another 25. Another 49. Now its actually installing. Phew.

Now it looks to be installing packages, or rather uninstalling packages. I guess ubuntu in all its wisdom deploys the lot and then cleans up stuff later, rather than just deploying what is needed. Cannot say I am a fan of this a approach, its like using duct tape from the spool and then trying to put back on the length you did not need after. Honestly it just punishes people who do not want crap everywhere.

Now its downloading updates again. Another 70 packages. Install complete, restart now. There will be a prompt to remove your USB boot media. push “Enter”.

Reboots.

On login there will be more user configuration prompts. Filling in the online services prompts is out of scope, as is the privacy window, but the last screen shows some useful items for the masses like discord and VLC.

There is one more nags to install updates, downloads a ton more updates, though importantly drivers too, so this bit is actually important. There will be another prompt to reboot.

On restart it bugs you for online account again. Odd.

Now I do not know what the graphical package manager is for Ubuntu, but I do know that ubuntu is just purloined Debian underneath.

Open a terminal.

sudo su -

#apt-get update && apt-get upgrade
0 things to update. Nice.

#apt-get install steam
install 135 packages. sure. push enter.

Click “actives” type Steam

Wait for steam to self-update. Then update the run-time.

Sign in to steam. It is at this point the lack of a e-mail client on a minimal install renders the online account sign in a little moot. Use Firefox or whatever to get the steam authentication code.

In the steam client. Select Steam, then settings. Go to Compatibility. Enable steam play for supported titles and enable steam play for all other titles. Restart Steam.

Click activities. Steam. Open Library. Select Eve Online. Install. Local Drive. Install. Read the EULA ( firstborn and all derivative works for 100 years ) and click accept. Watch 622 Mbytes download. This should be

Steam Linux Runtime 3.0 (Sniper)
Proton Experimental
EVE Online

Apparently it will even download these over the network from other nearby computers. Nice.

Game gets the green ‘play’ button. Launching EVE Online. Processing Vulcan Shaders.

EVE Launcher running. Launcher shows ‘enter e-mail address’. I always hit cancel, because the eve launcher does NOT NEED my damn e-mail address.

Choose client installation location. Leave as default ( with its dumb but still legal / path separators in a windows path ) and select install. Accept the EULA again. Select “I already have an account”. The text box asking for an email again might flash red but thankfully it just goes to the ‘log into your account’ window.

Wait for 4.5 Gbytes to download. I will be right back.

BREAKTHROUGH

One of the more annoying problems with the launcher under steam & wine is its inability to communicate to a external program ( the browser ) to get an authentication token, then to pass that token back into the launcher. This image illustrates the issue nicely.

Notice how Firefox does not have a protocol handler for eveonline:// and it is prompting the user to figure out what to do with it? On windows and OSX this ‘association’ is set up by the eve installer. On WINE, this does not happen, as the eve setup is stuck in the WINE sandbox, effectively isolating it from adding the necessary bits the the actual host system.

The workarounds I know of were logging in directly with account credentials, or using Lutris to duplicate ( which I originally posted ) the WINEPREFIX sandbox. The first option is awful, since steam based EVE accounts should not need to be converted to named ones and the second option was unpleasant because installing lutris to run a steam game feels like having to fit a spare tyre to drive around, even though its not touching the road.

Still, the second approach was the closest to what happens on a windows machine. EveLauncher.exe runs and downloads eve. EveLauncher is also run by the browser, but with a eveonline:// argument when an account token needs to be passed in. Somehow this second mode of operation connects to the first and that is how accounts are added.

On steam, this is impossible to do via the interface, as steam does not allow two instances of a game to run. Adding the eveonline:// in as a startup argument does not seem to work, no idea why but I have a feeling it is deliberate.

How to get around this?

This How to run another .exe in an existing proton wine prefix · GitHub and then this How to run another .exe in an existing proton wine prefix · GitHub combined to form the minimalist answer I just got working of this wholly command.

FIRST RUN EVE ONLINE VIA STEAM so it is just sitting at the ‘logon to account’ window.

open a terminal.

$cd ~/.steam/debian-installation/steamapps/compatdata/8500/pfx
$STEAM_COMPAT_CLIENT_INSTALL_PATH=“$HOME/.steam” STEAM_COMPAT_DATA_PATH=“/home/elokentoralen/.steam/debian-installation/steamapps/compatdata/8500/” WINEPREFIX=$PWD “$HOME/.steam/root/steamapps/common/Proton - Experimental/proton” run /home/elokentoralen/.steam/debian-installation/steamapps/common/Eve\ Online/Launcher/evelauncher.exe “eveonline://callback?client_id=eveLauncherTQ&code=&remember=true”

where code= is the text revealed by pushing F12 in firefox and going to the debugger console. I would post this in full, though its plausible this would allow someone logon as
me.

To summarize.

I installed Ubuntu LTS 22.04.4
I installed Steam
I installed EVE Online
I waited for the launcher to patch
I was able to add my account ( the Right ™ way )

But was I able to play eve ?

I will tell you in a minute.

Nope, crashed horribly just after the ‘authenticating’ message showed up. Hmm.

To be fair it is a very old computer, GA-H55M-UD2H with a i5 3.2GHz CPU and a ATI R9 280. Ran EVE just fine when Windows 7 was still supported. :frowning:

Under linux the machine uses about 30% CPU just to start steam, starting the EVE Client will max it out the rest of the way. I’ll try it on a less awful computer tomorrow, but the overhead of linux seems to mean the minimum specs might be well under par.

No update on Linux, have not had time try it on my more powerful desktop.

Same, i can’t loggin in to my account

For those who still care, I did a full reinstall on my more powerful desktop ( i3-13100F, GTX1060, 32GByte RAM, 500 GByte HDD ) and I have been able to launch the game and load the Jita station interior. I tried to undock in a rookie ship, but i did not see the grid load until I was about 60km from the undock. I changed the client setting from on demand to full download and that seemed to help, but every time I jump a gate the client freezes. Somehow EVE Online in the new launher era is worse than it was on Pop OS at the start of the year.

I also tried PROTON_NO_FSYNC=1 PROTON_NO_ESYNC=1 %command% and that does significantly reduce the CPU load, but the client textures look to be very low resolution and are all messed up ( a magenta artifacting like they are not loading ) and does nothing to fix the ‘getting stuck on gate’ issue.

Just as feedback…no help to fix your issues:
I can easily run 2-3 clients on a 14 year old Phenom x6 1090T using an also old NVIDIA 750TI with debian and wine staging and vulkan. I use the closed source nvidia drivers. Your ATI card or its drivers might be the issue here.

Just a standard install of wine staging 9.6 currently, with “./winetricks corefonts msdelta vkd3d vcrun2022 dxvk2030” is enough for a working install.

So either it is your graphics card/driver or steam thats blocking you.

That is actually helpful, I have another machine with a 750 TI in it that is about the same age. I will repeat the process on that and see how it goes. I might have to check the drivers also, I did not do anything to ‘force’ the proprietary driver to be used.

Looks like the nvidia drivers were automatically included during the install routine setup. Changed the proton vversion to 8 and still getting a client freeze right after loading. Annoying.

I turned this machine off and went to a basketball game, so gone about 3 hours. Turn the computer back on and on launch got a ‘processing vulkan shaders’ and now once into the game, have managed to jump three gates without locking up. CPU usage is actually low too, about 18% though I did change to the preset ‘best performance’ after the second jump. I ticked the box for full client download, the circular swirl in the bottom left corner seems to indicate that additional content was needed.

Autopiloting to Amarr and back is not exactly a standard test but as good a test as any.

Jita to Amarr and back. No problems, CPU is in the high 20’s RAM usage is 9Gbytes virt, 4GByte resident.

Op Success?

Edit: Changed Proton to 7.0.6 Will have to try again with newer.

Edit: 8.0.5 worked also. Settings still on ‘Best Performance’. Will bump to 9.0 Beta and try again.

Proton 9.0 Beta worked fine until I reset the graphics settings. It seems one or more options set to High causes a huge jump in CPU usage and the game to stick/crash within a minute of launch. It is 100% this since the three prior trips to Amarr and back were flawless until this was changed. I am retesting this with everything set to medium ( though leaving on missile trails, etc to what the default was ) and doing another lap. I can accept that EVE Online on linux will not have all the bells and whistles, but it also means people running EVE Online in native windows are getting their CPU smashed as well, just the game isn’t dying horribly because of it.

Did not get far with everything set to medium. Gotta toggle things down to low one by one it seems. What a PITA.

Proton Experimental

Amarr To Jita and back, CPU stays about 30%, RAM 4 GByte, FPS is a steady 60. There is just some setting in the “quality” preset that hoses the machine. Its not any of the effects, though its possible that any number of the effects do nothing with the other details down so low. Toggling them up one at a time is going to be the way to go it seems.

1 Like

Glad you’ve gotten it figured out to that extent, at least. Thanks for sharing your steps, it’s definitely a lot easier for me to troubleshoot when the guys who’ve gone before are detailed in their descriptions of how they made it work.