Steam not launching

On Friday evening after restart my launcher updated.
All worked as intended for a few hours playtime but I’ve been unable to login since saturday.
Any help would be appreciated.

Linux Mint 20.02

Just ran Loglite via wine (which also refuses to load Eve) and got;
EnableNonClientDpiScaling() failed for HWND 0x10086 (120) (Call not implemented.)

Well it seems Steam has dropped support for Eve on Linux.
I purged my steam install and reinstalled it fresh to see if Eve would work.
Am unable to even download Eve via stream, it just errors saying “this game is incompatible with the software you are using”.

Looks like the windows (no pun intended) to playing eve on Linux are shrinking even further now…

Did you check the option to allow non-supported/non-tested games? I’ve never seen Steam refuse to install a game with Proton, even if it doesn’t work at all

I also can’t reproduce, I just tried with both the Beta and Release steam clients, everything worked fine. Make sure you’re using Proton 5 for the Steam version and that you have “Enable Steam Play for all other titles” checked under Steam->Settings->Steam Play

Using Proton 5.13 Eve downloaded but won’t start.
Switched back to Proton 5.0, I get the splash screen then nothing, splash screen comes up for about 5 seconds then just closes.
My Steam settings are the same as I’ve had them previously, Enable Steam Play for all other titles, Proton 5.0.
Might it be worth trying Beta release? Or am I missing something else. I’ve played Eve via Wine for nearly 10 years and can no longer get it to start either…

Are you able to tell what version of the launcher it is?

No, all I get is the splash screen for about 5 seconds then it closes.

is it related to this?

Was using proton 5.0-10 for the last few weeks since the last launcher failure. Now today launcher launched, and updated itself, stated ‘ready’, but the little buttons to click play next to character never appeared so no way to actually launch the game.

Tested 6.3-5, launcher failed to launch at all.

Tested 5.13-6, launcher failed to launch at all.

Tested Experimental proton; probably same as 6.3-5…failed to launch.

Tested 4.11-13, error occurred, time out.

Kind of getting frustrated by this. Literally nothing wrong with the game itself…the compatibility troubles are baked into the launcher. The old days of just running exefile.exe … sigh.

UPDATE Rebooted and tried everything again. 6.3-5 failed, 5.13-6 failed, 5.0-10 working again. I just don’t understand, but am happy it functions again without a lot of mucking about.

Considering CCP is no longer offering any unofficial support for Linux, seems steam is gearing that way too

UPDATE Rebooted and tried everything again. 6.3-5 failed, 5.13-6 failed, 5.0-10 working again. I just don’t understand, but am happy it functions again without a lot of mucking about.

Glad you got it working, but just FYI, none of the versions between 5.13 and 6.13 will work–the ucrt runtime change landed in wine in 5.13 and a fix didn’t get merged until 6.14. So once Steam releases Proton 6.14 or newer I imagine it will work again.

@Geo_Eclipse_Oksaras I doubt Steam actually did anything, it’s probably related to things breaking during the actual update process

Update. It seems that Steam in the Mint repository hasn’t been updated recently.
I installed Steam Flatpack via Apt and it works with Proton 5.0.

I can once again play the game I love and hate. :pleading_face: someone save me…

1 Like