Linux Ubuntu + Steam + Proton = doesn't works

Hi everybody,

I’m using Ubuntu, then Steam + Proton (the last version) i could install EveOnline, and have the “PLAY’s” button. But when i’m clicking, nothing excpecting…
The game don’t launch.

Some help please ?
To you,

Linux isn’t an officially supported OS per EVE Support: System Requirements.

Could move this to the linux section though so the “right eyes” can see it


1 Like

Moved to Linux - EVE Online Forums

Whow not sure what exactly you expect with such a posting… at least some kind of error message dump would be helpful for experts.

As I am not a sufficient expert, I can only recommend to simply install Steam and run it over Steam. Works fine for me :slight_smile:

Thanks for all your answers :slight_smile:
I’ll be gonne checking the Linux Forum.

Thanks you,
Best Regards

I’m running EvE successfully through Steam on Linux Mint on both my desktop and my laptop. Both are running it through Proton 5.0-10 using Dx11 settings.

The laptop worked pretty much out of the box.

The desktop has taken a little more work to get running, for reasons I don’t completely understand; I had to copy the launchdarkly pyd file from sisi to TQ (read this post: Client start exception after today update - steam [SOLVED] ), then add this to steam’s launch options: PROTON_LOG=1 %command%

After that EvE launched on the desktop with what I guess is a caching issue related to proton? I don’t know what the problem is, but my solution is to first try to open it under a more recent iteration of Proton, usually 7 or Experimental. That fails, then I switch back to 5.0-10 and it runs through a brief setup, purges a cache and then works just fine. Not an ideal solution, but a working one until I can figure out what’s actually going on and how to fix it.

My first recommendation to you is swap to Proton 5.0-10. That’s the last version of proton I’ve been able to consistently get it to work with. After that, if it still doesn’t launch, read that post and go searching to make sure the .pyd is in both sisi and TQ.

If you want more advice, I’d recommend being more specific with what you’re using, plus getting logs of the failed start and posting them here so someone more knowledgeable than me can go through and see what the actual issue is.

1 Like

There are a couple little dependencies that frequently need to be sorted; especially with Ubuntu and some derivatives.
I know I’ve had to manually load libqt5webengine or libqt6webengine as the launcher uses QT.
I’ve also had to load a PPA for fresh Mesa. The stuff shipped in Ubuntu is quite ancient. Try the Kisak PPA

Would like to return after a number of years absence and want to play on Linux and I don’t have a windows system.
I am running Ubuntu 23.04 Lunar upgraded from 22.10 if that makes a difference.
EvE Online is showing in my Steam library but the install option is greyed out and cannot find a way yo get Steam to allow me to install it. Even enabled experimental to no avail.
Installing via Wine also not working.

Is there a decent howto guide for installing EvE on linux please? The one on EvE Univerity is old.

Thank you

1 Like

Only Eve is greyed out or other games too, do linux native games like csgo work, can you start the install?

Try running steam from terminal and see if there are errors related to that.

Might be a issue with ubuntu 23.04. I don’t know but it should just work, like you install steam, enable steam play and proton experimental and install the game.

I see your post is old and you’ve likely figured this out already, but for anybody who hasn’t:

Right-click the game in your library and choose “properties”. If it’s not in your library, hit the gear button on the right side of the screen and choose “properties”.

Under “compatibility” check the box that says “force the use of a specific Steam Play compatibility tool”

Choose your proton version. Currently I’m using Proton Experimental, but a lot of people default to 5.0-10

If you have more bugs, post back here. I’ve also had to do one other thing to get the client to work, which is to paste the following command in the launch options.

PROTON_USE_WINED3D=1 %command%

I have the same experience and I would say it’s something on the O.S.
I still can play EvE from steam in my 22.04 but on 23.04 I cannot (same experience as you).

I checked If I enabled any “force compatibility” and I do not … so there is something that has changed on the Ubuntu thats preventing the steam to enabled the “install” (?)

If your problem is that the “install” button on steam is greyed out, then you need to enable force compatibility.

Or are you saying that with force compatibility enabled, it still doesn’t let you install?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.