Vanguard not working

Unsupported RHI or FeatureLevel inferred. This game must be launched with support for D3D12 and SM6.

Chosen: D3D12 (SM6)
Default: D3D12
Preferred: Not Set
Forced: Not Set (Not Set)

how do i fix this ?

2 Likes

I have the same issue even though an AMD machine with 48 gb ram, everything instead on NVMe M.2 SSD. I ran DXDIAG and can confirm I have D3D 12 with Shader module 6.4 and a 8gb Raedon RX580 card

Hi, I have the same problem. The latest drivers are installed.
Windows 10 LTSC 1809.
AMD Ryzen 7 2700
RTX 3070TI
16GB RAM

1 Like

Vanguard feedback/help is on Discord during the preview here: [EVE Online - Discord] there will also be a survey after the preview period ends, worth providing feedback there as well.

I was a DUST514 player. Really enjoyed it. I had very high hopes here. Thought I would get to at least take a look at Vanguard. Seems the idea ended with the same error message so many others are getting and I have to say;
"Unsupported RHI or FeatureLevel inferred. This game must be launched with support for D3D12 and SM6.

Chosen: D3D12 (SM6)
Default: D3D12
Preferred: Not Set
Forced: Not Set (Not Set) ":

Just isn’t as much fun as I thought it might be. It might be time to just stop believing and move on. Giving up is right around the corner CCP"
(exactly what does CCP ‘currently’ stand for?)

ANYWAY, I don’t think I want to play-
Unsupported RHI or FeatureLevel inferred. This game must be launched with support for D3D12 and SM6.

Chosen: D3D12 (SM6)
Default: D3D12
Preferred: Not Set
Forced: Not Set (Not Set)

anymore. IT’S BORING and certain to lead to another ‘death of a dream’ position.

2 Likes

That error is due to the lack of some component present in some recent Windows update available in the most recent build(s). I’m too lazy to do a deep dive for this to find out what exactly is the cause, but if you update to the most recent build of whatever compatible Windows version you’re using, it will be fixed.

…And then you’ll have to deal with all of the other issues, like terrible performance.

Not only this error… some prereq install is stuck in infinite loop… the error is from going to vanguard directory directly because it wouldn’t launch from launcher at all. :smiling_face_with_tear:

The install script just runs in loops… and for the record, where do you see some error reporting in this batch file?

: Copyright CCP Games. All Rights Reserved.

@echo off
@setlocal enableextensions
@cd /d "%~dp0"

call "..\Engine\Extras\Redist\en-us\UEPrereqSetup_x64.exe" /quiet /norestart
call "..\EasyAntiCheat\EasyAntiCheat_EOS_Setup.exe" -verify-and-install 3f3ce0dab1b14ac396f3bd3cb0b625d1
Unsupported RHI or FeatureLevel inferred. This game must be launched with support for D3D12 and SM6.

Chosen: D3D12 (SM6)
Default: D3D12
Preferred: Not Set
Forced: Not Set (Not Set)

The obvious question is why oh why isn’t the launcher checking for pre-requisites instead of trying to download 13GB of data, and restarting that from scratch dozens of times?? Data usage is about 90GB to download the 13GB …

And why is batch file, without error checking, used to install anything?

3 Likes

Man… I have the same issue. I got in once, and now its telling me that again.

I’d love to go on the discord and ask for help, but they require my phone number which is not ok. And really really lame. So unless EVE support wants to actually have support in appropriate support places, and not discord, there probably won’t be a fix we’re told about.

I also have a similar error. I’ve already tried everything but nothing helps solve it. I will not receive bonuses and will not take part in the test.

The “Unsupported RHI /SM6 inferred” does have a few workarounds, I e of them :thinking: involving the registry editor, I’ll link it below but anyway I found it more interesting that it has been a known issue for almost a year and effects several new games as the developers attempt to use the newest features available of which I mean DirectX12.1 and up but I’ll point something as one does. That the fix has been posted URE’s dev forum instead of made an update at all since is just funny to me. In an attempt to slow the want by game companies they moved and tweaked capabilities in different versions of Directx12 and 12.1. Dx ULTIMATE is the best way to get that functionality without playing with the registry on one’s PC. Mine came with DirectX12. 1 and shader model 6.6 had been in use without a problem until realized they could just not fix it and tell no one. lol. It has now come down to is a battle by software makers being of one click or another so likely there won’t be any further fixes.

So you can still enjoy eve online, and vanguard is still in early phases. Why cant you play? Not omega? Anti cheat not installed? Whats going on?

Mine won’t work but it says Easy Anti Cheat is not installed but I can play other games that require it (paladins, etc) and the installer located in the vanguard folder blinks open and close some kind of window but I don’t have time to see anything. it should be an easy anti-cheat window that says install or repair but I get nothing. Any ideas?

I got in, it was my issue had to reinstall windows. Working great now!

Unsupported RHI or FeatureLevel inferred. This game must be launched with support for D3D12 and SM6.

Chosen: D3D12 (SM6)
Default: D3D12
Preferred: Not Set
Forced: Not Set (Not Set)

How do i fix this¡? CCP…
unsuported

Really want to play this game

I’m having the same exact issue

Hey, sorry you encountered a problem with Vanguard. We’ve been adding to our official Vanguard Help Center to provide some fixes to the most common issues as well as a gameplay guide.

If you run into something that is not covered in the help center then feel free to reach out to support directly via an email to support@eveonline.com.