World audio completely gone [FIXED] | Arch

Hi all you Linux people.

So. I have an odd issue with the client. In all other respects , it works flawlessly. Decent performance, no glitching, or anything.
But. I have no “World Audio” when I’m in space. Well. I do have warp-effects and stuff, but no ship/space atmosphere. No turret sounds, cloaking sounds, no explosions… It is driving me mad tbh… At first is was just annoying, but over time it has become a more and more annoying.
Music, UI sounds, Aura, some station sounds works.

I’ve checked all settings. all as it should be.
I’ve tried proton versions 4.19 to 5.8-GE. I’ve tried Lutris’s versions of Wine. Stock Wine. I’ve installed the client in a new Wine environment.
I’ve tried a different sound-card.
The only thing I think i’m missing to try is another Kernel release.

I’m usually pretty good at figuring out issues, and give more to go on, but, honestly, I’m confused, since the issue is so stable, and that there is no other adverse effects.

System Info:
Operating System Version:
“Manjaro Linux” (64 bit)
Kernel Name: Linux
Kernel Version: 5.6.15-1-MANJARO

Video Card:
Driver: X.Org AMD Radeon RX 5700 XT (NAVI10, DRM 3.36.0, 5.6.15-1-MANJARO, LLVM 10.0.0)
Driver Version: 4.6 (Compatibility Profile) Mesa 20.0.7

2 Likes

Have you checked for sound at different zoom levels? I know on Windows when you are zoomed really far out you lose most of your sounds. You start getting more sounds when you zoom in closer to your ship.

Yes. All ambient sound, except those mentioned is completely gone.

You are not alone, I have had the same problem with sound over the last 2 weeks. I am am running it on a MacPro 2013 mojave 10.14.6. I was hoping that with the last two updates to have resolve but no such luck. I downloaded the launcher and tried from scratch as well and stil the same.

1 Like

Glad I’m not alone. That the bug is present across platforms seems to point towards it being a bug in the client and not the host system. Speculation though.

It’s a known issue since a few patches ago where there is no world audio in MacOS/Win7.

Turret and other world audio is missing for players running Windows 7 and MacOS

Both MacOS and Linux use Wine to run, so they share fixes… and bugs.

3 Likes

I’m on Linux, and submitted a ticket about (part of) this issue. They assured me that the problems are known and the devs are working on fixing them. No timescale given though…

2 Likes

Awesome. I suspected as much

Dang, so it’s not my gear…just switched to Mint from Win10, i love the system so far, installed Lutris version of EVE based on WineHQ wine version (due to gecko issues) , and IMHO the game works even better than it did on Win10, except for the world sounds…hope CCP will do smth about it asap.

When did sounds disappear for you?

Sounds have been missing for me as well around May 24 and I’m on Linux as well

I don’t remember exactly, but that sounds about right. I haven’t lost all sounds though, just a subset related to wormholes (AFAIK).

Sometimes i get like a burst of sound. But never more than a single second. I usually notice when running sites and stuff. Startled me more than once.

I’ve had this issue for several weeks on Fedora 32. At one point I lost music as well, but clearing Shared Cache and reinstalling brought that back.

1 Like

This is a known bug that affects Win7 and MacOS. (you have to read between the lines. win7/mac = wine = linux as well.)

No response other than “we’re working on it”.

1 Like

UPDATE!
[Patch notes link]

Audio:

  • Fixed an issue that caused World Audio, such as turret sounds and cloaking, to be inaudible for Windows 7 and MacOS users.

Please report here if the issue is fixed!
@Tenda_Adestur
@tnull
@Dravick_Afterthought
@Besonu_Isagar
@Voy_Putonsky
@Gravotto_Patrouette
@Kyra_Lee

1 Like

I’ve just tested this, and can confirm that the issue is indeed fixed on Linux Mint 17.3.

2 Likes

Also now OK on Mint 19.3.

Hi Colinde, How are you? I can confirm that the sounds are working on MacOs 10.14.6 as well.
Thanks for the update it is much appreciated!

I’m happy to report all sounds have returned for me on Fedora 32. Cheers!

I completely forgot to end this thread.

The Issue seems to be resolved.
Other than a few random sounds, that come our of nowhere once in a while, the issue seems to be resolved.
World audio is restored for Linux clients.

Thank you for all your replies and inputs to the thread.

Fly safe o7

1 Like