Alpha: Wine-4.4 w/ 64bit support

(CCP Bartender) #1

Hey all,

We’re overhauling our wine delivery pipeline as part of the work for the 64bit client. The mac environment needs a combined 32/64 bit wine and I have side-ported that work to linux too.

If you’d like to give it a spin:

  1. Set your launcher to beta mode
  2. Wait for it to patch to at least version 1500694 and restart it
  3. check settings->wine options->Use dev versions
  4. Set Dev branch to winehq-linux-binary (this is only available if you have the latest beta)
  5. Wait for wine to install and launch

Be aware that if you’ve done custom things in the CCP wine folder, this will replace them, and the replacement may not work. Only give this a try if you’re willing to re-create your old wine setup from scratch if it doesn’t work. This is alpha, and you’re the first testers.

Please check in with what distro you’re on, whether you’re using dx9 or dx11 and how it went!

2 Likes
(Halvorsen) #2

First.

Also, how is this dev-Wine-Version different from vanilla wine? Does it contain some eve-specific adjustments?

(CCP Bartender) #3

It’s not different. That’s the biggest change to the wine delivery pipeline. The last major revision of CCP wine, which is at this point very old, had a lot of custom patches in it. Some graphics card ID’s that weren’t in upstream wine at the time, a few custom patches to solve eve-specific graphics bugs, stuff like that.

At this point a lot of those custom changes have been solved in upstream wine independently, and we’re working at upstreaming some of the stuff which hasn’t made it. There’s very little left in our custom fork that we can’t upstream and that isn’t already fixed in newer versions of wine, so we’re jettisoning our custom fork.

Instead, we’re taking binaries from the winehq website, fiddling with their shipped libraries a little to make sure they work on the systems we target and then repackaging them so they can be installed by the eve launcher.

The alpha build this thread is referring to is really just this: https://sourceforge.net/projects/wine/files/Slackware%20Packages/4.4/x86_64/

Hopefully this will allow us to ship wine builds much faster. Instead of having to custom build them (and have something go wrong every time), we can just grab the most recent binaries, give them a quick QA pass to make sure no regressions have popped in and then “bless” them for delivery through the launcher.

4 Likes
(Elassus Herron) #4

alpha-testing is always such a … bracing experience!

It seems to run on my system, but now that I’ve closed and re-opened the launcher, it’s downloading wine again. Are you still rolling new builds?

UPDATE: OK, it turns out that alt-tabbing doesn’t work. When I go back to the EVE client, the window doesn’t come back up to full screen or grab the mouse. I only see a part of the screen in the upper left, and although I can move the mouse outside of that area, I can’t actually alt-tab back out again, and mouseclicks on what appears to be my desktop actually click things in EVE that I can’t see.

Since the “Log Out” button is outside of the area I can see, I can’t actually log out of the game. I have to use Ctrl-Alt-F4 to kick back out to a terminal and kill the wineserver manually (which additionally kills the X server, so I can’t get back to it).

Any guess what might be causing this?

(CCP Bartender) #5

There were several new ones after the one you tested on slack to solve the libwine issue, but not since last night.

It’s possible that the way I added the new build to the launcher is not good and thus it isn’t correctly persisting your wine choice between restarts.

(Elassus Herron) #6

No worries. It’s not downloading it anew each time. Just that once.

But now you see I’m having another issue, added above.

(CCP Bartender) #7

Yep, I can repro it here too. I’m not gonna look at it today, for the moment I recommend fixed window mode if you want to keep playing with the new build :slight_smile:

(Elassus Herron) #8

… Or I could just make sure TeamSpeak/mumble/whatever is setup before I log in for now.

No worries. I’ll fiddle around with seeing if I can get local wine to work again, and see about swapping back and forth between them to check for issues. But otherwise it seems OK.

Good work! Thanks so much!

1 Like
(das licht) #9

wow, wow and wow! this is truly an amazing linux client. everything is so smooth and snappy now. even without dxvk. i love it – thanks for your great work!
i think i’ll stick with it, 64bit seem to make a big difference!

(das licht) #10

Oh, i forgot:
I’m on ‘elementary OS’ running in ‘dx11’

1 Like
(Elassus Herron) #11

@CCP_Bartender, is this client already running the 64-bit wine? I thought that still needed a bit of tweaking to use a different executable?

(CCP Bartender) #12

The wine environment bitness and the client environment bitness are related, but orthogonal.

This wine can support both 32 and 64 bit windows applications inside it. The previous wine could only support 32 bit.

If you’re using this wine on TQ, you are running a 32 bit client inside a 32+64bit wine.

Later today there will be a 64bit mass test on sisi. If you join in, you will be running a 64 bit client inside a 32+64 bit wine.

(Aida Isu) #13

Ubuntu 18.04
CPU usage seems to be a bit insane now. Previously with 4 clients I would average ~70% usage. Now i’m averaging 80% usage with 3 clients, and running 4 clients is unplayable. Using dx9 or dx11.
I noticed this before I switched to the beta launcher and winehq-linux-binary, which prompted me to give this a go so it may not be directly related. Previously I was using winehq-stable, btw.

(elitatwo) #14

While that sounds cool, I am currently trying out the upcoming MESA 19.01 and the dx11 performance.

Looks like MESA 19 gets a nice push even without Vulkan libs.

I have re-appropriated Steam to install EVE and run with proton 4.23 to check MESA with Vulkan.
So if you like roller coasters and have an iron stomach, you should give it a go.

Surprise everyone, if you have a Steam account, you can run EVE with Steam and your account data.
Vulkan support is active and running by default but Steam runs its own wine libs, which are hidden deep in the Steam folder.

(Elassus Herron) #15

hooo boy I just loaded the client this morning, and man, something went really wrong. It took me nearly 20 minutes to get to the character selection screen, even though CPU load wasn’t any more than usual and there wasn’t any unusual RAM or disk use. And when I got there, the background was a garbled collage of stuff from my browser cache (including a mosaic of my discord page, some fragments from twitter, and a couple news sites) like some sort of google-AI recursive image soup. No visible text, the buttons were all blank. It was wild. When I tried to log out, I got a “Windows has encountered a serious error” popup and had to close out.

But when I started the launcher back up, everything was fine again. Far out.

Also, ever since I switched to the CCP wine binaries, I’ve been unable to switch back to my local wine. I’m using a shell script; is there anything that might be going weird?

o7
EH

(RakThorrak) #16

Ubuntu 18.04.2 LTS
Intel® Core™ i3-4010U CPU @ 1.70GHz × 4
RAM: 4GB
Radeon™ Software for Linux® 18.50
gpu: AMD Radeon HD 8670M
Running on an old laptop.Tried beta with the said wine version
missing texture patches all over the space ,nothing seem to be missing when inside structure,maybe its the driver idk for sure but everything runs good in dev branch winehq-stable version with release game version.

(bibble) #17

Participated in some SISI stress testing, with two clients on max settings (DX11). Client was stable and responsive throughout.
OS: Mint 18.3 (with kernel 5.0.15)
CPU: Ryzen 1700, 16GiB ram
GPU: Radeon RX 570, 8 GiB ram

1 Like
(CCP Bartender) #18

If this is the black cubes in space, it’s a shader problem with gas clouds rather than a texture problem I think. I might try pushing the linux dev build even further upstream and see what happens to this. Science!

1 Like
(RakThorrak) #20

So i take back what i said about everything was fine with release version on winehq stable, the same patches appeared on the space again the shape is kinda hard to explain.Also noticed these patches in the map on each of the solar systems when i zoomed in.So then i switched to the opensource driver
OpenGL renderer string: AMD HAINAN (DRM 2.50.0, 4.15.0-48-generic, LLVM 8.0.0)
No issue so far.
On a side note there is some serious fps drop when i launch the map so i keep it minimised all the time and i’m using the new map,this was the case even when i was using 32bit version,i’m guessing this is because of the not so great hardware spec.

(elitatwo) #21

Do you also have MESA 19 installed by any chance? It will be out soon and gives a nice performance increase.

Also, you should check if kernel 4.18 is available for Mint 18.3 (I am running Mint 19 with kernel 4.18) because it has newer AMD libs.

And try to clear your client cache (I use a cronjob for that, that deletes the cache folder every day at 12pm).