Alpha: Wine-4.4 w/ 64bit support

I’ve been running EVE via Wine 4.2 tkg build with DXVK and it runs okay. Will I get any performance improvement by running the Linux launcher?

Say what?

It “runs okay”?

Is a 400% performance increase not good for you?

A quick note on the performance, it does look like there is increased CPU usage with this version of wine under linux. I hope to be able to find ways to improve that although I remind people that this is a spare time project for me so I’ll do what I can but I can’t promise anything.

Despite that, it looks like this build is very stable across a wide range of distros and so I’ve elected to push it to release (happened yesterday) and make it the default wine because the old wines will certainly break once we push a 64bit client.

I’m choosing a performance hit over a crash for people who just want a plug and play experience. Anyone who needs high performance may need to look into a custom tuned wine, at least in the short term.

Oh cheers man, much appreciated!!

Are you using wine-staging, dev or stable?

If and please take this as a not super important suggestion and only if your spare time would allow it, could you take a look at DXVK libs for wine for Vulkan™ support?
DXVK are actually only 4 files that need to be exchanged with a special wine version that allows those DXVK files to be loaded to enable Vulkan™ support.

I bet that would even benefit mac os users and some older macs would spike a ton in performance by just adding Vulkan™ support.

What about partnering with Valve and working to improve Proton?

As I said in another post, I’m using Wine 4.2-tkg with ESYNC and DXVK, on Arch Linux, with Lutris. There’s a few issues but I got used to it: 1) it takes a while to load the industry window if you have too many blueprints and 2) it takes 2-5 minutes for the frame rate to stabilize itself after starting the game.

I’ve tried using Proton 4.2, Wine 4.4 and Wine 4.2-tkg and couldn’t notice a performance differente between them.

CCP does not support linux, and I’m not interested in attempting to partner with valve as an individual :stuck_out_tongue:

Currently the launcher is pulling down wine-staging-4.4 by default.

Re the DXVK stuff, the best way to speed that along would be to give me very specific instructions that I can follow to the letter and then immediately test.

I suggest the following:

  1. Allow the launcher to download the default wine
  2. Go to the wine folder in the shared cache (often something like ~/.eve/wine) and do a git init there, then add and commit everything to create a baseline
  3. modify the contents of the wine folder in place to have the patches you’d like me to implement
  4. Launch the client to ensure your modifications work
  5. Send me the git diff of what you’ve changed
  6. Tell me where to get the files that are shown as added or modified on the diff

Armed with that information, it should be fairly simple for me to make a DXVK testing branch and implement your patches, and we’ll see how it goes :slight_smile:

1 Like

Actually, I can just launch EVE Online from my Steam account, since Steam uses “proton 4.23” now, which enables Vulkan™ for all windows games.

And may I say OMG does DOOM 2016 look gorgeous with Vulkan™ at 200 frames per second.

This is really good, thank you!

Ubuntu 18.04.2 LTS (all default packages, no custom builds)
CPU: i7-4790K 4.0GHz
GPU: GeForce GTX 1070 (proprietary Nvidia driver 390.116)
Running under GNOME Shell on X not wayland.

First, with the default Release launcher, wine and game client: The launcher works and updates as expected, the game client starts but crashes with some X window exception as soon as you click on a non-ui component, ex. try rotating the ship view in hangar. Crashed every time so was unplayable.

Now, the new shiny Beta: The launcher and game client work fine, no crashes. The game client froze on me once in 4 days of use, so that’s pretty good. There are a couple minor issues:

  1. Launching Eve client breaks the GNOME Shell nightlight filter.
  2. Running on dx9 the performance is good but there are visible artifacts at the edges of explosion textures and some gate effects.
  3. Running on dx11 has pretty bad performance, low fps, many frame drops.

Thanks for the new version, now I can finally play on Linux!

ETA: I’ve found the cause, one of the updates had switched-off my ‘Use DX-9’ flag - I switched it back on and we’re working as before. I’ll leave my original post below in case anyone else gets hit the same way :-

Something has hit my setup pretty badly - Linux Mint 17.3, Not sure which Wine version. Without any changes at my end, my memory use for each client is almost doubled, and my FPS with just a single client is noticably worse - I used to be able to run 3 clients concurrently with no Swap file interaction, and without FPS dropping too much - now 2 clients uses most of my available memory and the FPS with just 2 is around 10. Additionally i’ve noticed that each client now takes 100% of a cpu full-time, whereas I rarely saw that before.

OK, so this is a fairly old setup lacking the most up-to-date version of the op-sys, but it used to be that Eve would run on almost any old computer - are we heading for a world where, to run Eve, you must have the latest and greatest gaming hardware ?

Could I get details on the X crash please?

At the moment there’s no difference between beta and release in either the launcher or wine, so it’s very odd that it would crash with one but not the other.

Had another oddity after downtime today - I logged-on and my FPS was down to 5. I went into the Launcher settings to check the DX9 setting was ticked and indeed it was. However, I had to un-tick and re-tick it again to get my FPS back up to it’s usual 30+. This suggests 2 things - a) Something in the down-time update cleared the internal flag which controls the use of DX-9, and b) The Launcher Settings page does not show the true state of that flag.

There’s definitely something strange going on with this DX9 flag. I usually get an FPS of 30+ with a single client running, or 20+ fps each if I’m running 2 clients and they’re both visible on screen. Today I had cause to leave one client running while I repeatedly re-logged the other one (re-arranging some skill-sets between 2 characters on the same account, with reference to information from the other account). Each time I relogged, the FPS for both clients went down a bit, after 7 or 8 relogs it was down to 5 FPS for each account. Bearing in mind my post above, I logged off the account I was swapping characters on and went into Launcher Setup. I unticked the DX9 box, left Settings, went back into Settings and re-ticked DX9. At no point did I log-off the launcher itself or the 1st account client. When I logged my 2nd account character back on the FPS for each account was back up to 20+…

Unfortunately I cannot reproduce it after switching back from Beta to Release and disabling the dev version of wine. So using the Beta / dev version must have fixed it. Are old logs (older than 4+ days / 10+ startups) stored somewhere locally so I could look for them? I did not save them explicitly when that happened…

First of all thanks for keeping us updated and alive :slight_smile:

Second, I just wanted to mention that before the patch… I could run 4 clients with 95% usage on my 4 cores. After the patch, I run 2 at 86% and it feels very heavy, at 3 goes to 95-100% and its worse than a slideshow.

I realize we don’t have support, and that we are not a priority, and we don’t really know if you will be able to fix this CPU usage problem, but thanks for trying.


Another comment about Steam:

Even though the EVE launcher enables the Vulkan™ api, there is something wrong with input devices.
You will have terrible frame drops whenever you try to spin your ship in a station.

Setting the dx11 down to dx9 removes that.

I found the cause - this new version puts a lot more load on the graphics, so I’ve had to reduce my in-game graphics settings considerably in order to stop my frame-rate bombing. Hopefully a temporary glitch, but I’m not sure that using all your linux gamers as involuntary alpha testers is entirely reasonable, even if we are officially unsupported…

I was wondering if its just a few of us who can feel the performance hit this update has done. I dropped down details, but running 2 accounts, it drove my cpu between 95-100 and its not fun to multibox that way, so Im thinking that untill this is fixed, I may have to cut off 3 accounts and forget about the pain that it is to run this as it used to.

I wonder if the mac guys are also taking a performance hit like I am getting. I guess, in a way, its good that it happened now, cause then I can simply not ‘resub’ the other 3 since I still have a week left, would have been worse to pay/plex 4 accounts to find out that I cant use 3.

1 Like

Something changed today, its slight but it is noticeable. Now I run 3 accounts and its using 95-100% usage on 4 cores, which is better than my last reply (2 accounts 95-100% usage). And it doesnt feel as heavy as last reply with 2 accounts. I dont see any news updates but something has changed for the better, YAY.

There is hope :wink:

Also the temps have improved, now with 3 accounts, with my cpu’s set for Performance (max speed), and at the aforementioned usage, the temps are stable at 49C, and GPU temp and fan speed is back to something more manageable.

Now, maybe a little bit more adjustment and ‘nirvana’ :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.