Any details on the new excel integration?

I have found that the formulas don’t update by themselves.
I created a macro which copy and pastes the formulas over themselves which seems to trigger the Add-in to refresh the cells.

Cell C2 has the formula =EVEONLINE.TYPE(A2)
With cells A2…A5051 having the type id’s for whatever you want to list.

Sub UpdateMarket()

’ UpdateMarket Macro

Application.ScreenUpdating = False
Sheets(“Market Prices”).Select
Selection.AutoFill Destination:=Range(“C2:C5051”), Type:=xlFillDefault
Application.ScreenUpdating = True
End Sub


I use the streaming formula for refreshing market orders every 5 minutes (let’s not be infogready)


I also use this formula


to get a row with all regions in one row and each in separate column

and in the next row i put that streaming formula with region id from cell above like that


Cell A1 contains type id of the market item
Row 2 contains regions
Rows 3 and below contains market orders for a given region in a column, it looks like this

This is a kind of mind blowing for me every time I use it :smiley:

Refreshing the formulas does trigger data download from Add-in but values stayed the same.

Its not working at all now #BUSY! everywhere

When I see that, I need to close and re-open the file. After that it loads the data. Have you tried that?
I hope there will be v1.1 with fixes …like soon™ :thinking:

It’s been 4 days and yet neither CCP or Microsoft has addressed the fact that it states support for perpetual excel office from 2016 onwards, those who have it can’t use it cause it will just create a #value! or #name? error .
I really hope they will either just come out and say, no it’s just gonna be office 365 support, or sorry we made an oversight it will be fixed with an office update pending. but sadly not even crickets to be heard.

And if I’d be bothered to login to ms website I’d leave a 1 star review for the add on.


Do you have language set to english in excel? If not, have you tried to? See my post in this thread

If that’s the issue it could be a temporary workaround until fixed?

I have switched excel to other language than english (latin and not latin based) and the add-in still works.

I have not tried to switch entire system to other language than english.

Hey guys, MS Excel Dev here

There was some confusion about the supported excel types as the true requirements weren’t relying on customsfunctions API but rather the ExcelApi since it introduced the data types / the fancy cards.

The minimun version for ExcelApi is 1.16 and for the next update this will be properly checked before the addin would display anything else in the sidebar, so users are more informed when they have a version that doesn’t support the required ExcelApi version. MS docs on ExcelApi requirements

If ExcelApi wasn’t in this version the most common scenario would be a #VALUE error on every single function provided since the add-in uses it almost exclusively to display data.

For updating formulas, most data is on a 1 hour clientside cache or a timer that matches the ESI cache timers. (They are often 1 hour so it’s the most common scenario), a common way to force updates is to have your functions rely on a reference to an active_character cell, and manually updating that single field will have the functions referencing update as well, even if nothing changed in them.

For market orders, like others have point out there is a _STREAMING version that will update every 5 minutes. But it takes more resources to maintain that auto-update limiting the number of formulas that can be updated before hitting ESI ratelimit bottlenecks or framework max concurrent requests.

Searching for data you might need:

  1. For items there is INVENTORYSEARCH that uses the ESI and requires a logged in character.
    *Next version is moving it away from ESI into static data so users do it faster and without having to log in a character to the sheet.
  2. SEARCHSOLARSYSTEMS returns solarsystem matching the string entered
  3. SEARCHREGIONS returns regions matching the string entered
  4. Station search (from SDE station list) is on the backlog. SoonTM
  5. CORPORATIONSEARCH uses the ESI to find corporations matching the string entered.
  6. ALLIANCESEARCH uses the ESI to find alliances matching the string entered

Web version has issues with ASSETS as web has a payload limit that assets can easily reach. It gets stuck on #BUSY and we’ve made Microsoft aware of this issue and how it tricks users that it’s running when it’s already been processed but the web sheet rejected the payload.

Corporation contracts have a logic bug in them that causes only couple of contract types working that’s being fixed next patch.

I hope these things answers some of the questions you guys have. Hopefully we can get the numerous update and fixes we’ve done out soon.
Feel free to pop into the discord spreadsheets channel where I can help with almost anything related to the add-in, or you might be able to find the question in there already (and hopefully already answered). :slight_smile:


Thank-you for this explanation.
This answers several of my questions, such as why some isolated data, changes from what I see from ESI, and won’t sync up for an extended amount of time.

I’m looking forward to the next version that drops ESI.

I believe that the non-web version also has trouble with ASSETS, but perhaps with a larger payload limit.
Your description seems to explain what I am experiencing.
I keep a lot of stuff inside station containers. Maybe it has a hard time parsing containers inside containers.

Sort of wish Google Sheets would be able to export my data

1 Like

I am a little confused, I have office 2021 version 2305 build 16501.20228, which atleast from the look of it looks higher than the required for api 1.16.
or does it mean with the second column that I’ll very likely never be able to use it as its not applicable


How often is the average price linked to =EVEONLINE.TYPE( updated? It has changed in game a couple of days ago but has not fed down to the Add-in Data.

1 Like

Is there no way to pull the total SP of a character using this plugin?
I can only see how to pull SP that is in a specific skill

Yeah, I thought there would be special skill named Unallocated or smth, to get this out… Like this:


or better yet, add search parameter to use it like this


then it would be possible to get a specific skill, without using FILTER


(where cell A1 contains character entity or character id)

Good note, it seems like there isn’t an expiring cache on this object in the builder of types so it’s most likely not being refreshed after it is first called upon from ESI through the get_markets_prices endpoint.

I’ve added this to the backlog to fix this (I’ll most likely go on a 1 hour cache timer matching the endpoint configuration).


Good note, the unallocated_sp is returned in the response but the builder for the output only loops over the array of skills to give to the list output. I’ll have this expose a fake skill entry called “Unallocated” so it’s exposed properly.

Adding a search_string parameter is also something I can do when I do that fix. Hopefully it can make it into v1.1 but otherwise it’s the next thing to be added into the patch after that.


With the release of 1.1 soonTM the plugin will be able to tell users if they have an incompatible version, but version where it’s “not applicable” don’t look great in terms of getting that Api supported later, it’s up to the Microsoft Excel team if that’s even possible in the future.

1 Like

ASSETS with more parameters and an optional paging option is hopefully going to enough for the time being to allow the exposure of all assets, even with more complexity in terms of displaying it.

If you have a lot of stuff in cargo containers it leads to the payload getting bigger since it’ll increase the size of each .location entity for each item that’s in a container. So it get’s easier to hit any framework limits of customsfunctions for outputting data when the assets are more nested.

The logic for outputting these nested containers is something that I tested a lot and hopefully managed to cover almost all the edgecases but if there is for example ever missing data that isn’t the result of a structure fetch that hit the ratelimit I’d love to know about it to improve the functionality.

1 Like

then with all due respect its a bad plugin if you need to have office 365 or that special perpetual license, especially seeing as how supposedly microsoft worked on it alongside ccp


One issue I’m facing is not being able to log in all accounts.

After you’ve logged in a decent number (30-40 or so), attempting to log in any more throws this error:

The exact same issue also has existed with the EvE launcher itself, but the quick fix was always just to delete the “C:\Users\username\AppData\Local\CCP\EVE\QtWebEngine\Default\cookies” file, after which you can then add more accs to the launcher.

Is there any way to do something similar with this plugin so all of my accounts can be logged in?

I’m in the same boat as others. I have a retail version of Office 2016 which, according to the ExcelApi requirement link posted above, means it should work. But it doesn’t.

I’ve tried using the online 365 version. It’s awful. Downloading information is completely erratic. Sometimes it downloads part of the information, then freezes completely. Very, very occasionally it manages to get all the information I need. Only a handful of times so far. But the majority of the time it makes the effort to gather some information then throws a “something went wrong” message, and refreshes the sheet. At its worst, it goes into an error/refresh loop that continues until I close it down.

It could be an excellent tool, but it needs a lot of work.