Any support for redhat distro/clones?


(Troy Chartrand) #1

i’m currently running CentOS 7 and would like to get back into game after my windows wipe.

if anyone using CentOS7/REHL7 or Fedora 29 (Bob forbid that it will work cross platform from the Ubuntu of the redhat distros) could maybe help me along a touch, it would be greatly appreciated.


(Whitehound) #2

The easiest way to start is to install WINE from your distro. If your distro comes with WINE 3.0 or newer, then you should be able to install and run EVE just like you do on Windows, but with one, minor work-around.

Once you’ve installed WINE do you need to choose where you want to keep your WINE drive and EVE. You do this by setting the WINEPREFIX variable. For example in your home directory under .eve:

shell$ export WINEPREFIX=~/.eve

Then you need to apply a work-around, because of a bug, which only very recently got fixed (with WINE 3.20). What you need to do is to set WINE into Windows XP-mode. You do this with the winecfg command:

shell$ winecfg

Once the window of winecfg pops up do you select “Windows XP” at the bottom of it.

image

If you have WINE 3.20 then you no longer need to do this.

All that’s left to do is to download and install EVE Online.

shell$ export WINEPREFIX=~/.eve
shell$ wget https://binaries.eveonline.com/EveLauncher-1381807.exe
shell$ wine EveLauncher-1381807.exe

Not every distro is the same however. Some may require additional packages. So do some not install the corefonts needed for WINE and require you to install them manually. Either check if your distro offers you a separate package for it, or you can install them using the winetricks command.

shell$ export WINEPREFIX=~/.eve
shell$ wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
shell$ chmod +x winetricks
shell$ ./winetricks corefonts

(When you keep using the same shell then you only need to set WINEPREFIX once of course.)

If all went well should you have installed EVE and also find an icon on your desktop through which you can start it.

Depending on the WINE version may you have to use DirectX9 and not DirectX11. DirectX11 is noticably slower than DirectX9 and anti-aliasing doesn’t work under DirectX11. This is a bug, which also only got recently fixed, although I cannot tell which WINE version after 3.0 fixed it. You can change the DirectX version in the launcher settings to EVE.


(Gharim Turen) #3

Please have a look at eve-launcher-build-1385477-beta-release-for-linux if you want to try the Linux Launcher.


(Troy Chartrand) #4

soo the linux version of eve launcher wont even fire up. nothing i’ve tried on that end will work. using wine itself i had to find a 32bit wine (tried making one and it failed aswell) from an extra available repo designed by a guy specifically for wine one centos 7. got the game installed, downloaded and patched and can get into the client but the launcher still fails to work properly and crashes. since i need the launcher to get into eve, i’m still stuck out. using the supplied 32 bit and the 64 in the centos repo i was able to build a functional wine wow64 and can get alot of nice things to work, except eve launcher properly.changing the settings in wine don’t make any difference no matter what i try.

sum= one last attempt downloading and installing certain fedora 29 libs to get the launcher to work preoperly is last remaining option. will update upon success.


(Troy Chartrand) #5

eve online is working through regular wine and the launcher set to beta. still have the occasional thing that doesn’t load but overall it’s functional and pretty. had to build up a fedora Xfce build which was hard because fedora don’t give alot of options to build from scratch like centos does but centos lacks the up to date libcxx libraries needed to run alot of things. so other than trying to manually install said C++ libs and have them kinda buggy, fedora took the win… :frowning:


(Troy Chartrand) #6

well, it works beautifly, problem is as follows:
after alttabbing either to switch accounts or to update/check websites like pathfinder, it becomes very very sluggish. not sure why, anyone have any ideas?