[August] Input Method Editor (IME) Code Cleanup

Hi there

As part of the release on August 11th, there has been a cleanup of the code that handles IME within EVE.

If you’re not familiar with IME, it allows for input of characters that are not on typical standard Latin based keyboards. For example, typing in Chinese on a US-105 keyboard.

If you’re a user that switches between different character inputs while playing EVE and you notice any issues, please let us know by filing a bug report.

1 Like

We have become aware that some 3rd party programs are having issues, Namely Sogou pinyin and QQ pinyin.

We are currently investigating these reports. Default OS based IME should be working as intended.

Edit - The issue lies with the 3rd party tools. We’re trying to reach out to the developers of these tools.

Edit2 - Sougou should now work with the latest update. Please update if you’re running an old version.

actually the default OS based Chinese input method are not working when i click IME

Hi
Could you provide more information? A bug report would be ideal.

When you say “i click IME” - what / where are you clicking this? We’ve tested Chinese input within Windows and not experienced any issues. I’m keen to get a reproduction that we can follow up on.

Many thanks.

Never used the IME in EVE before so I don’t know what I should be looking for but yeah it dain’t work.

I have the English UK keyboard layout, and the Microsoft Japanese IME installed. I can switch between them with WinKey+Space, or by clicking on the task bar.

When I switch to the Japanese IME in firefox, 日本語出ます、but in EVE, I still type in roman characters, with no IME conversion to kana or kanji. I’ve tried chat windows, the notepad, and ship name windows - none of them work how I’d expect, which is “at all”.

Windows 10.

1 Like

@CCP_Caffeine you there my dude?

Unfortunately myself, and numerous other players, also experience this bug while using Microsoft Pinyin.

@CCP_Caffeine Is there any news or updates regarding IME?

Thanks for the posts, I will follow them up internally.

Do you know of anything “unusual” with your setups? I know that’s quite a vague question, but anything which is non-standard we could investigate could be helpful.

As it stands, we’ve tested Japanese IME and it works as expected for us. The person who made the IME changes is a Japanese speaker who has checked it again.
We’ll do more digging on this - but please file a bug report. It includes useful system information in it, which may just contain something that helps us find the problem.

Your bug report was successfully sent and has the ID EBR-208132
To edit your bug reports, add additional attachments, and find replies from our bug hunters or developers you can access them on our website. Do you want to access them now in your default web browser?

There’s nothing weird about my setup at all. This PC is completely dedicated to gaming so doesn’t have any of my usualy weird oddities on it, and isn’t even in a VM. It’s very boring.

1 Like

I’ve done a bit of testing tonight on a clean Windows 10 machine and can get the Japanese IME working.

My steps were as follows:

  • Installed the Japanese IME through the standard Windows control panel application
  • Started the client in windowed mode. Fullscreen is fundimentally incompatible with MS IME
  • With the client focused, changed language using ‘Windows key + Space’ to “Japanese - Microsoft IME”
  • This didn’t alter the language in the client
  • With the EVE client focussed and a textbox selected (notepad, chat etc.), I Then clicked the “A” icon in the system tray to change the input type:
    image becomes image
  • The client now seems to use Japanese IME:

Could you let me know if clicking the lettered icon in the system tray alters anything for you?

Dunno if you can see my bug report’s text, so I’ll paste it here. God save the forum’s formatting code.

Description

As explained in the thread, the IME you can install in Windows 10 from the Region and Language section in the settings does not work at all in EVE. I have set it such that the language input setting is global across all applications, so I press WinKey+Space and I’m in Japanese mode, even if I Alt+TAB to Firefox or Notepad or whatever.

The language bar in the start menu has an icon for the current input mode, When there’s no text input selected, it shows a little grey cross and the IME is disabled. When in a text input such as Notepad, or the URL bare in Firefox, the grey cross changes to either a hiragana あ, or a romaji A, depending on whether the IME is enabled or disabled respectively.

Everywhere in EVE, it’s a grey cross, so the IME is completely unusable. EVE seems to handle unicode just fine - I can type in Notepad and copy paste it here, chat, ship names, the notepad, etc., but I can’t actually type with it.

Session Info:
Character: Xyfu (1261778055)
Solar System: Emolgranlan (30002548)

Reproduction Steps

  1. Install Windows 10;
  2. press Start;
  3. type “Region &” and press Enter;
  4. in the middle section on the right, headed “Languages”, click “Add a language”;
  5. scroll down to and click 日本語;
  6. click the newly added 日本語 option and click “Options” in the new expando;
  7. make sure “Microsoft IME” is present in the list headed “Keyboards”;
  8. close applications at will to satisfy OCD tendencies;
  9. observe the shiny new language bar in the start menu - it may read “ENG” or have a white “J” in a black circle in a white square - click it and select “Japanse\nMicrosoft IME”;
  10. open Notepad and observe the language bar’s grey cross has become a romaji A. Click the A to turn it into an あ;
  11. in Notepad, type “hitsuji” and notice it’s spelt “ひつじ” with an underline;
  12. press Space and notice that “ひつじ” becomes “羊” (probably);
  13. launch EVE;
  14. select any text input.

Expected:

  1. The grey cross in the language bar becomes a romaji A;
  2. switching to kana input works;
  3. typing Japanese words in EVE has some manner of IME integration - ideally in the text box in which I’m typing but plenty of games suck for this and Windows just has to draw the IME as a popover in the top left.

Actual:

  1. The grey cross in the language bar remains grey and cross;
  2. I am also grey and cross.
2 Likes

Beep boop. Would still like to shitpost in Japanese ingame. Would not like the thread to lock.

Well.

If you right click in a text area ingame, (maybe you need an IME installed too, I didn’t check), there’s an option to “Open IME”. Click that, and everything works perfectly and flawlessly - there’s even an IME popup at the cursor ingame which is amazing, it only resorts to the OS IME for switching suggestions between different kanji and such.

So.

Did I just always miss that option in the past or is it new? More importantly, why is the default state “make it so nothing works lmao”?

A fix has been made which will hopefully resolve your issue. It should go live on Singularity tomorrow and later this month on Tranquility.

This is the first time CCP Lease has posted — let’s welcome them to our community!

Welcome to EVE, CCP Lease! If you need any help or guidance in game, feel free to convo me any time.

:^)