Bug with research and invention?

I’m having an issue with T2 blueprint invention. I’ve researched and invented thousands of blueprints at this particular NPC station, but today every time I go to start an invention job it tells me “Your industry job could not be submitted” with the errors “The job cost has changed” and “The facility tax rates have changed”.

Multiple relogs have not been able to fix this, neither has clearing and re-verifying the game cache. I’ve never had this problem before. Any ideas on how to fix this?

I’ve even taken the blueprints to a different station and I’m still getting the same error messages.

I just submitted several inventions successfully in a structure, if it’s a bug it’s unique to NPC stations.

Now it’s back to working properly again. There’s no telling what the problem was, but it seems to have gone away for now.

1 Like

May be caused by lag on your end or game end. If the cost of the job ( system index , iev, or facility tax) change while you submitting the job, it will not be started. If you lagging, it takes a little bit more to your "start job " reach the server, then cost of job may change if a busy system.

1 Like

I have seen that happen once… fixed by itself after DT. Funny thing is that it affected only one alt.

i’m getting the same error. But waiting for DT seems a bit too long to wait

This has been a problem with me too, it seems to be related to lag.