Your industry job could not be submitted

Getting this error message today when I try to submit an ME research job.

“Your industry job could not be submitted”

(1) I have enough isk for it
(2) The blueprint is brand new (0 ME 0 TE)
(3) The Sotiyo has the required mods (I put a TE job on there before DT).
(4) I have enough research slots (using 1/10 at the mo).
(5) There are no input materials required
(6) I am at the correct station
(7) I have the blueprint in the station hanger, not my cargobay
(8) The job is < 30 days
(9) I relogged and it didn’t help

It doesn’t give me any error message apart from “can’t submit”. Can someone give me a clue please?

switch to another industry tab(jobs or structures) and back to blueprints tabs to refresh the isk cost.

It sucks, it happens often. It’s likely because the cost index was updated since you opened the blueprint window and your blueprint window does not know it so requests the job with an invalid fee : eg it know 1% price of a 100isk eiv job, and so ask to start the job with 1 isk cost, but actually the index has been changed to 1.01 % so the price allowed is only 1.01 isk, so your request fails when submitted to the server.
Basically just an issue of caching that does not reflect to window when updated.

If this does not solve it, then it’s another bug. Look at your log&message window to have a clue.

If still issue and no clue, submit a bug report (F12)

Yea tried all that, didn’t work. So logged out for an hour, logged back in and now it works.

next time please submit a bug report. The industry window is full of bugs and it’s a pain to handle it. Adding more data would help, or at the least show that those issues are actually annoying.

1 Like

Did you say your industry hand job couldn’t be completed? There are pills for that you know.

1 Like