Cannot Sign Into Accounts | Launcher CAPTCHA Fails | Steam & Linux

I have not been able to play the game for several months now. I took a break and then when the launcher updated a few months ago, my accounts required authentication. When I do so, the CAPTCHA fails, I presume because I am running the game through Steam and Proton on Linux.

I have not been able to resolve the issue myself or through online discussion forums or searches. I also opened a ticket with CCP, but that failed as well. I have played since 2009, but am now seriously considering giving up.

As one last ditch effort, I am hoping the community can provide some insight, particularly from Linux users who have solved this problem somehow or found ways to launch Eve without Steam.
I am running Fedora 36 (Nobara version).

P.S. I had been playing Eve on this Linux setup for about two years before this issue started without issues. I had my accounts added to the launcher, which launches with Steam and Proton, but not the Steam Linked account. In fact, the game ran better on this setup than it used to when I had Windows. lol

Thank you in advance for any help!

Remove and readd the accounts to the launcher is the only method that i know of when you have this problem. Unfortunately there are also a few people claiming that this also doesn’t work for them.

Also i have yet to read something from CCP acknowledging or adressing the problem.

I have the automatic captcha on launcher startup fail on my launcher with some consistency, maybe once or twice a week. It doesn’t prevent me from logging in, though the process of loading the launcher does seem to take longer when this happens.

Running Mint 21.3 and Proton Experimental, no launch options.

Thank you @Power_Armor for your reply. I tried it, but it didn’t work. I removed one of my accounts and now I can’t re-add it. Same issue with CAPTCHA.

Thank you @Hyperionus_Iapetorii for the context. I am running the same launch settings as you, just a different distro. But I cannot get past the CAPTCHA at all.

SOLVED!

I finally solved it (for now):

  1. Use ProtonUp-QT to install the latest version of Proton GE (At the time of writing GE-Proton9-7).
  2. Open Steam and change the Compatibility Version to the GE-Proton version you installed.
  3. Launch the game and re-sign into your account. It should let you past the CAPTCHA.

Note: If you have multiple accounts to sign into, you will need to log out of your Linux user account and log back in (between account sing-ins) until all your accounts are verified again.
Use this log out / log in trick any time you are met with a CAPTCHA failure.