Steam launcher still not working

With the ‘old’ launcher I was able to launch EVE from Steam and it would remember my (non steam) accounts. Now with the new launcher I have to enter my login details every single time I start the launcher. Can this please be fixed?

Thank you for the report, however I’ve been unable to replicate this issue.

I have the same issue on my side.

This wasn’t a problem the last time I played and meant getting in was pretty slick, even when I had to restart the client.

Is there something I can help with getting a reproducible case here? The client does remember that I’ve told it to not ask for the 2FA code again, it just complains with the following error:

Win10 10.0.016299 Build 16299

1 Like

Are there logs or something that we can provide to help remedy this issue? Please note, we’re talking about using the Steam launcher to log in a non-Steam account. Logging in manually works, but the launcher refuses to remember the login credentials. Also it will reset the assigned account profiles on occasion, but not always.

I’ve looked through the launcher logs, but it doesn’t appear that it has anything regarding sending login credentials to this point. I do see CDKey being referenced (likely a huge holdover from a long time ago?) but nothing pertaining to session tokens or otherwise.

The weirdest thing is so far I still haven’t had to provide my 2FA codes as I told it to remember.

Have you pinned the accounts?

I’ve pinned multiple times for weeks. After you get past the initial login screen, all of my pinned accounts appear.

Steam and CCP Auth don’t appear synced. The launcher is unable to detect that my Steam account is pre-authorized for my accounts and forces me to log in.

Doubtful this will ever get fixed.

I have the exact same issue. When ever I start the Steam Launcher it starts with “We are currently in the process of creating your EVE account. Please try again in a few minutes.” And does not remember my pinned non-Steam account.

Login in with my user details still works. Please fix!

Same here, bought sub yesterday couldnt login anymore. Thanks EvE, well I am refunding it. Going back to WoW wanted to give EvE a try but if its gonna be acting up like this 24/7…

The account is pinned, however you have to log in due to the error listed above.

You were able to log in here, are you unable to log in to account management outside of Steam? This doesn’t sound like the same problem (as the original issue lies with people who had accounts prior to Steam Auth integration). I’d recommend you consider checking/submitting a support ticket if you are literally being barred form logging into the client.

Disappointing to hear that you’re giving up so early.

I’ve had the same issue for weeks. I’ve had to re-enter my account info to log in every time. Only 1 account, but I cant use the other until I put in the info for my main account. Its a real pain!

Hey guys, The reason you are getting this error and then seeing the account after log in is very likely due to the fact that you never actually created a steam eve account, which for proper function, like buying plex, is needed.

If this gives the same error in the browser, try logging out of steam (in the browser) then back in. Still wont work, try this guys trick; “I went to help, then steam support, selected eve and selected to permanently delete the content. Then deleted it from the steamapp folder. Reinstalled and it worked after that.”
Once you create the steam account for eve, you will be taken to the proper launcher screen.


Just followed the steps from Pele above and then even the Eve website presents me with the same error!

Having this same issue - on the Steam launcher and website.

Oh, I’m glad its not just me, been having this damn annoying “processing of creating whatevs” thing for quite a while, started happening 2ish patches ago.

I hope we can get a fix anytime soon… this really sucks

I may have found a workaround. On my login screen there is a cancel button under the “Can’t create steam account” non-sense Clicking cancel goes to the saved logins.

It’s another button press but it’s better than having to relog every time to get to remembered accounts.

I didn’t notice that in the original poster’s image so it may have been added and no-one noticed.

hmm i dont have a cancel button…
i dont understnad why ccp doesn’t fix it, i cant be that hard

Yep, having the same problem here. Bought injectors through steam, because I thought I could just log in with steam to redeem them. But I just CAN’T get steam to set up an account at all now! I can ONLY play through the launcher. I’ve wasted my money.

Exactly the same promblem with difference that ive played via steam years ago already and now it doesnt let me log in saying they are creating account, although ive played on it before? Weird, well, seems like ive lost my money as well buying injectors prematurely, sucks to be me