CAPTCHA on the EVE launcher doesn't work

After a disconnect from the game, I closed the EVE launcher and now whenever I try to use the launcher it asks for the CAPTCHA verify. I complete it and it just pops back up again like it didn’t go through. I submit it correctly tens of times and the same thing. Here is a line from the launcher logs. Default browser is an update Chrome. I can also login into the game through browser game client just fine, even through the same CAPTCHA.

Hello Mate,

have you allready tried to fix the Cache permission and to veryfy the Cache data within the Launcher Options?

You can find the options here:

Yes. Just reinstalled again clicked all those buttons again, nothing. I am playing on the browser client, even went through the same CAPTCHA verify, no issues.

In this case it would be good, if you file a support Ticket u guess.

You can do this here

Yep I have filed a ticket, used the chat function on the website, and posted here too in case someone else had something like it happening.

In the launcher log file, I can see a line where there is conflict with some cookie that the CAPTCHA uses. So I cleared all my Chrome cookies, and I have no addons running. Even tried to switch default browser to Edge with no change.

Same probleme here. I wrote also a ticket.

I can no longer play on this acccount. CAPTCHA does not work via the launcher and only works in a browser which is why Im logged in here but can’t actually play the game. I’ve cleared everything, took their recommended steps, and even installed on anther computer fresh. Ticket filed.