Client start exception after today update - steam [SOLVED]

I think many have problems launching SteamPlay (Wine) games on anything later than Proton 5.0-10 on some distributions that’s why they stick to that version. It’s not by choice, Valve did a patch in 5.13 and they force later versions (you cannot pick minor point releases) that broke launching for many games. Mint specifically was one distro that was affected, and others perhaps.

So whilst it may be fixed in Wine later versions, that’s not an option for some.

I do think we’re now at a crossroads for a Linux native client rather than having to rely on Wine, as Mac no longer uses Wine. The divergence and cost of wine support will possibly increase going forward, it may make better technical sense to port the Mac native to Linux too as Mac doesn’t use DirectX either.

Work smoothly on Archlinux with 5.14.2.21.realtime1-1-rt kernel.

Funny thing Ive started to have same issue on Windows 11 after today update :smiley:

No longer works with Manjaro and Steam, the launcher no longer runs. The paths listed above do not match on my system …
In short, a little tired of struggling for hours to unblock the situation.
When will we see a true native client under Linux?

When Eve dies.

PS: Works on Proton 5.0-10 (Wine 5) on Steam and Linux distros derived from Debian->Ubuntu->??

Try using PROTON_USE_WINED3D=1 %command% if Vulkan doesn’t launch.

My launcher is working under the not so new method that Renard shared with us on the other thread, but now is asking for the exefile.exe which I remember seeing before there, but bin64 looks empty with just 3 folders and nothing else.

It kinda feels like CCP keeps sabotaging our hopes.

CCP cant you stay away from making stuff not work? if you are deliberately running us out… why dont you just say so??

:frowning:

Its like they gave a command to delete the whole folder contents. Its a good thing I can compare with my other EVE installations… my linux native install had 161 items and 5 folders in the bin64, why in hell is my current one, which was working wednesday… empty with 3 folders instead? Not only that, the TQ folder, had 12 files before, and now I only have the launchdarkly.pyd… which we set as read only, so thats why it survived.

I cant understand how idiotic the devs are being…

Is this also happening on windows?

Hey! So I hit the same wall you did. Copied that pyd file, read-only. Then launcher wouldn’t run at all. Uninstalled & re-installed. Started getting the exefile error. Uninstalled & re-installed a 3rd time, finally was good to go.

On that 3rd time I checked the SharedCache folder before actually launching the game, confirmed all the bin64/ and exefile etc. were all here. Copied them elsewhere in case they go missing again.

It has to be deliberate, I can’t see so many things constantly ‘going wrong’ without malicious intent.

My guess is that a launcher update triggered a cache refresh where it detected files that shouldn’t be there but that it couldn’t remove, so it errored out in a non graceful manner. I suggest unsetting read only if people keep running into this and seeing if that helps stop the temporary breakage.

FWIW I’m running a wine with the patches (so I don’t have to tamper with launchdarkly) and I haven’t seen this problem, so I’m thinking its because of the read only bit

Debian, Lutris, and it worked for me. Set file to unreadable and cancel any updates to the launcher

All seems to be fine now, but I also setup EVE in Lutris as well as Steam. So I can actually run accounts in either as long as not at the same time. Great for informing friends about the test server using one acc via Lutris while using steam with another acc. I haven’t remove the read only file mod to get this all working. also there was an issue with using hardware rendering but that seems to have resolved itself.

Been struggling to get this running since the update. Running Manjaro. Everything was dandy, I don’t understand why an update would suddenly break so many things without intent,

Edit2: Fixed it by renaming the CCP folder to oldCCP inside steam/steamapps/compatdata/8500/pfx/drive_c/users/steamuser/AppData/Local/

You can get your settings back by copying the eve_online_sharedcache_tq_tranquility from oldCCP/EVE to CCP/EVE

Im using Proton-GE 6.21

1 Like

Perhaps you’re holding it wrong?

You want your file set to unwritable (or read-only). Unreadable would be bad.