Connection Failure - Handshake Error


(Markus Reinhart) #1

I had a major update this morning (Win 10, I do it manually so others probably had gotten it days ago)

Since then I get the handshake error. I’ve tried every suggestion I found through google.

  • cleared cache
  • cleared settings
  • removed accounts and readded them
  • synched time
  • uninstalled, removed all EVE related data and reinstalled
  • waited till after downtime

Still nothing. I disabled the firewall, the traceroute works fine, checked for more windows updates, checked integrity with scf /scannow. I still get this every time and I need my EVE Fix, Halp!


Login Failed - Handshake error
(GM Mechanic) #2

This is most likely an issue with your computer clock and your time zone. You say you synced time, I’m not sure what you mean by that. But here is how I would do it.

  • Start the launcher.
  • Click on open settings.
  • Click on share cache settings.
  • Click on show in explorer.
  • Open tq folder.
  • Open bin folder.
  • Start logserver.exe.
  • On the logserver click on file and then on New log storage.
  • Go back to the launcher and click on start. Look at log server, some data should appear including the time. Check your computer clock. Do they match?

(Markus Reinhart) #3

Hey, thanks for the fast reply.

I do all that, then get to the “start EVE client” and get this error:
EVE

There’s MORE than enough HDD space left so that can’t be it. Clicking yes doesn’t fix it, If I click ignore I get a red message saying the client won’t start. Also the client can’t be stopped normally, I have to use task manager to kill it.

[edit]

With that last bit I checked the EVE folder, it was set to read only so I removed that flag from all sub folders and files. Still didn’t help.


(Markus Reinhart) #4

The log itself is displaying EVE time, ie 13:48. MY time is +2 so it’s 15:48

I DO see this:

Also this:


(Jacques Yvormes) #5

I’m not a programmer but to me it looks like the EVE server does not recognise the new Windows 10 build 1809.


(Jacques Yvormes) #6

Run the logserver as administrator, that removed the access denied-errors on my Win 10, build 1809.


(Markus Reinhart) #7

Thank you, that removed the issue with the log server. I’ll attach the log to the ticket.


(Markus Reinhart) #8

I uninstalled that build update and guess what, it works fine again. I’ll add that to my ticket and bug report and keep them open because it’s something that needs solving, if only because at some point I’ll want/have to update again.


(CCP Goliath) #9

To help us diagnose this further, please submit bug reports from our website, attaching your dxdiag file and mentioning your EVE and Shared Cache install paths in the description of the report. You can reply with the EBR number, or title the report “Handshake Error - FAO CCP Goliath” for extra bonus points.

Find shared cache - https://support.eveonline.com/hc/en-us/articles/213281985-Shared-Cache-Options
Generate dxdiag - https://support.eveonline.com/hc/en-us/articles/202079009-DirectX-Diagnostic-report-DxDiag-
Submit bug report - https://community.eveonline.com/support/bug-reports/

EDIT: Other useful info - running in a VM, bootcamp installation, illicit/unactivated copy of windows (we won’t tell)


(Markus Reinhart) #10

I have, temporarily, solved it by uninstalling Win 10 update 1809 so there’s really no point in sending all that info right now, as it’s working. But when I (have to) update again it might become an issue. It IS directly tied to that update.

Ticket number: 794003
Bug report: EBR-161557


(CCP Paradox) #11

I left the office and went home, just to try out EVE on my machine that has been upgraded to 1809 but was unable to reproduce the issue there. I’m in the process of updating my workstation to also test.

Your issue EBR-161557 does not contain a dxdiag file, or the LSW files. Could you please attach them there? Taking screenshots of them is unfortunately not the best solution to go forward with.


(Markus Reinhart) #12

I can do that but I’m not running 1809 any more. Which makes it pointless? If you think it’s still useful I will.


(CCP Paradox) #13

If you did not save them from version 1809 then yes it’s not going to be too helpful. However it will be helpful to have the information for both DxDiag and log files for when it is working for you. Since your environment did not function correctly after the upgrade, we will at least be able to know a bit more about how it is when it works.


(Markus Reinhart) #14

Turns out that I did save it last night (wasn’t exactly at my best at that point). So I have attached 3 files:

  • log file from when I DID have the problem (from yesterday)
  • log file from just now while it’s working
  • DXdiag from now, while it’s working

(Qiang Feng) #15

I have got the exact same issue since Updating to 1809.


(Markus Reinhart) #16

Windows update
View update history
recovery options
go back to previous version of Win 10

That solves it, for now.


(CCP Paradox) #17

Can you please try connecting to Singularity Qiang Feng ? And report your results on if you are able or not able to connect?


(Jacques Yvormes) #18

Support ticket opened - Log sent. Ticket number 795073.

JY


(CCP Explorer) #19

We are investigating this issue but we are not able to reproduce this yet. According to https://support.microsoft.com/en-us/help/4464619/windows-10-update-history then Microsoft has paused the rollout of version 1809 due to issues. We don’t know if and how they are related to these handshake issues. For the time being I recommend that you uninstall update 1809.