EFT (Eve Fitting Tool) for Onslaught


(Hirmuolio Pine) #61

Well I added a third version of the skill importing script that works for those who can’t register as developers.

When you use it you will need to log in every time you want to import skills. It will be less tested than the normal script as I am not going to be using it.


(Chaz Aa) #62

Looks like the gnosis is missing.

love you for keeping this tool up and running


(Chan'aar) #63

See my post further up this thread.


(Chaz Aa) #64

I read it but it just doesent reflect what Im seeing at all. Also while I can search for the other ships in the same line I get no results when searching for the Gnosis. I can also find the Sunesis and the Praxis the conventional way. The Gnosis though, its just not there


(DerekMcCoy) #65

re: EFT ESI importer,
Ignorant oaf here trying to learn what Python is and Powershell. Tried both and failed. I can get to the character login screen, but no further. For Python, I figured out what it is, downloaded and installed.

When attempting to log in a character, the UI stops at “Give your authentication code:”

Google Chrome opens the Eve character login screen. When I click “Authorize” the webpage changes to:

http://localhost/oauth-callback?code=6Bh1TB9…long string of text

This site can’t be reached
localhost refused to connect.

And that’s as far as I got.

I had no trouble getting EveMon updated and working using Localhost:4916/callback. I did figure out that a new oauth application needed to be created, so an independent unique account was created just for EFT ESI. Spent hours trying to figure this out on my own. Just don’t see what the problem is.

Thanks


(Hirmuolio Pine) #66

@DerekMcCoy
That is working as intended. The long string of text is the authentication code.
http://localhost/oauth-callback?code=6Bh1TB9...
Copy the 6Bh1TB9... part into the input field.


(DerekMcCoy) #67

Awesome! Thanks for the encouragement. I was probably too tired. Needed to add some path entries so Python and the Import commands could be found properly.

Thanks again!


(Fonsui) #69

Confirmed this missing behavior, as well as further investigated missing data - opening the ships.dat file with a text editor allows you to find entries for Praxis and Sunesis, but the file contains no mention of Gnosis.


(Peter Han) #70

A partial update for Into the Abyss has been posted, including the new Triglavian ships, weapons, and skills. Note that EFT’s automatic skill import remains inoperative since the decommissioning of the XML API.

Abyssal Mods are incomplete and not included in this update. An issue which caused the Gnosis to be hidden due to an ID collision with the Praxis has also been fixed.


(Satori Sartori) #71

I was very glad to see it got updated already. Great work!

Anyway, it’s a minor detail, but I would propose adding Filament effects. I assume it can’t be too complicated as EFT already features Wormhole effects, yet it will be a big QoL improvement for Abyss EFT warriors.


(DrysonBennington) #72

What we need is an app that would take the original values of the module before it was mutated then the values that were mutated where the app would then generate a read out of non-mutated modules that are comparable to the mutated module to develop a baseline price mark up for the newly mutated module.


(eshkoliminot loriko) #73

Kind time of day. Tell me whether the update dango application?


(Odris Meza) #74

Ty alot!


(Chaz Aa) #75

Well done. Thank you so much!


(Reileen Kawahara) #76

Ok I can’t for the life of me get this to work.

In lamens terms can you do some screen shots? I run the powershell but all it does is create a new blank config.

Does the code etc go inside the quotes and what goes in the brackets?

Thanks


(Jimy F) #77

Hi
Thank you for great work with EFT as always.
i write this in good intention, not for show that pyfa have it faster, becouse in my opinion EFT is Better,
one thing is people from pyfa prabobly have more time for this, to made some beta mutoplasids, so maybe if you take a look for this, it maybe help to do this for eft, one thing i notice is kinda need in eft, is that, some how, maybe like in pyfa when u slide on numder its show how many cpu or powet grid or giga jules per sec you have left not only how much in total are used and in total u have, and pure hp regen per sec, with active tank, and total tank, not ehp. and automatic sort ship’s fits by name


(Peter Han) #78

The July update has been posted. Only the ship rebalances to the Zealot, Claw, and Retribution are included in this update. Mutaplasmids are still under investigation, with much of my free dev time spent instead on EVEMon for ESI.


(Yornic) #79

Found a weird issue. When I try to add mid-slot items, they show up in the low slot boxes. When I try to add low-slot items, they don’t get added at all.


(Markus Reinhart) #80

I very much prefer EFT over Pyfa for a number of reasons. I’d to thank you for putting in the effort to make it work.


(DeMichael Crimson) #81

OK, I’m not a computer programmer, I’m just a user who’s having some serious trouble and hopefully some of you tech-savvy Eve players can help me.

A few months ago EFT was working fine on my Windows 10 HP computer but somehow the program got corrupted and stopped working. I tried to get it back working and ended up deleting it so I no longer had the original program with the EFT.exe code on my computer.

I tried the EFT 2.35 link in the OP of this thread and I got this page which nothing worked on it:

Thankfully the link posted by Tonto Auri worked and I got EFT back on my computer.

I then downloaded the update posted by the OP - Peter Han - and EFT is now current on my computer.

Now I had previously done a ‘Developer Application’ for EveMon so setting one up for EFT was easily completed. I then tried to follow the directions posted throughout this thread by Hirmuolio Pine to import my character:

Unfortunately like I said before, I’m just a computer user, not a programmer.

I basically have no idea how to implement the EFT - ESI Import script so I am now seeking help to get my character back on EFT.