Error while adding character to EVEMon

I hope this is the right place for this.

So I’ve installed EVEMon 4.2.0, I followed the guide at EVEMon for ESI - Configuring Client ID | peterhaneve.github.io to configure ESI, but when I try to add a profile, after choosing the character and getting an “authorization succesful” message from the EVE website, EVEMon repeatedly gives me this error:

ESI token could not be obtained.
EVEMon did not receive a valid response from the CCP SSO server.
Try again in a few minutes.

Could I have done something wrong? I added all the scopes, I put in the Client ID and secret key, I even tried turning off the firewall (to no avail). I’m using Windows 7 Ultimate.

This could be a local firewall issue. See if you have anything blocking EVEmon’s webserver port.

As I said, I tried disabling firewall completely multiple times. I’ve tried it on another PC and it kinda works, but the character data is incomplete and I keep getting an “Error logging in to EVE SSO” popup.

It displays my skill queue, market orders and kill history correctly, but there is no wallet history or assets. Sometimes it only shows cached data, sometimes it gives “Error querying character sheet” errors, it’s hard to add new characters, etc. Sometimes restarting the app seems to help a bit, but It’s very inconsistent.

I have no clue what may be the issue here. I tried deleting cache and settings several times as well.

Ok, it turns out I somehow installed an outdated version on the second PC (I thought I had 4.2.0, but it was actually 4.0.2), after updating to 4.2.2 everything seems to work fine. @Tonto_Auri Perhaps you’re right and I just missed some firewall setting on the first PC, gotta look into that. Thank you for taking the time to answer!