ESI: "error": "Character ID mismatch between request path and auth token"

For some reason I am refused access to endpoints on the ESI https://esi.evetech.net portal with the error code in the title. I am using this access from Excel Power Query, this same query used to work a year ago, I have only renewed the OAUTH2 keys.

The character id is from the account I used in the application, and the app has the permissions for the paths I am trying to access, but there seems to be some kind of mismatch with the token…
Any idea?

This happens when you are requesting a resource for a character, e.g. /v5/characters/123/assets/, while using a token that belongs to character 456 or vice versa.

I’d ensure your OAuth2 flow is still up to date based on SSO Authorization Flow | esi-docs. Just going thru the flow for that character again should be sufficient.

Hey all! I’m just getting started with ESI. I am getting this same error when just using the “Try It Out” options on the Swagger Interface itself. Is that just a bug that will be solved when I handle the tokens in my own app?

FYI: I’m trying to capture all of the responses to build a data structure before I start actually pulling in data to the app.

Thanks!

Does the character_id you’re putting into the form match the character you authenticated with?

You can see the schema for each response via the Model button. E.g.

Which tells you the name, data type, and if it’s required or not.