EVE Installing

Here’s the link to the launcher log:

https://pastebin.com/azgPFf3b

And here is the launcher log when I toggle off “Run clients with 64-bit”:

https://pastebin.com/0V7yYcNS

On both logs you have the same error, the used wine environment are only 32bit but eve need a 64bit wine prefix:

"0009:err:module:__wine_process_init L\"C:\\\\tq\\\\bin64\\\\exefile.exe\" 64-bit application not supported in 32-bit prefix"

If you have wine-stable from WineHQ with all dependencies and recommendations installed should this not be the case, except you have used an older wine prefix and them only updated to the actual wine version. If the old wine prefix was only 32bit before then wine updates only the 32bit part nothing more, so you missing the 64bit part in this wine prefix and eve cannot launch.

Please remove following directories if they exists:

rm -rf ~/.cache/CCP
rm -rf ~/.config/CCP
rm -rf ~/.local/share/CCP
rm -rf ~/.local/lib/EVE
rm -rf ~/.eve

After this you can start with a new installation. Have a look into /opt/wine-stable/bin if there a wine64 executable exists. If not i would recommend install winehq-stable which should fulfill all dependencies when you prefer the stable branch from WineHQ.

Got it working after following these instructions to install wine. Not from WineHQ, but in the yellow box at the top:

https://wine.htmlvalidator.com/install-wine-on-ubuntu-20.04.html

I can get EVE running fine, but I’m having trouble with performance.

Here is my setup:

Linux Mint 19.3
Ryzen 3600 with 8GB DDR4
RX580 8GB

Using the ‘Linux client’ or a Windows client seems to make little difference. DX9 performance is pretty good, 60 fps most of the time with a few 45 dps dips. But dx11 performance is REALLY substandard, struggle to get 60 fps even just sitting outside with max settings. With more scene complexity the FPS goes down to 25-35, usually settling at about 35-40. I have vulkan installed and dxvk running with wine 5.0.

I really don’t want to keep installing EVE on steam, proton or whatever when the result is probably the same. So why is my performance so bad? The only client that works smoothly for me is dx9 using the older wine builds…

@Maktina
My setup is extremely similiar as I’m on a slightly older Ryzen and an RX590.

If I set interval to immediate I instantly get between 180-190 fps. Even under heavy load in Jita with interval set to 1, it solidly pegs to 60fps same as my monitor refresh rate.

I prefer the plain windows client over the linux one, but even better is the steam/proton as it helps blend in some tweaks with dxvk and such which drastically improves performance. Even on an older machine with older videocard it generally improved 60% or better. I’ve tried manually installing vulkan, mesa and wine5 and still had abysmal frames like you speak of. I have no idea why it seems better on steam but it does.

DX11 is far superior now using anything wine 4 or 5. The only thing you might be missing is mesa-vulkan?

After a long time i have updated my script package to version 1747682 (Thanks to @CCP_Bartender for his hard work). Now is it possible to use the QT libraries from the system again as long she are version 5.12 or newer. Another update is the integration of installation from DXVK version 1.7 (dx11 part only, dx9 has no advantages over internal wine dx9), so no fiddling with winetricks or other console magic are needed anymore.

If you want to update from older versions of evelauncher is it possible, that evelauncher crashes on the first launch because of a incompatibilty of qtwebengine to older versions. To avoid this remove following directories

rm -rf ~/.cache/CCP
rm -rf ~/.local/share/CCP

This will delete cached files from the evelauncher user interface and stored eve login credentials if they exists, so you must login again.

Downloads can be found on the usual place on AUR tagged as evesetup as always.

– fly safe o7

1 Like

The other thing that might be confusing in this update is that the launcher had a bug where when it closed for update, it didn’t actually close because there was a hanging thread in the background.

That meant the undead launcher had exclusive hold over the settings files and so when the updated launcher started it seems to have forgotten your accounts. If you kill all launcher instances from the task manager and start it again, all your accounts are back.

Unfortunately, because it’s a problem with closing the launcher, and you have to close the launcher to patch, the issue happens one last time in the process of rolling the fix out :crying_cat_face:

I try to install eve based on the wiki.eveuniversity.org/Installing_EVE_on_Linux
I put evelauncher in a folder Games on Manjaro (arch linux). On launching evelauncher.sh I get:

Language selected based on system locale: “en”
QObject::startTimer: Timers can only be used with threads started with QThread
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (8 8 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 8 8 0)

qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
Could not initialize GLX

Then a memory dump on aborting. I found out that my current version of qt installed is 5.15.0 and that in the evelauncher folder I find 5.12.0. (coredumpctl gave the information that things went wrong in libQt5Core.so.5.12.0 0x8615d). Can I specify evelauncher to work with qt version 5.15.0 in my /usr/lib, a new version that does (got the version evelauncher-1747682.tar.gz) or how I can try to get it to work? I would love to install it without having to use wine.
(PS: I’m new to Linux: had it for a week now so I’m on a steep learning curve atm)

I found out a little more with the qt debug and I hope someone can help me further

remark: the file libqxcb-glx-integration.so (file does exist, just the configs aren’t):

…everything that works well, then the last lines before the problem occurs
FactoryLoader::QFactoryLoader() checking directory path “/home/oene/Games/evelauncher/plugins/xcbglintegrations” …
QFactoryLoader::QFactoryLoader() looking at “/home/oene/Games/evelauncher/plugins/xcbglintegrations/libqxcb-egl-integration.so”
Found metadata in lib /home/oene/Games/evelauncher/plugins/xcbglintegrations/libqxcb-egl-integration.so, metadata=
{
“IID”: “org.qt-project.Qt.QPA.Xcb.QXcbGlIntegrationFactoryInterface.5.5”,
“MetaData”: {
“Keys”: [
“xcb_egl”
]
},
“archreq”: 0,
“className”: “QXcbEglIntegrationPlugin”,
“debug”: false,
“version”: 330752
}

Got keys from plugin meta data (“xcb_egl”)
QFactoryLoader::QFactoryLoader() looking at “/home/oene/Games/evelauncher/plugins/xcbglintegrations/libqxcb-glx-integration.so”
Found metadata in lib /home/oene/Games/evelauncher/plugins/xcbglintegrations/libqxcb-glx-integration.so, metadata=
{
“IID”: “org.qt-project.Qt.QPA.Xcb.QXcbGlIntegrationFactoryInterface.5.5”,
“MetaData”: {
“Keys”: [
“xcb_glx”
]
},
“archreq”: 0,
“className”: “QXcbGlxIntegrationPlugin”,
“debug”: false,
“version”: 330752
}

Got keys from plugin meta data (“xcb_glx”)
QFactoryLoader::QFactoryLoader() checking directory path “/home/oene/Games/evelauncher/xcbglintegrations” …
loaded library “/home/oene/Games/evelauncher/plugins/xcbglintegrations/libqxcb-glx-integration.so”
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (8 8 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 8 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (8 8 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 8 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 8 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
qt.glx: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
Could not initialize GLX
./evelauncher.sh: regel 16: 18703 Afgebroken (geheugendump gemaakt) “$dirname/appname" "@”

It’s time for another update for my script package. The nasty details of this update you can find on AUR under View changes ( i’m too lazy to explain all of it here again :wink: ). The only issue which i have atm is evelauncher leave one instance running on close, but this issue have all builds of evelauncher even on linux, steam on linux or windows as far as i know . The only solution for this on linux and steam on linux are killing remaining evelauncher instances with killall evelauncher at the moment.

– fly safe o7

1 Like

You cannot run EVE Online on linux without using wine. Wine are essential for all linux installations of EVE because eve and his libraries itself are windows binaries and needs the wine layer to run.

The linux version of evelauncher delivers a customized wine runtime which are downloaded during the first launch and will be used per default but i recommend the wine package from your linux distribution.
Have a look in this forum how to setup using another wine version instead the default one.

The error during launching eve itself on your installation looks for me, that you have missed to install some drivers and support libraries for your graphics hardware. Under Manjaro use manjaro-settings-manager to install the proprietary part for your graphics if you use nvidia hardware (nouveau driver doesn’t work with eve). If you use AMD hardware you need drivers especially for your device which you can found in manjaro-settings-manager too (vesa driver or fb-driver doesn’t work with eve). Furthermore install mesa which are needed for non-nvidia hardware afaik.

HTH :slight_smile:

I got it up and running. Thanks Gharim :slight_smile:

Hi Everybody.
I am back here after some time after my last issue brilliantly solved by @Gharim_Turen on XBC libs.

I am back because now I have a new problem and I don’t find documentation anywhere again.
I was happily playing Eve when I had the idea of installing Steam to play to Kerbin Space Program.

Steam required three libs to be installed:
libgl1-mesa-dri:i386
libgl1:i386
libc6:i386

Now launcher start and I can log in but as the information box states “Done processing bulk data”, at the screen of the character selection I have black screen.

Hitting the x on top right appears the box to confirm to exit the game as normal.
I seek advice, thank you!

Thank you for your time, I wanted to let you know that I have fixed the issue.
Resetting cache and using internal wine configuration tha client started as good as before!
See you in space!