EVE Launcher build 1385477 beta release for linux


(Kitten Ripper) #162

Read through the thread and you’ll notice that some had to delete the xcb library, which comes with the Linux-native launcher, before it ran on their distro. Seeing how you’re having an issue with the same library would I suggest you try this first. Find the libxcb.so* files of the Linux-native launcher and rename them or remove them. Alternatively try to change LD_LIBRARY_PATH to put your distro’s library before the launcher’s version. Whichever works for you.


(BlintWave) #163

Hi all, just want to say that this version of the Linux launcher works just fine on Debian 9.6. I just did a clean install of Debian Stretch ( also installed WINE according to this, dont know if it matter tho ) and installed EVE Linux Launcher following UNIwiki. Keep up the good work Devs… :wink:


(Andris Arickson) #164

Centos 7
nvidia-driver.x86_64 version 3:410.78-4.el7
Old launcher works but won’t update or add new accounts
new launcher gets the same error as the Snorlax launcher when it tries to update.
GLIBC is the wrong version and it’s not available on Centos.
So I’m going to have to update to Fedora 29 and get everything working again.


(Andris Arickson) #165

I’m on Fedora 29 / 64 bit now but having trouble getting the linux launcher to work properly.

I’ve tried installing the 32 bit counterparts to what I think I need but starting from scratch is hit and miss. Then I installed the .i686 counterpart for everything in my OS.

I can log into the launcher and into the game, I can log in to one of my characters and open and close windows inside the client.

As soon as I click on the client screen and not on some sort of window control, ship or other thing the client crashes.

Log shows:
last yellow errors:
Tr2ImageHandler failed to create texture ‘res:/texture/fx/flares/flarex_01a.dds’

red errors
2x: No dynamic constructor found for resource name, dynamic:/inspacevideos
and
STACKTRACE #5 logged at 12/19/2018 22:14:48 : Unexpectedly got shipID = None

which is better than it had been as the previous error I got with this was nonsense.

In the terminal I’m launching the evelauncher.sh from there are ssl_transport_security and secure_channel_create errors so I’m not sure there what is going on.

when the client crashes I get:
Server started
QWidget::setLayout: Attempting to set QLayout “” on QWidget “tableParent”, which already has a layout

so perhaps I’ve missed a Qt dependency somewhere along the way.

anyone got some ideas where I can look next?


(Elassus Herron) #166

Anybody else having issues with whatever changes went through with the launcher at today’s patch? I can’t add any account: when I give username and password, and then my 2fa verification, the SSO window disappears, but the main launcher window gives the error, “The code verifier, associated with your account, could not be found. Please try logging in again.”

I can log in to the website, using 2fa, just fine.

Anybody else?


(Tyrannee) #167

Yes, I’m getting exactly the same thing.


(Andris Arickson) #168

got the The code verifier, associated with your account, could not be found briefly but was ok after downtime and I could log in again.


(Nana Otomeya) #169

I’m getting the same problem and it is still persising. My ‘Absolute’ injection Augmentor booster is going away…


(Elassus Herron) #170

PSA: update, thanks to CCP Bartender: the Linux launcher build was quite old, and missing a necessary protocol for the verification check to work. Thanks to his quick work, the launcher has been updated to a more recent version, and should now work.

you will need to re-add accounts, as the beta launcher does not carry over pinned accounts from the Release version. You can also (for now) switch your launcher version back to the Release version and re-gain the accounts, and also log in with that as well.

TL;DR: issue should be resolved now. Thanks to CCP Bartender and CCP Avalon for looking into it for me, and fixing it so quickly. <3 <3 <3


(Tyrannee) #171

It works now - all hail CCP Bartender!


(Lou Lingg) #172

after upgrading to the latest Xubuntu distro last night, i can no longer launch the game client. I can log into my accounts with the launcher, but attempting to play the game results in the game client dying as soon as it opens a window.

What can i do?


(Tyrannee) #173

To start you need to look into it a bit and post something about what’s actually going wrong. Is there log or terminal output which gives a clue to what failed?


(Lou Lingg) #174

nothing in terminal. terminal is open because that’s how i’m running the launcher.

i did find logs in ~/local/share/CCP/Eve/launcher but i dont know how to make sense of them, and i suspect copy/pasting several hundred lines of output would make me zero friends here lol

this, however, is about a dozen lines from the bottom:
“X Error of failed request: BadWindow (invalid Window parameter)”


(Andris Arickson) #175

NVIDIA 415.22 and 415.23 both have client crashes on screen click, menus and interaction with client works, just not clicking on blank parts of the client when logged in and in game.

Nvidia released 415.22-1, 415.22-2, 415.23 and 415.25 in pretty quick succession so I may have to roll back to the long release 410.78.

Still experimenting.


(Andris Arickson) #176

New and improved, coming to a theater near you.

Fedora 29 64bit install with MATE GUI

Wine 4.0 .rc2 comes default as of the date of this post

Install every 64 bit and 32 bit package under the sun … literally took a list of every package on my wife’s Centos system and installed them, one after the other. around 5000 packages or so.

linux launcher works but can only run one client at a time and if you click on blank space inside a logged in client it crashes without a useful error.

Nvidia 415.25 binary driver manually installed (os is actually only using a 415.22 buggy version)

Install winetricks and install the usual metric ton of extra things

winecfg to winXP

Install windows launcher and run.

works like a charm so far

no linux launcher for me for a bit and I’ll just have to work out how to transfer my profiles over from my linux install, a much easier problem.


(Cassandra Colizza) #177

Since my latest updates, i cannot start neither the linux launcher, nor the beta launcher.
Both do not start with the message

./evelauncher: symbol lookup error: /usr/lib64/libGL.so.1: undefined symbol: xcb_dri3_get_supported_modifiers

I already tried prepending the ld_path, removing the libraries from the launcher dir, which are found in system…

I am starting the launcher with evelauncher.sh.

Gentoo stable
ldd shows no missing libraries.


(Gharim Turen) #178

On my system (Ubuntu 18.0.4.1) are this symbol in /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0.0.0 and /usr/lib/i386-linux-gnu/libxcb-dri3.so.0.0.0 defined but not in the library libxcb-dri3.so.0.0.0 from both eve launcher versions. Both launchers works here with or without the delivered xcb libraries when i set LD_LIBRARY_PATH. Maybe has something changed on your graphics driver since the last update.


(Elassus Herron) #179

/usr/lib64/libGL.so.1 belongs to mesa; what version are you using? Also, what wine (packaged or system? staging or vanilla?) do you have.

I have ~arch 64-bit gentoo, and aside from the issues with the old launcher build not handling SSO, I haven’t had too many problems (aside from the occasional system freeze and broken shaders, but the latter is wine’s problem).

What graphics card and what driver? What kernel?


(Cassandra Colizza) #180

I am running ~arch 64-bit gentoo on both my machines.
The laptop is running with the internal Intel HD 3000 and the in kernel i965 driver for quite some time.
I made no changes on the kernel configuration during the update.

The issue came with updating to:
kernel-4.14.83
mesa-18.2.7 from 18.1.9
wine-vanilla-3.0.3


(Lexie Huren) #181

Distro: Debian Stretch with Raspberry Pi Desktop.

It didn’t start. After doing the chmod stuff, then trying to run it, I get: bash: evelauncher.sh: command not found