EVE Launcher build 1385477 beta release for linux


(Dravick Afterthought) #141

I tried that but didn’t get very far - what’s your Linux/Wine environment please ?


(Whitehound) #142

Debian Buster aka “Testing”, WINE 3.18, Nvidia 396.54.09, DXVK 0.90

All I need to do is to set WINE into “Windows XP”-mode with winecfg. The rest works out of the box. I use the Windows-native launcher and I don’t touch the Linux version. It’s been working like this since before WINE 3.0 and apart from minor glitches has it been running out of the box (with the changed mode) ever since.

Steam Play aka Proton is also running fine for me. Same thing here, where one has to set WINE into “Windows XP”-mode before it runs, but then it again runs out of the box and even includes DXVK.

You’ll find some more detailed info here:




Debian 9 - Can't install libssl1.0.0 - launcher does not launch
(Dravick Afterthought) #143

Thank you for all that - I can see what I’ll be spending my weekend doing :slight_smile:

Hmm… How do I tell what version of Wine I’m currently running ? It doesn’t seem to have a ‘Help About’ anywhere ?


(Dravick Afterthought) #144

I’ve downloaded the latest stable Wine and installed it, but it doesn’t add any entries to the Mint program menu. I’ve found the Wine configurer and set it to default to XP, but I can’t see how to actually do the install of the Eve launcher - any suggestions ?


Launcher (Linux) update fail
(Whitehound) #145

The WINE version can be seen with winecfg and when you go there into the About tab.

Do the folowing to set up EVE from a shell, assuming you’ve downloaded the Windows installer:

export WINEPREFIX=~/.eve           # set this to where you want to keep the game
winecfg                            # set WINE into "Windows XP"-mode
wine EveLauncher-1381807.exe       # run the installer

This will install EVE and you can start playing with DirectX9/11 over OpenGL.

For DXVK (DirectX10/11 over Vulkan) see the info above where I’ve detailed the steps needed to get it running.

When you want the least amount of work, but with DXVK, then choose the Steam set up. Steam comes with its own WINE version, some extra patches, plus DXVK. The steps for Steam are also described above.

The common issues people encounter here are the missing “Windows XP”-mode and missing 32-bit WINE components and missing 32-bit graphics drivers. For DXVK does it also need 32-bit vulkan drivers. Some have reported they needed the core fonts and/or dotnet40 via winetricks before it worked for them on their particular distro.


(Dravick Afterthought) #146

Thank you Sir, you are a scholar and a gentleman :+1: Up and running, now to copy all my settings over from the Linux version and I should be OK (said with fingers crossed :slight_smile: )


Launcher fails to start - missing symbols after update
(Roxanne Estemaire) #147

Reinstalled my OpenSUSE install yesterday, after trying to upgrade from Leap 42.3 to 15.0 (which failed). After restoring access to my /home partition (containing a pre-existing install of the launcher) I found I could not run EVE. The pre-existing install quickly showed a red square that read that the process had stopped unexpectedly.

After much unsuccesful trial and error I removed everything and anything CCP- or EVE-related that I could find and downloaded the most recent beta release linked here: it starts EVE, my screen goes black for a fraction of a second before returning to my desktop without any notification of failure. The launcher looks as if it is yet again waiting for me to click ‘Play’, with the Play icon having reverted to a Stop icon.

While loglite is full of data, it is not telling me anything useful.


(Whitehound) #149

Did you reinstall all the 32-bit libraries required to run WINE?


(Roxanne Estemaire) #150

I assumed that such requirements would have been met by my package manager, as they had been before…

After much frustration, I’ve found that running the windows executable under 64-bit wine runs a lot better for me, only needing winetricks allfonts to get the launcher working for me. It’s set to resemble Windows XP right now, but a second wine-bottle resembling Windows 10 seems to run just as well as long as the game sticks to d3d9. d3d11 works without readily apparent graphical problems, but the framerate suffers greatly for it. (Here’s hoping CCP will commit to Vulkan…)


(Whitehound) #151

There seems to be a misunderstanding in there somewhere. A pure 64-bit WINE can run almost none of the common Windows programs, because many Windows DLLs are still 32-bit. What you will be using is very likely the combined 32- & 64-bit version of WINE. This is also what most Linux users will be using, because they will have 64-bit computers, running a 64-bit Linux distro, and using the 32- & 64-bit combined WINE version.

This is confusing, but it’s caused by how Linux and Windows differ from one another and WINE has to bridge between the two. Linux can exist as a pure 32- or a pure 64-bit operating system, whereas Windows can only exist as a pure 32-bit or a mixed 32- & 64-bit operating system. The later is referred to as 64-bit Windows, but there is no actual 64-bit Windows made entirely from 64-bit software.

Regarding Vulkan can you already use DXVK, which translates DirectX11 into Vulkan and runs as fast as DirectX9. This is what already some of us here do. We play EVE under Linux and in DirectX11, using DXVK to map it to Vulkan, and get very decent performance from it as well as a very low power consumption.


(Dravick Afterthought) #152

Curiouser and curiouser - I thought the client hanging was the cause of my problem, but i’ve just found the launcher hung with no client active.


(Dravick Afterthought) #153

I’ve found a work-round for my hangs. I noticed that, when running multiple clients, only one client (not always the same one though) and the launcher froze, the other clients kept running. So… I tried terminating the launcher as soon as the clients were up and running - done about 20 hours gameplay since, including multiple clients and a 30±system autopiloted (AFK) tour of HS, no hangs or crashes. Not a fix as such, but it will do for now.


EVE Installing
(D43dun) #154

Dude I ■■■■■■■ love you.

Installed Fedora 29 on my laptop. Was trying to get the launcher to work. This totally worked for the client.

Now have to check if the game actually loads. :smiley:


(Forlorn Wongraven) #155

I upgraded to Fedora 29 as well, removing all libxcb*files made the launcher work again, but the client doesn’t start.


(Godric Arji) #156

@Forlorn_Wongraven,
Try using Gharim Turen’s Launcher from the AUR. I know its in arch but there is a script to make a version that will work with any distro. His scripts have never failed me and ive ran just about every distro except gentoo/gentoo based ones.


(g0nz028) #157

I reinstalled suse tumbleweed today hand have the same problem like you. The last few lines in the log are reporting a crash. Not sure if this is relevant:

|info|2018-11-14T21:01:38.170|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|"X Error of failed request:  BadWindow (invalid Window parameter)"|
|---|---|---|---|---|---|---|---|
|info|2018-11-14T21:01:38.171|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|"  Major opcode of failed request:  10 (X_UnmapWindow)"|
|info|2018-11-14T21:01:38.171|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|"  Resource id in failed request:  0x5e00001"|
|info|2018-11-14T21:01:38.171|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|"  Serial number of failed request:  308"|
|info|2018-11-14T21:01:38.171|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|"  Current serial number in output stream:  311"|
|info|2018-11-14T21:01:38.272|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|Process 6611 finished with exit code 1|
|info|2018-11-14T21:01:38.272|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|CustomWebPage(0x18d77b0) "processstatus({server:'tq', username:'g0nz028', isRunning: false, crashed: false})"|
|info|2018-11-14T21:01:38.272|6207|/mnt/hdd/gonzo/Games/eve_linuxlauncher/evelauncher/evelauncher|linux-ou2v|evelauncher|default|Queueing CustomWebPage(0x17ebe20) "processstatus({server:'tq', username:'g0nz028', isRunning: false, crashed: false})"|

(g0nz028) #158

I tried it again today and took a closer look into the log. I have a bunch of wine errors now. Like said I’m on suse tumbleweed 20181112. KDE Plasma 5.14.3. NVIDIA Geforce GTX 960, OPENGL 4.6.0 NVIDIA 410.73.

https://pastebin.com/EK0mebwf


(Gharim Turen) #159

Today i have installed openSUSE Tumbleweed to see, if my scripts worked on an rpm based distribution. It works so far, only the wine check in evelauncher.sh cannot find the right date from the wine installation, it updates eve’s wine every time, when i start evelauncher.sh.

Used components:

  • openSUSE Tumbleweed 20181112

  • KDE Plasma 5.14.3

  • nvidia-computeG05

  • nvidia-gfxG05-kmp-default

  • nvidia-glG05

  • x11-video-nvidiaG05

  • wine

  • wine-32-bit

  • winetricks from Winetricks

  • dxvk version 0.92 installed with winetricks

  • and my scripts from EVE Setup ofc.

All packages are from the standard repos of tumbleweed except winetricks and evesetup.


Any support for redhat distro/clones?
(Gharim Turen) #160

After an closer look on the wine check in evelauncher.sh i have it now fixed, should work on all distributions. If i use the delivered QT5-libraries from the launcher, the internal commands doesn’t work. In the previous mentioned environment i can use the QT5-libraries from the system after installing libQt5WebSockets5 which are missing after the default installation.
The used wine-package delivers winetricks, so are it not needed to download an external version, but make sure, that winetricks are in the path and executable.
For the AUR package i have written a patch which should be used, if you want to use the linux launcher with my scripts on rpm-based distributions.

jernuh@linux-niw8:~/Downloads> cat evesetup_tumbleweed.patch

diff -uNr evesetup.orig/build_installer.sh evesetup/build_installer.sh
--- evesetup.orig/build_installer.sh    2018-11-17 14:35:11.000000000 +0100
+++ evesetup/build_installer.sh 2018-11-17 15:18:39.308283744 +0100
@@ -9,6 +9,9 @@
 release=$(grep ^pkgrel PKGBUILD | cut -d= -f2) || exit 1
 arch=$(uname -m)
 
+printf "\n\n Warning, this version are only for Plasma Desktop "
+printf "or installed QT5 libraries version>=5.11! \n\n"
+
 if [ ! -f "makeself-2.4.0.run" ] ;then
 printf "\nGet makeself...\n\n"
     curl -L -O https://github.com/megastep/makeself/releases/download/release-2.4.0/makeself-2.4.0.run
@@ -31,52 +34,52 @@
 mkdir evesetup/
 echo "done."
 
+printf "\nExtract evelauncher-$version.tar.gz..."
+tar xf ../evelauncher-$version.tar.gz
+echo "done."
+
 printf "\nCopy needed files from AUR package..."
 for eia in $(ls ../eve-icons*.tar.gz) ;do tar xf $eia -C evesetup/ ;done
-for eta in $(ls ../eve-transl5.11-??.tar.gz) ;do cp $eta evesetup/ ;done
 for cmd in evelauncher.sh everegedit evewine evewinecfg evewinetricks ;do
     if [ -f ../$cmd ] ;then cp ../$cmd evesetup/ ;fi
     if [ ! "$cmd" = "evewine" ] ;then
         cp ../${cmd%.*}.desktop evesetup/
     fi
 done
-cp -f ../evelauncher.sh.in evesetup/evelauncher.sh
 grep -v '^#-' ../setup.sh.in >evesetup/setup.sh
 chmod a+x evesetup/setup.sh
+mkdir -p Launcher
+cp -r evelauncher/errorpage Launcher/
+cp evelauncher/evelauncher* Launcher/
+cp evelauncher/LogLite Launcher/
+cp evelauncher/libg* Launcher/
+cp evelauncher/libprotobuf.so.16.0.0 Launcher/
+cp evelauncher/libsteam_api.so Launcher/
+cp evelauncher/libcrypto.so.1.0.0 Launcher/
+cp evelauncher/libssl.so.1.0.0 Launcher/
+cp -f ../evelauncher.sh.real Launcher/evelauncher.sh
+ln -sf evelauncher.sh Launcher/LogLite.sh
+ln -sf libgpr.so.6.0.0 Launcher/libgpr.so
+ln -sf libgpr.so.6.0.0 Launcher/libgpr.so.6
+ln -sf libgrpc++.so.1.12.0 Launcher/libgrpc++.so
+ln -sf libgrpc++.so.1.12.0 Launcher/libgrpc++.so.1
+ln -sf libgrpc++.so.1.12.0 Launcher/libgrpc++.so.6
+ln -sf libgrpc.so.6.0.0 Launcher/libgrpc.so
+ln -sf libgrpc.so.6.0.0 Launcher/libgrpc.so.6
+ln -sf libprotobuf.so.16.0.0 Launcher/libprotobuf.so
+ln -sf libprotobuf.so.16.0.0 Launcher/libprotobuf.so.16
+chmod 0755 Launcher/*
+chmod 0644 Launcher/*.qm
+cp ../qt.conf Launcher/
 echo "done."
 
-printf "\nExtract evelauncher-$version.tar.gz..."
-tar xf ../evelauncher-$version.tar.gz
-echo "done."
-
-printf "\nClean up evelauncher directory..."
-cd evelauncher/
-rm -f ./*.a ./*.la ./*.prl
-chmod 0755 ./*
-chmod 0644 ./*.qm ./*.conf
-echo "done."
-
-printf "\nReplace identical files with symbolic links to the original file\n\n"
-ln -sfv evelauncher.sh LogLite.sh
-libb=/dev/zero
-for lib in $(find ./ -maxdepth 1 -type f -name 'lib*' -printf '%s-%f\n'|sort -r)
-do
-    liba=${lib#*-}
-    if [ "$(cmp -s $liba $libb; echo $?)" = "0" ] ;then
-        ln -sfv $libb $liba
-    else
-        libb=$liba
-    fi
-done
-
 printf "\nRemove unneeded symbols from files..."
-find ./ -maxdepth 1 -type f -exec strip -s {} 2>/dev/null \;
+find Launcher/ -type f -exec strip -s {} 2>/dev/null \;
 echo "done."
 
-printf "\nRepack evelauncher-$version.tar.gz..."
-cd ../
-tar czf evesetup/evelauncher-$version.tar.gz evelauncher/
-rm -rf evelauncher/
+printf "\nRepack launcher-$version.tar.xz..."
+tar cJf evesetup/launcher-$version.tar.xz Launcher/
+rm -rf evelauncher/ Launcher/
 echo "done."
 
 printf "\nBuild self-extractable archive evesetup-$version-$release-$arch.run\n\n"
diff -uNr evesetup.orig/qt.conf evesetup/qt.conf
--- evesetup.orig/qt.conf       2018-11-17 14:35:11.000000000 +0100
+++ evesetup/qt.conf    2018-11-17 15:13:54.551619991 +0100
@@ -1,6 +1,6 @@
 [Paths]
-Libraries=/usr/lib
-LibraryExecutables=/usr/lib/qt/libexec
-Plugins=/usr/lib/qt/plugins
-Data=/usr/share/qt
-Translations=/usr/share/qt/translations
+Libraries=/usr/lib64
+LibraryExecutables=/usr/lib64/qt5/libexec
+Plugins=/usr/lib64/qt5/plugins
+Data=/usr/share/qt5
+Translations=/usr/share/qt5/translations
diff -uNr evesetup.orig/setup.sh.in evesetup/setup.sh.in
--- evesetup.orig/setup.sh.in   2018-11-17 14:35:11.000000000 +0100
+++ evesetup/setup.sh.in        2018-11-17 15:20:03.668282876 +0100
@@ -41,10 +41,7 @@
        fi
     done
     install -dv "${target}/lib/"
-    for eta in $(ls ./eve-transl${qtver}-??.tar.gz) ;do
-       install -m 0644 "$eta" "${target}/lib"
-    done
-    install -m 0644 "./evelauncher-${elver}.tar.gz" "${target}/lib"
+    install -m 0644 "./launcher-${elver}.tar.xz" "${target}/lib"
     for icons in $(find . -type f -name '*.png') ;do
        install -D -m 0644 "$icons" "${prefix}/share/${icons#*/}"
     done
@@ -96,7 +93,8 @@
 #-     otarget=$(grep ^SETUPDIR= ./evelauncher.sh)
 #-     sed -i s,$otarget,SETUPDIR=\"$target\", ./evelauncher.sh
 #--
-    printf "\n"
+    printf "\n Warning, this version are only for Plasma Desktop "
+    printf "or installed QT5 libraries version>=5.11! \n\n"
     read -p 'Install EVE Online Launcher Setup? (Y/n) ' key
     [ ! "x$(echo $key | tr [:upper:] [:lower:])" = "xn" ] && \
        bootstrap_install && \

Download the snapshot from AUR extract it and use the patch above with

patch -p1 -l -i ../evesetup_tumbleweed.patch

after changing in the evesetup directory.
(Crap, forgot the whitespace handling after copy from the webbrowser, should work now.)

Update: Merged changed wine check routine in AUR, so patch has changed too.

Update 2: Fixed some bugs in wine check which raised trough whitespaces in installed wine path.


(Ender A Wiggins) #161

Distro: Kali/GNU Linux rolling (Yes I’m serious :stuck_out_tongue: )
./evelauncher.sh outputs the following error:
root@kali:~/evelauncher# ./evelauncher.sh
/root/evelauncher/./evelauncher: symbol lookup error: /lib/x86_64-linux-gnu/libGLX_mesa.so.0: xcb_dri3_get_supported_modifiers

Any suggestions other than “Don’t use Kali”?