EVE Launcher build 1385477 beta release for linux


(Sboycole) #121

Have an issue with not being able to refresh authorization, hit play and it tries, then fails half way, linux mint 18.2. I get no unusual errors in the terminal window


(Flar) #122

lots of d3d shader spam, and the X Error Bad Window message when I click game… have latest nvidia drivers for 1070

IDK… I’m gonna set up qemu-kvm with vga passthrough and install win7 for now


(Whitehound) #123

You mean to run the game on Linux?

Have you yet tried to just run the Windows launcher and installer under WINE? You don’t have to use the Linux-native launcher to play the game. The Windows version runs just fine, too. Don’t believe you would need to have the Linux-native version of it! It’s simply unnecessary and can cause you extra work before it runs. You can just install WINE and run the complete game, from it’s Windows installer and launcher to the game itself, all under WINE.


(Flar) #124

How do you reply like that :smiley:

OK I try WINE from ground up, didn’t try until now :slight_smile:


(Whitehound) #125

You can either select a part of a comment and it will show you a “Quote” button above it so that you can copy the text into your comment. Or you can click on the speech-bubble (left of the B for bold) and have the whole comment quoted. Try it!

The forum also understands the Markdown formatting syntax.

A lot of us Linux users don’t actually use the Linux-native launcher, because it has been broken for a while. And since about WINE 3.0 does the whole Windows version run under WINE. It was because CCP had introduced the launcher in the past, which didn’t run in WINE at first, that it needed a Linux version of a launcher before the game could be played. But this has changed for some time now. So long that the Linux-native launcher fell into decay and only now got picked up by CCP Bartender. It still remains an unofficial piece of software.

When you’re not comfortable with fiddling to get the Linux-native version running, or just don’t care for the extra effort, then you’re more than welcome to just run the Windows version.


(Flar) #126

OMG! EPIC


(Whitehound) #127

It can do all sorts of thing. Like inline code or entire segments of code:

some code here

It can do titles

Pictures and videos (i’ll spare you examples), bold, italic, strike-through, and a separation line:


  1. Numbered lists
  • Unnumbered lists
Tables Tables
123 abc
789 xyz
Hidden Text (click it to see it)

:smile:

And probably other things I just cannot remember right now.

Quote the entire comment and you can see what the syntax looks like!


(Rika Ronuken) #128

Seems like I am late for the party…
Wow I happy to see that the linux native client still gets some love !
I didn’t realized this update was a thing until it hit me today, september was a busy month.

I had some problems with the this update though. I had to delete all the libxcb* files in the evelauncher folder to make the launcher start after the update and although after deleting them all I was able to start the launcher and the game in the terminal I got a few warnings and errors that I didn’t get previously (https://pastebin.com/nXyskHjM).
Distro: Manjaro (4.18.9-1-MANJARO)

Also it would be nice if you update to a newer wine too. :wink:


(Ty'Ran) #129

Also late to the party. Did the launcher correctly update to the new version once you did that, or are you still on version 1225328.3104?


(Rika Ronuken) #130

My launcher version is 1385477.3104.
Because I had no idea what was happening at the time actually what I did was:

  • Downloaded the evelauncher-1385477.tar.gz from the OP
  • Renamed my old evelauncher folder in my home directory(I deleted it after I made sure everything worked)
  • Then extracted the new one in my home directory
  • Then deleted all the libxcb files in the new evelauncher folder
  • And I just run the launcher

At that point everything worked as before. I haven’t run in any issues, aside some warnings/errors in the terminal, when I run the launcher but everything seems to works since then. I played a few hours and logged in logged out and relaunch the launcher numerous times no problem.


(Specific Alduin) #131

Using this launcher does not work for me. It will show that the game is launching for a few frames then revert back to the play button next to my account name. Ubuntu 18.04 LTS, fresh install. NVidia 390 drivers


(Billy Lavapants) #132

Same here.

I downloaded all (settings) in case that was the issue but no joy. Logging in generates the missing root cert warnings in the console (the Qt locale warnings are there when you first run the launcher, too) but that’s it.

Clicking play doesn’t generate any additional info, it just does nothing (apart from the play button bit disappearing briefly then returning).

Ubuntu Bionic, Dell XPS 13 9370, 16GB, SSD, Intel Corporation UHD Graphics 620


(SiMOON HO) #133

Hi,
i got an issue with starting the programm, the launcher runs but if i start the client the log says:
“X Error of failed request: BadWindow (invalid Window parameter)”

It runs on Ubuntu 18.04 LTS.
Can someone help to fix this?
br
simoon


(Kaliba Mort) #134

Fails to run for me now.

./evelauncher: symbol lookup error: /usr/lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

Debian Sid

Workaround was to run with VNC - a little extreme :smiley:

./evelauncher.sh -platform vnc:mode=websocket


(Godric Arji) #135

This launcher is working on Fedora 28 after installing proprietary nvidia drivers from the repos and installing wine. I did not have to add or remove any libs or anything else. It just works out of the box.


(Dravick Afterthought) #136

I tried this, but got This application failed to start because it could not find or load the Qt platform plugin “vnc” in “”. I can’t find an application called VNC in Synaptic (Mint 17), any idea where I can get it from, please ?


(Dravick Afterthought) #137

I must admit I’m getting very confused now, but does this help ? I just tried ./evelauncher.sh, and got (after the update downloaded) a termination with the message “/home/username/.eve//updater: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21’ not found (required by /home/username/.eve//updater)”.

As an aside, I actually found an old response from a CCP dev (didn’t save the URL unfortunately) that said, in effect, that CCP couldn’t afford a PC on which to run Linux to check for this sort of issue - so a company which sold for $425,000,000 can’t afford a PC and a few man-hours to check that they don’t screw up a small but significant (over 1,000,000 Linux gamers in 2016 *) number of potential and actual users, really ??


(Whitehound) #138

If you have to use VNC just to get the Linux-native launcher up and running then perhaps you better just run the Windows-native launcher directly under WINE.


(Godric Arji) #139

@Dravick_Afterthought

I’ve gotten the linux launcher to work on Debian 9 “Stretch” before but yesterday i tried to get it to work on Debian Testing and couldn’t. I would recommend either using the wine version of the linux launcher or if you want to install Fedora 28. All I did on Fedora 28 was install properiatary drivers, nvidia, then wine, and then used the linux launcher and set it to beta and voila! it worked.

Also you need to remember that this is an unofficial linux launcher from one or two of the devs so technically they don’t even have to be doing this at all and could just leave us with wine and the windows one.


(Dravick Afterthought) #140

That’s my point - I believe there should be an official version which works with Linux, or at least Wine - and updates should be tested on Linux/Wine before release. This is a $425 million gaming company, not some fly-by-night app provider messing-about in his mother’s basement…