EVE Launcher build 1385477 beta release for linux


(Roesjka) #101

I have pinned my Login account name now in the launcher (getting lazy) so I don’t have to go through the seperate login window anymore.


(Lock Smith) #102

Hi!
Solus (with Budgie) user here (in case it matters: using Nvidia Beta drivers 410.57 on a GTX 1050TI).
Downloaded the launcher build 1385477, unpacked it, started evelauncher.sh, and boom! It worked! :slight_smile:
Logged in, started the game, seems to work fine.
Thanks a lot for putting work into this, it’s much appreciated.
Here’s the output from the shell: https://pastebin.com/raw/y28c7GfA

Edit: Output of “ldd ./evelauncher”: https://pastebin.com/raw/NVvuxeXK
Some of them say “not found”, but it doesn’t seem to matter.


(Nathan Durr) #103

Hi,

On Devuan under 4.15.0-3-amd64 and various versions of wine (3.0.2 and 3.16), the game client launches, but crashes during “processing data” message. LogLite acknowledges the crash and produces a dump file which it claims is uploaded, example dump ID is f3dd2be7-6f99-449c-a164-ca0e12276055.dmp. I can produce the dump file if you like.

Crash messages:

|info|2018-09-25T17:59:14.993|8|C:\tq\bin\exefile.exe|bg-ops|svc|bulkSvc|Bulk data is up to date: 130478|
|---|---|---|---|---|---|---|---|
|info|2018-09-25T17:59:14.993|8|C:\tq\bin\exefile.exe|bg-ops|fsdBuiltData|General|Trying to load cFSD file at Z:/home/xxx/.eve/ResFiles/ce/ce9505f3f2b1f3c8_f882f145750ebd78e8c39217919a08b0|
|info|2018-09-25T17:59:15.000|8|C:\tq\bin\exefile.exe|bg-ops|fsdBuiltData|General|Trying to load cFSD file at Z:/home/xxx/.eve/ResFiles/8f/8f44ee1a9a017bf2_44821ac98cc8c78290735eac760f0ebe|
|info|2018-09-25T17:59:15.163|8|C:\tq\bin\exefile.exe|bg-ops|fsdBuiltData|General|Trying to load cFSD file at Z:/home/xxx/.eve/ResFiles/7c/7c36c6611a23b18e_0fe59d03886e2aced9e720924b4e64bf|
|info|2018-09-25T17:59:15.165|8|C:\tq\bin\exefile.exe|bg-ops|fsdBuiltData|General|Trying to load cFSD file at Z:/home/xxx/.eve/ResFiles/dc/dcd171d0ca977380_9d9516ba97b12a1c0620beed0598701a|
|info|2018-09-25T17:59:15.181|8|C:\tq\bin\exefile.exe|bg-ops|fsdBuiltData|General|Trying to load cFSD file at Z:/home/xxx/.eve/ResFiles/fb/fb909889a553c448_20aac76ee3ff84b2689cc0fcdcc6cf35|
|warning|2018-09-25T17:59:15.232|8|C:\tq\bin\exefile.exe|bg-ops|blue|TaskletTimer|!! timeslice {"time": 240, "order": 1, "what": "returning to", "new": "None", "old": "Marshal::Load"}|
|info|2018-09-25T17:59:15.245|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.loaders.dictLoader|Loading FSD index for <file res:/staticdata/dustIcons.static>. 23.9 KB|
|info|2018-09-25T17:59:15.517|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.binaryLoader|Loading FSD data file res:/staticdata/regions.static into memory. 52.4 KB|
|info|2018-09-25T17:59:15.696|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.binaryLoader|Loading FSD data file res:/staticdata/constellations.static into memory. 129.0 KB|
|info|2018-09-25T17:59:15.974|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.binaryLoader|Loading FSD data file res:/staticdata/systems.static into memory. 1.5 MB|
|info|2018-09-25T17:59:16.293|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.binaryLoader|Loading FSD data file res:/staticdata/jumps.static into memory. 438.8 KB|
|info|2018-09-25T17:59:18.426|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.loaders.dictLoader|Loading FSD index for <file res:/staticdata/solarSystemContent.static>. 97.1 KB|
|info|2018-09-25T17:59:19.018|8|C:\tq\bin\exefile.exe|bg-ops|fsd|schemas.loaders.dictLoader|Attribute lookup table for MultiIndex <file res:/staticdata/solarSystemContent.static>. 92.0 bytes|
|info|2018-09-25T17:59:19.086|8|C:\tq\bin\exefile.exe|bg-ops|ExeFile|Main|Upload Crash Dump for b1387351, C:\users\xxx\Local Settings\Application Data\CCP\EVE\f3dd2be7-6f99-449c-a164-ca0e12276055.dmp, RESULT_SUCCEEDED:|

(Gharim Turen) #104

Have you checked the Shared Cache? If not give it a try. It seems, some files in your cache are broken.


(Nathan Durr) #105

Thank you for the tip, I wiped all the client directories and started from scratch - works perfectly now.

Tip for everyone else: once you start the launcher, do not interrupt it until it finishes downloading, even though you’d think it makes sense to restart it when you change from release to beta and set a custom wine path.


(Nathan Durr) #106

Another side note: if you use a tiling window manager like i3 you should probably switch to windowed mode, otherwise it’ll fail to switch windows and grab mouse focus.


(Flar) #107

I looked at a lot of errors and I can tell I’m not having problems with graphics, but I think this is QT related?

Can some1 confirm this is QT thats not working for me, or is it steam?
Do I need to buy EVE on steam to use this scrips correctly?

When I launched the shell script fhe first time I saw the launcher and it started updating but then closed right after. now I don’ẗ get to see it when I run the script (only after first extract).


(Gharim Turen) #108

I dont understand, wat your problem is. Evelauncher works by me and many others with this errormessages. CCP_Bartender has in his first post in this thread mentioned, that this happens and how you prevent that.


(Flar) #109

me?

update, I tried making a new extract and ran the script, when the dialogue box popped up if I want to update the launcher I clicked cancel and now the launcher begins to download files:

So don’t click OK or you will mess up the install!

I think its what he means with “attempt to downgrade”?

OK so you have 12 seconds to respond! :smiley: be quick or be dead!


(Gharim Turen) #110

have you read this?


(Flar) #111

NO HAHA :smiley:

im logged in


(Nathan Durr) #112

Ok, after several days of testing, I can confirm it works flawlessly on Devuan (wine 3.16) and Ubuntu 16.04 (wine built in)


(Niria Omastasi) #113

I give it some runs in the last days. After throwing out all “xcb”-stuff and configure wine to be win10 (xaudio2_7 error) it runs smoothly on Arch-Linux. :+1:


(Gharim Turen) #114

Maybe are this from interest for you Optimized AUR Package

Update: Minor changes on libs and startup made today.


(carboneater) #115

Debian buster/sid
wine 3.0.2

Had to throw out all the new XCB libs (I already used to flush all supplied XCB libs and use my system’s)

Because I’m using KDE, there used to be a conflict with Qt lib versions. As both EVE and my system are using 5.11 that’s not an issue for now, but I used to flush the evelauncher.sh script and symlink my system’s Qt to evelauncher. (Launch command is ./evelauncher from the evelauncher directory)

I guess that last ones happens because I launch evelauncher using my system’s libs, but I had to symlink libprotobuf.so* to /usr/local/lib/

The latest launcher looks like its working with all these fixes…


(Katrina Bekers) #116

I’ll try to set LD_PRELOAD on another custom script - I already use one to bridge from Steam to the launcher…

And I knew about the GL thread optimizations being active in recent drivers. Only found funny I cannot set those shell variables anymore or else the QT GUI won’t be built.


(Elassus Herron) #117

I ran into a weird problem today using the (non-beta) old launcher build: I saw only a button with “Log In.” When I clicked that, a new window popped up with the SSO page. I logged in, gave my 2fa, and then that window just went blank and I got nothing.
When I switched to the beta launcher (and thus this build in the OP), going through the SSO page worked as before. I had to re-add all my accounts, but otherwise it appears to be working.

CCP Bartender, thanks so much for working on this. I know we’re a niche community, but I really appreciate it. o7


(CCP Bartender) #118

@Roesjka I built them because those are the versions we use for our proto objects in the launcher. Rolling them back would mean making a lot of changes to the windows and mac build process, so it’s not on the cards, we have to use a modern libproto and libgrpc.


(CCP Bartender) #119

Just bumped 1385477 to release. 122 seems to be causing more people problems than providing solutions.


(Flar) #120

much better now, it has stopped nagging about downgrade :smiley:

did a fresh extract and moved the folder, I can start the game now and manipulate UI elements, but when I turn the camera or otherwise click in the gameworld it closes instantly.

Very strange. Currently trying the “download everything” option, 9GB to go :thinking:
Still nothing. I can pilot the ship with the keyboard, but if I click with the mouse the game closes.

Ubuntu 18.04 64-bit with KDE Plasma 5.12.6

Log:

info 2018-10-03T19:43:19.545 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher wine “fixme:d3d_shader:print_glsl_info_log 0(13) : warning C7050: “vs_out[11]” might be used before being initialized”
info 2018-10-03T19:43:19.547 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default “X Error of failed request: BadWindow (invalid Window parameter)”
info 2018-10-03T19:43:19.547 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default " Major opcode of failed request: 10 (X_UnmapWindow)"
info 2018-10-03T19:43:19.547 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default " Resource id in failed request: 0x9000001"
info 2018-10-03T19:43:19.547 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default " Serial number of failed request: 6553"
info 2018-10-03T19:43:19.547 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default " "
info 2018-10-03T19:43:19.547 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default “Current serial number in output stream: 6556”
info 2018-10-03T19:43:19.704 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default Process 15822 finished with exit code 1
info 2018-10-03T19:43:19.704 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default CustomWebPage(0x1074670) “processstatus({server:‘tq’, username:‘REDACTED’, isRunning: false, crashed: false})”
info 2018-10-03T19:43:19.704 15629 /home/flar/evelauncher/evelauncher WhiteBox evelauncher default Queueing CustomWebPage(0x2335b70) “processstatus({server:‘tq’, username:‘REDACTED’, isRunning: false, crashed: false})”

pretty sure this is where it gives up:
““X Error of failed request: BadWindow (invalid Window parameter)””