EVE Launcher build 1385477 beta release for linux


(Tyrannee) #81

That fixed it, thanks! I’m not sure what winecfg was changing before since it was my only wine install and ~/.wine didn’t exist, but it works now and I can finally play again. I appreciate your help so much.


(ATOM ANT) #82

Been messing with 1225328 and 1385477.
Finally found set to beta msg and solved the downgrade issue.
fumbled around some more and finally managed to get past the login to the character selection screen which was really messed up but the music was good.
Downloaded the nvidia linux X86_64-390.87 run driver and got as far as in game with access to mail and other menus but if i click on the main screen eve crashes. Also managed to exit the station but now i’m in a pickle since i cant get back into the station without crashing.
at least i’m not in a pod. A little more messing around and perhaps i can actually play the game and stop the withdrawl ss ss s ssssymptoms. I tryed loading a bunch of QT 5 packages but to no avail. As the computer on the enterprise would say…“WORKING”


(ATOM ANT) #83

you can just cancel the download which gives you time to do the settings beta thing.

AA.


(Roesjka) #84

I have a question. Where does this requirement for libprotobuf16 and libgrpc6 come from. These packages only show in Debian experimental as a port for for Sparc64. Would it not be wiser to base on libprotobuf10 and libgrpc3 which are for Debian buster/sid. As that will make it a lot easier for most distros.
Cheers


(Gharim Turen) #85

Good question. I am atm by searching for solutions to minimize the download size and by this i’m stumbled about grpc. Oh and btw it seems, that grpc are the reason for these security errors by logon.


(Roesjka) #86

As mentioned before relying on libssl.so.1.0.0 and libcrypto.so.1.0.0 is also a regression with the old launcher. The old launcher did work fine with a link to libssl.so.1.0.2 and libcrypto.so.1.0.2.

Noticed that libprotobuf16 and libgrp6 rely on libssl1.0.0.

If the requirements for libprotobuf and and libgrpc are not needed it should be dropped as that will make debugging also easier.

I deleted all the libqt5 bits in the evelauncher including the qt.conf and qtwebengineprocess and also deleted the plugins and resouces dirs.

As I have the neccessary libqt5 version already installed on my Debian Buster/Sid distro. For the locales error make sure to install libqt5webengine-data as that contains the locales.


(Gharim Turen) #87

I dont know, if QT5.11 relies on libssl1.0.x, Qt5.6 does.


(Roesjka) #88

It actually relies on libssl1.0.2 on Debian and it still does work with QT5.11. Except with beta evelauncher as somewhere that relies on libssl1.0.0 which deprecated like hell.


(Gharim Turen) #89

Oh nice look at this

[jernu@amd4k3 Launcher]$ ldd ./evelauncher
	linux-vdso.so.1 (0x00007ffc24003000)
	libprotobuf.so.16 => /usr/lib/libprotobuf.so.16 (0x00007f6503438000)
	libgrpc++.so.1 => not found
	libgpr.so.6 => not found
	libsteam_api.so => not found
	libQt5WebEngineWidgets.so.5 => /usr/lib/libQt5WebEngineWidgets.so.5 (0x00007f65033f0000)
	libQt5Widgets.so.5 => /usr/lib/libQt5Widgets.so.5 (0x00007f6502d88000)
	libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0x00007f65027f0000)
	libQt5WebSockets.so.5 => /usr/lib/libQt5WebSockets.so.5 (0x00007f65025c0000)
	libQt5Network.so.5 => /usr/lib/libQt5Network.so.5 (0x00007f6502418000)
	libQt5Concurrent.so.5 => /usr/lib/libQt5Concurrent.so.5 (0x00007f6502408000)
	libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007f6501f00000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f6501d70000)
	libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f6501d50000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f6501b88000)
	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f6503968000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007f6501970000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f65017e8000)
	libQt5WebEngineCore.so.5 => /usr/lib/libQt5WebEngineCore.so.5 (0x00007f64fb3a8000)
	libQt5Quick.so.5 => /usr/lib/libQt5Quick.so.5 (0x00007f64faf18000)
	libQt5PrintSupport.so.5 => /usr/lib/libQt5PrintSupport.so.5 (0x00007f64faea0000)
	libQt5QuickWidgets.so.5 => /usr/lib/libQt5QuickWidgets.so.5 (0x00007f64fae88000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f64fae60000)
	libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f64fadc8000)
	libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f64fab90000)
	libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f64faad8000)
	libssl.so.1.1 => /usr/lib/libssl.so.1.1 (0x00007f64faa68000)
	libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1 (0x00007f64fa7e0000)
	libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007f64fa750000)
	libicui18n.so.62 => /usr/lib/libicui18n.so.62 (0x00007f64fa480000)
	libicuuc.so.62 => /usr/lib/libicuuc.so.62 (0x00007f64fa2b8000)
	libpcre2-16.so.0 => /usr/lib/libpcre2-16.so.0 (0x00007f64fa040000)
	libdouble-conversion.so.1 => /usr/lib/libdouble-conversion.so.1 (0x00007f64f9e30000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f64f9e28000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f64f9d00000)
	libQt5WebChannel.so.5 => /usr/lib/libQt5WebChannel.so.5 (0x00007f64f9ae0000)
	libQt5Positioning.so.5 => /usr/lib/libQt5Positioning.so.5 (0x00007f64f9a58000)
	librt.so.1 => /usr/lib/librt.so.1 (0x00007f64f9a48000)
	libnss3.so => /usr/lib/libnss3.so (0x00007f64f9918000)
	libnssutil3.so => /usr/lib/libnssutil3.so (0x00007f64f98e0000)
	libnspr4.so => /usr/lib/libnspr4.so (0x00007f64f9898000)
	libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f64f9858000)
	libevent-2.1.so.6 => /usr/lib/libevent-2.1.so.6 (0x00007f64f9600000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f64f94c0000)
	libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x00007f64f94b8000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f64f9288000)
	libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0x00007f64f9080000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00007f64f8e70000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007f64f8c68000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f64f8a50000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007f64f8848000)
	libXi.so.6 => /usr/lib/libXi.so.6 (0x00007f64f8630000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007f64f8420000)
	libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007f64f8218000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f64f7f48000)
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f64f7f00000)
	libwebpmux.so.3 => /usr/lib/libwebpmux.so.3 (0x00007f64f7cf0000)
	libwebpdemux.so.2 => /usr/lib/libwebpdemux.so.2 (0x00007f64f7ae8000)
	libwebp.so.7 => /usr/lib/libwebp.so.7 (0x00007f64f7878000)
	libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0x00007f64f77e0000)
	libXss.so.1 => /usr/lib/libXss.so.1 (0x00007f64f77d8000)
	libre2.so.0 => /usr/lib/libre2.so.0 (0x00007f64f7768000)
	libsnappy.so.1 => /usr/lib/libsnappy.so.1 (0x00007f64f7560000)
	libasound.so.2 => /usr/lib/libasound.so.2 (0x00007f64f7280000)
	libavcodec.so.58 => /usr/lib/libavcodec.so.58 (0x00007f64f5dc8000)
	libavformat.so.58 => /usr/lib/libavformat.so.58 (0x00007f64f5b78000)
	libavutil.so.56 => /usr/lib/libavutil.so.56 (0x00007f64f5af8000)
	libvpx.so.5 => /usr/lib/libvpx.so.5 (0x00007f64f5568000)
	libopus.so.0 => /usr/lib/libopus.so.0 (0x00007f64f5310000)
	libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007f64f52b8000)
	libminizip.so.1 => /usr/lib/libminizip.so.1 (0x00007f64f50a8000)
	liblcms2.so.2 => /usr/lib/liblcms2.so.2 (0x00007f64f4e48000)
	libQt5Qml.so.5 => /usr/lib/libQt5Qml.so.5 (0x00007f64f4a40000)
	libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007f64f4a08000)
	libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007f64f4948000)
	libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f64f4920000)
	liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007f64f46f8000)
	liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007f64f44d8000)
	libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007f64f41b8000)
	libicudata.so.62 => /usr/lib/libicudata.so.62 (0x00007f64f2818000)
	libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f64f25a0000)
	libplds4.so => /usr/lib/libplds4.so (0x00007f64f2598000)
	libplc4.so => /usr/lib/libplc4.so (0x00007f64f2590000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f64f2388000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f64f2180000)
	libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f64f1f70000)
	libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007f64f1d68000)
	libswresample.so.3 => /usr/lib/libswresample.so.3 (0x00007f64f1d48000)
	libopencore-amrwb.so.0 => /usr/lib/libopencore-amrwb.so.0 (0x00007f64f1b30000)
	libaom.so.0 => /usr/lib/libaom.so.0 (0x00007f64f12b8000)
	libgsm.so.1 => /usr/lib/libgsm.so.1 (0x00007f64f10a8000)
	libmp3lame.so.0 => /usr/lib/libmp3lame.so.0 (0x00007f64f0e28000)
	libopencore-amrnb.so.0 => /usr/lib/libopencore-amrnb.so.0 (0x00007f64f0bf8000)
	libopenjp2.so.7 => /usr/lib/libopenjp2.so.7 (0x00007f64f0b98000)
	libspeex.so.1 => /usr/lib/libspeex.so.1 (0x00007f64f0978000)
	libtheoraenc.so.1 => /usr/lib/libtheoraenc.so.1 (0x00007f64f0738000)
	libtheoradec.so.1 => /usr/lib/libtheoradec.so.1 (0x00007f64f0518000)
	libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007f64f02e8000)
	libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00007f64f0038000)
	libx264.so.155 => /usr/lib/libx264.so.155 (0x00007f64efd78000)
	libx265.so.160 => /usr/lib/libx265.so.160 (0x00007f64ee8a8000)
	libxvidcore.so.4 => /usr/lib/libxvidcore.so.4 (0x00007f64ee590000)
	libva.so.2 => /usr/lib/libva.so.2 (0x00007f64ee368000)
	libxml2.so.2 => /usr/lib/libxml2.so.2 (0x00007f64ee200000)
	libmodplug.so.1 => /usr/lib/libmodplug.so.1 (0x00007f64ede70000)
	libbluray.so.2 => /usr/lib/libbluray.so.2 (0x00007f64ede20000)
	libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007f64edb88000)
	libgnutls.so.30 => /usr/lib/libgnutls.so.30 (0x00007f64ed818000)
	libssh.so.4 => /usr/lib/libssh.so.4 (0x00007f64ed7a0000)
	libva-drm.so.2 => /usr/lib/libva-drm.so.2 (0x00007f64ed598000)
	libva-x11.so.2 => /usr/lib/libva-x11.so.2 (0x00007f64ed390000)
	libvdpau.so.1 => /usr/lib/libvdpau.so.1 (0x00007f64ed188000)
	libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007f64ed170000)
	libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f64ecf50000)
	libsoxr.so.0 => /usr/lib/libsoxr.so.0 (0x00007f64eccd8000)
	libogg.so.0 => /usr/lib/libogg.so.0 (0x00007f64ecad0000)
	libmvec.so.1 => /usr/lib/libmvec.so.1 (0x00007f64ecaa0000)
	libp11-kit.so.0 => /usr/lib/libp11-kit.so.0 (0x00007f64ec970000)
	libunistring.so.2 => /usr/lib/libunistring.so.2 (0x00007f64ec5f0000)
	libtasn1.so.6 => /usr/lib/libtasn1.so.6 (0x00007f64ec3d8000)
	libnettle.so.6 => /usr/lib/libnettle.so.6 (0x00007f64ec1a0000)
	libhogweed.so.4 => /usr/lib/libhogweed.so.4 (0x00007f64ebf68000)
	libgomp.so.1 => /usr/lib/libgomp.so.1 (0x00007f64ebf38000)
	libffi.so.6 => /usr/lib/libffi.so.6 (0x00007f64ebd28000)

made on Arch linux after removing all delivered libs from the launcher directory. After setting from LD_LIBRARY_PATH and a customized qt.conf it works without libssl.1.0.0

[jernu@amd4k3 Launcher]$ cat qt.conf
[Paths]
Libraries = /usr/lib
LibraryExecutables = /usr/lib/qt/libexec
Plugins = /usr/lib/qt/plugins
Translations = /usr/share/qt/translations

(Ristovski) #90

I can confirm this version also got rid of the annoying bug where the launcher contents would stop updating/redrawing after some time, requiring the user to hover over the minimize/maximize/close buttons for it to start redrawing again.

Distro: 64bit Gentoo


(Ristovski) #91

Can confirm same output on Gentoo.


(Roesjka) #92

Forgot to mention I also deleted the libicu* files in evelauncher so it doesn’t use the outdated libicu55 so it uses the libicu60 files…


(Gharim Turen) #93

This is atm my launcher directory and with this it works.

[jernu@amd4k3 Launcher]$ ls -1
errorpage
resources
evelauncher
evelauncher_de.qm
evelauncher_fr.qm
evelauncher_ja.qm
evelauncher_ru.qm
evelauncher.sh
evelauncher_zh.qm
libgpr.so
libgpr.so.6
libgpr.so.6.0.0
libgrpc++.so
libgrpc.so
libgrpc++.so.1
libgrpc++.so.1.12.0
libgrpc.so.6
libgrpc.so.6.0.0
libsteam_api.so
LogLite
LogLite.sh
qt.conf
qt.conf.orig
steam_appid.txt

only errorpage and resources are the original subdirectories, launched with the delivered evelauncher.sh but without exporting QTDIR and QT_PLUGIN_PATH


(Roesjka) #94

I take you hashed out the QTDIR and QT_PLUGIN_PATH.

Have you put set -x in evelauncher.sh?

I get the following error:
E0923 18:29:15.587627956 727 security_connector.cc:1184] load_file: {“created”:"@1537720155.587574379",“description”:“Failed to load file”,“file”:“src/core/lib/iomgr/load_file.cc”,“file_line”:71,“filename”:"/usr/local/share/grpc/roots.pem",“referenced_errors”:[{“created”:"@1537720155.587564132",“description”:“OS Error”,“errno”:2,“file”:“src/core/lib/iomgr/load_file.cc”,“file_line”:45,“os_error”:“Bestand of map bestaat niet”,“syscall”:“fopen”}]}
E0923 18:29:15.587704302 727 security_connector.cc:1027] Could not get default pem root certs.

Are you running via steam?


(Gharim Turen) #95

Have the same error all the time. I run evelauncher with and without steam, both works. Have a look at this:


(Roesjka) #96

grpc is not installed on my notebook and desktop.

The linux launcher startsup and launches the game on my notebook but not on my desktop system. Have to find out why. Notebook works with Bumblebee but cannot use dxvk. Desktop has a GTX 1070 does work with dxvk.

Have to change my notebook to NVidia Optimus, but will loose the powersavings that Bunlebee gives me, to get dxvk wotking on my Notebook.


(Gharim Turen) #97

Thats, why you have these grpc-libs in your launcher directory. More interesting are, why the launcher crashes when i try to login with following environment variable

GRPC_DEFAULT_SSL_ROOTS_FILE_PATH (found in the grpc docs on git)

If i set these in evelauncher.sh with export and point to the launcher directory where i have copied the root.pem from grpc git, this happens always. And then are from interest, which purpose the site elg.evetech.net has.

[jernu@amd4k3 Launcher]$ /bin/sh -x ./evelauncher.sh 
++ basename ./evelauncher.sh
++ sed 's,.sh$,,'
+ appname=evelauncher
++ dirname ./evelauncher.sh
+ dirname=.
+ tmp=
+ '[' . '!=' / ']'
+ dirname=/home/jernu/.local/lib/EVE/Launcher/.
+ LD_LIBRARY_PATH=/home/jernu/.local/lib/EVE/Launcher/.:
+ export LD_LIBRARY_PATH
++ pwd
+ export GRPC_DEFAULT_SSL_ROOTS_FILE_PATH=/home/jernu/.local/lib/EVE/Launcher
+ GRPC_DEFAULT_SSL_ROOTS_FILE_PATH=/home/jernu/.local/lib/EVE/Launcher
+ /home/jernu/.local/lib/EVE/Launcher/./evelauncher
qt5ct: using qt5ct plugin
[0924/153419.696041:WARNING:stack_trace_posix.cc(699)] Failed to open file: /tmp/.glynz6f0 (deleted)
  Error: Datei oder Verzeichnis nicht gefunden
[4368:4368:0924/153419.770851:ERROR:gpu_process_transport_factory.cc(1019)] Lost UI shared context.
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
Received signal 6
#0 0x7f49586a289e <unknown>
#1 0x7f49586a29b0 <unknown>
#2 0x7f49586a2fe7 <unknown>
#3 0x7f495d54fe00 <unknown>
#4 0x7f495d54fd7f __GI_raise
#5 0x7f495d53a672 __GI_abort
#6 0x7f495eff41d8 gpr_malloc
#7 0x7f495ce77fb5 grpc_load_file()
#8 0x7f495cec47e4 grpc_core::DefaultSslRootStore::ComputePemRootCerts()
#9 0x7f495cec4994 grpc_core::DefaultSslRootStore::InitRootStoreOnce()
#10 0x7f495cde74ff __pthread_once_slow
#11 0x7f495eff6539 gpr_once_init
#12 0x7f495cec4a59 grpc_core::DefaultSslRootStore::GetPemRootCerts()
#13 0x7f495cec4cd5 grpc_ssl_channel_security_connector_create()
#14 0x7f495cec1638 <unknown>
#15 0x7f495ceeb270 <unknown>
#16 0x7f495cef67b2 <unknown>
#17 0x7f495cef71fb <unknown>
#18 0x7f495cee028e grpc_core::LoadBalancingPolicyRegistry::CreateLoadBalancingPolicy()
#19 0x7f495cedc919 <unknown>
#20 0x7f495ce694e0 grpc_combiner_continue_exec_ctx()
#21 0x7f495ce7632d grpc_core::ExecCtx::Flush()
#22 0x7f495ce763f1 <unknown>
#23 0x7f495ce765a3 <unknown>
#24 0x7f495eff727c <unknown>
#25 0x7f495cddfa9d start_thread
#26 0x7f495d613a43 __GI___clone
  r8: 0000000000000000  r9: 00007f48a232cf50 r10: 0000000000000008 r11: 0000000000000246
 r12: 00007f48a232d2d0 r13: 00007f4898004d40 r14: 00007f48a232d1d0 r15: 0000000000000001
  di: 0000000000000002  si: 00007f48a232cf50  bp: 7fffffffffffffff  bx: 0000000000000006
  dx: 0000000000000000  ax: 0000000000000000  cx: 00007f495d54fd7f  sp: 00007f48a232cf50
  ip: 00007f495d54fd7f efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.

libpng warning can be ignored, qt5ct-plugin are for desktop theme customizing.


(Roesjka) #98

These are the QT5.11 libs installed on both my systems.

libicu60
libQt5concurrent5
libQt5core5a
libQt5dbus5
libQt5gui5
libQt5help5
libQt5multimedia5
libQt5multimedia5-plugins
libqt5multimediagsttools5
libQt5multimediaquick5
libQt5multimediawidgets5
libQt5network5
libQt5opengl5
libQt5printsupport5
libQt5qml5
libQt5quick5
libQt5quickparticles5
libQt5quicktest5
libQt5quickwidgets5
libQt5sensors5
libQt5serialport5
libQt5sql5
libQt5svg5
libQt5test5
libQt5webehannel5
libqt5webengine-data
libQt5webengine5
libQt5webenginecore5
libQt5webenginewidgets5
libQt5websockets5
libQt5widgets5
libQt5x11extras5
libQt5xcbqpa > libqt5gui5
libQt5xmlpatterns5

The versions used by CCP Bartender of libgrpc and libprotobuf are way in the future and I don’t know where he got those from, certainly not from Debian or Ubuntu. The versions available on Debian Buster/Sid and Ubuntu are libgrpc3 and libprotobuf10. My feeling is that he should build with the packages available in Debian/Ubuntu

@CCP_Bartender if you are reading this as it will probably resolve a lot of issues.


(Roesjka) #99

Forgot to mention I am running EVELauncher linux know and logged in the game, on my Notebook, without the need for root.pem.


(Gharim Turen) #100

Thats only for a secure connection. Without this works the launcher even with this error messages about secure-channel and so on. The used grpc are from git build i guess. Version there was 1.12.0 released May 2018.

On Arch was this about installed Qt packages easier :slight_smile: have use these snippet:

pacman -Qo `ldd ./$1 | grep Qt5 | cut -d' ' -f3` | cut -d' ' -f4 | sort | uniq

which show me the used packages

qt5-base
qt5-declarative
qt5-location
qt5-webchannel
qt5-webengine
qt5-websockets

most of them are dependencies from other packages in this list so are this only

qt5-base qt5-webengine qt5-websockets

in the end. For localization are then qt5-translations needet but its not a dependency.
So, enough fumbled on evelauncher today. :slight_smile: