EVE Launcher build 1385477 beta release for linux


(Tyrannee) #61

I need to learn more about wine. The launcher log had this:

2018-09-22T05:40:33.163Z default debug Queueing CustomWebPage(0x12fd4b0) “processstatus({server:‘tq’, username:‘jorvis’, isRunning: true})”
2018-09-22T05:40:33.205Z default debug “wine client error:0: version mismatch 533/559.”
2018-09-22T05:40:33.205Z default debug “Your wineserver binary was not upgraded correctly,”
2018-09-22T05:40:33.205Z default debug “or you have an older one somewhere in your PATH.”
2018-09-22T05:40:33.205Z default debug “Or maybe the wrong wineserver is still running?”
2018-09-22T05:40:33.205Z default debug Process 11685 finished with exit code 1

in my path the first wineserver is wine-3.16 in /usr/bin/wineserver. I saw that there was no wineserver process running though, so I started one with ‘wineserver -f -d’ to see any debugging information. Clicking play again gives the same error, and no output from wineserver.


(Gharim Turen) #62

Ok no much effort :smiley: On console type killall wineserver because there is running another wineserver in background.


(Tyrannee) #63

$ killall wineserver
wineserver: no process found

I checked the ps list before doing all of this.


(Gharim Turen) #64

Try to remove the eve wineprefix in $HOME/.eve After restart the launcher he should rebuild him again with the right wine version.


(Tyrannee) #65

Sorry, what does “remove the eve wineprefix” mean? Delete the wine and wineenv directories there?


(Yrael Oramara) #66

Try to remove the eve wineprefix in $HOME/.eve After restart the launcher he should rebuild him again with the right wine version.

That actually worked - thanks ^^
I’ll update the wiki article with it.


(Gharim Turen) #67

Both directories, wine and wineenv. Just to be sure. The wine directory there are the binaries from the launcher which are outdated and he fall back of these if Use Custom Wine are not set.


(Gharim Turen) #68

Nice to hear that. With the new linux laucher version he is mostly outdated like the wine version in the launcher himself :slight_smile: I hope, @CCP_Bartender change the internal wine version soon.

btw. which wiki? ArchWiki?


(Yrael Oramara) #69

btw. which wiki? ArchWiki?

I (attempt to) maintain the uni wiki article on Linux: https://wiki.eveuniversity.org/Installing_EVE_on_Linux

Mail me if you find anything that needs changing on it :slight_smile:


(Gharim Turen) #70

Well i think, the section about OpenSSL-1.0 and QT are not needed anymore because the qt runtime with his dependencies are included in the launcher package.


(Yrael Oramara) #71

Likely not, but I’ll leave them there as historical info anyway, at least until this new launcher stuff gets ironed out properly :slight_smile:


(Gharim Turen) #72

Ok made a point about that. :slight_smile: You should mention, that by 1st start the launcher will itself downgrade to version 1225328 in by setting to beta this are avoided.


(Tyrannee) #73

OK, stuck still. I removed all installations of wine from my machine, reinstalled winehq-stable, then restarted the machine. I deleted the ‘.eve/wine’ and ‘.eve/wineenv’ directories. Now I can login, click play, and nothing ever appears.

LogLite output after clicking play
Launcher log


(Gharim Turen) #74

Please remove the launcherlog from pastebin fast, You have exposed your credentials there. If that is not possible, change your EVE password.
Try to run wine without EVE, to check if it works on your machine, a winecfg will do.


(Tyrannee) #75

Thank you, I did and changed my password again with 2-factor auth. I had removed the wine path accidentally. Reinstalled, then I see this error again:

Backtrace:
=>0 0x000000007bc3d431 RtlEnterCriticalSection+0x21() in ntdll (0x000000000e54fe38)
1 0x00000000f407f661 in xaudio2_7 (+0xf660) (0x000000000e54fec8)
2 0x000000007bc80324 call_thread_func_wrapper+0xb() in ntdll (0x000000000e54fedc)
3 0x000000007bc83859 in ntdll (+0x73858) (0x000000000e54ffdc)
4 0x000000007bc80316 call_thread_exit_func+0x31() in ntdll (0x000000000e54ffec)
0x000000007bc3d431 RtlEnterCriticalSection+0x21 in ntdll: movl 0x14(%esi),%eax

I went into winecfg and added the xaudio2_7 module to the disable list, but the same thing still happens.


(CCP Bartender) #76

I’m thinking about bumping this build to release so that peoples launchers stop trying to downgrade.

My thoughts on the matter are:
a) 1225328 doesn’t launch at all on my computer
b) 1385477 seems to be launching pretty well on most distros with only minor tweaks in a few cases

Is there anyone that’s currently relying on 1225328 as a bootstrapper platform or can make 1225328 work but not 1385477?


(Gharim Turen) #77

From my side speaks nothing against it to release 1385477 only fix the issue with 3 time packed libraries, please :slight_smile:


(Gharim Turen) #78

Better change than sorry. Have you winecfg called with the right wineprefix?

env WINEPREFIX=$HOME/.eve/wineenv winecfg

If not, then you have only changed wine settings in the standard wineprefix $HOME/.wine
By using winecfg you can try changing windows version to Windows XP instead of Windows 7.


(Kubetz) #79

Arch is working for me.

I switched my wine to fresh esync-staging-pba-3.16 and graphics works well. Having audio issues (crackling), but AFAIK that is an openal issue.


(Gharim Turen) #80

Or an issue with pulseaudio. Please have look in the Steam thread for this.