EVE Launcher build 1385477 beta release for linux


(Katrina Bekers) #41

Tried on

  • Kubuntu 18.04.01
  • kernel 4.15.0-34-generic (i7-4790K, 32GB)
  • nvidia-driver-396/bionic,now 396.54-0ubuntu0~gpu18.04.1 (GTX 1080Ti)

Notes:

  • Can’t update old launcher: the links are a total, utter mess. Had to start from scratch. Maybe it’s a good thing.
  • CanNOT set LD_PRELOAD (for Mumble) or __GL_THREADED_OPTIMIZATION, or else the QT GUI fails to build. Had to unset both. Had them set in previous version. Maybe a bad thing. The mumble overlay never worked correctly: it overlays on the launcher but NOT ingame.
  • No need for libssl/libcrypto/Qt5 env link juggling. This is definitely a good thing.
  • The game starts nicely. There’s a bit of delay in the first processing of bulk data, but I guess something in cache was cleansed and had to be re-done.

(June Ting) #42

Worked perfectly and can log into new accounts again now.

Ubuntu 18.04.1 LTS


(Gharim Turen) #43

The launcher is a 64bit executable and EVE are 32bit executable. Try to use LD_PRELOAD in a customized script, which run wine with preloaded 32bit libmumble.so. This script should be set in the settings menu as Custom Wine Path.

The variable __GL__THREADED_OPTIMIZATION are set by default on newer driver versions from Nvidia without explicit setting.

Tryed to running mumble overlay with EVE. After installing mumble 32bit version with his dependencies and disabling the use from DXVK in EVE, i become on the character selection screen a distorted symbol from the overlay by speaking. To be short, mumble overlay are unusable atm on dx9 and dx11 mode just as in DXVK mode. Used mumble version was 1.2.19 on Ubuntu 18.04 with Nvidia graphics card and proprietary drivers installed.


(Tinkerbell's Evil Twin) #44

@Gharim Turen any hints on what to look for in the Launcher logs? Nothing jumps out at me to scream “this is broken”

EDIT: Possible relevant; upon launching the launcher (ah ha) it opens the “downloading new version” window then immediately closes it. The bar at the bottom of the launcher that is the usual downloading/installing update progress bar stays grey. So it definitely seems like it isn’t fetching some files.


(Gharim Turen) #45

Check in the log, if the launcher can successfull connect to to his servers or not. I am not under linux but afair, should be tree server been there which he will connect, binaries, ressources and login. If one of them fails then he cannot download what he need.

If you have a fast connection delete the complete installation and reinstall all new.
Directories are the same as i described before and

$HOME/.config/CCP/EVE

and if you have no other setups used

$HOME/.eve

Its the hardest way, but i dont know atm other choices.


(Tyrannee) #46

I’m using Ubuntu 18.04 (do please let me know if I should create a new thread somewhere). I downloaded the latest launcher (1385477) and deleted these two directories:

$HOME/.config/CCP/EVE
$HOME/.eve

When I start “evelauncher.sh” for the first time it immediately opens a window saying “Downloading new launcher binaries” for version 1225328, which is older. That version is what was causing the white-login-screen issue and why I started trying to update to 1385477 in the first place. How can you start the launcher and it not download that older version? Even clicking “cancel” just makes the window disappear. It still updates in the background and reopens the launcher.

EDIT: I’m in Reykjavik for the next few days and visited the CCP office today. After playing for 11 years, I was so excited!


(Kubetz) #47

When I start “evelauncher.sh” for the first time it immediately opens a window saying “Downloading new launcher binaries” for version 1225328, which is older. That version is what was causing the white-login-screen issue and why I started trying to update to 1385477 in the first place. How can you start the launcher and it not download that older version? Even clicking “cancel” just makes the window disappear. It still updates in the background and reopens the launcher.

From the OP:

Note: The launcher will attempt to downgrade itself to version 1225328 if you don’t settings->version type: beta

So click on the settings in top right corner and in the Version Type combo-box select Beta.


(Tyrannee) #48

Yes, I saw that. But to change that setting I have to launch the UI, which immediately downgrades itself.


(Kubetz) #49

I let it download the old version, then I selected Beta and it stayed with the current version without downgrading.


(Tinkerbell's Evil Twin) #50

Ah-ha! You fixed it :slight_smile: Deleting the $HOME/.eve directory triggered the launcher to re-download the binaries properly, and I can now log in to the launcher and launch the game.

Thank you very much for your help.


(Tyrannee) #51

Now I get as far as logging in and clicking the play button, but after a minute or so I get a “Program Error” and there’s a lot of output on my terminal. The end of it is this:

[31208:31399:0922/035519.279034:ERROR:leveldb_database.cc(311)] Failed to open LevelDB database from /home/jorvis/.local/share/CCP/EVE/QtWebEngine/Default/IndexedDB/https_launcher.eveonline.com_0.indexeddb.leveldb,IO error: /home/jorvis/.local/share/CCP/EVE/QtWebEngine/Default/IndexedDB/https_launcher.eveonline.com_0.indexeddb.leveldb/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
[31208:31399:0922/035519.279664:ERROR:indexed_db_backing_store.cc(951)] Unable to open backing store, not trying to recover - IO error: /home/jorvis/.local/share/CCP/EVE/QtWebEngine/Default/IndexedDB/https_launcher.eveonline.com_0.indexeddb.leveldb/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)

I checked that the files are there and have 600 permissions


(Gharim Turen) #52

It is the same error i have described here EVE Launcher build 1385477 beta release for linux Previous versions from QtWebengine dont use a indexed database for cached files and if you start a newer version without an indexdb results in this error is my guess. So delete the old cached files from QtWebengine and the directories too, to build all them correct again. These files are only cached data from the UI so you do not harm the installation by doing this.


(Tyrannee) #53

That took away those entries in the error log. It still crashes though but I don’t see anything obvious in the short terminal output. Here’s the text dump from LogLite.


(Gharim Turen) #54

Hmm, crash in the soundengine. Which wineversion did you use?


(Tyrannee) #55

Right now it says:

Use dev versions: Checked
Dev branch: winehq-master
Wine version: Latest


(Gharim Turen) #56

Which windows version have you set in winecfg for the used wine? In my case when i use Windows 7 (which is default in wine) wine crashes with CPF in xaudio2_7, maybe the same in EVE’s soundengine. Try another setting for windows version in winecfg. I’m using atm WIndows 10 for this. I dont know if there is command line parameters to starting EVE with disabled audio.

Oha, did you use the internal wine version from the launcher or wine from WineHQ? In case you do that, DONT use the internal wine version she is outdatet. Use wine from your distribution or directly from WineHQ


(Yrael Oramara) #57

Use wine from your distribution or directly from WineHQ

Are there specific prefix settings needed to get this to work with a custom prefix? I’ve tried with both a 64 and 32-bit prefix with various Windows versions, and the game simply doesn’t open after clicking the play button.


(Gharim Turen) #58

EVE use his own wineprefix and he is hardwired means not changeable by the user, only through ugly hacks like symlinking to another wineprefix (but i dont recommend this). You can only change the path to EVE’s shared cache folder where this wineprefix are.

Default setting is $HOME/.eve/wineenv If you using wine from the distribution or WineHQ you must set it as

Use Custom Wine

and the path to wine himself, in my case are this

/opt/wine-devel/bin/wine

by using distributed wine are this

/usr/bin/wine


(Tyrannee) #59

Gharim -

Thanks for your continued help. I just tried changing the menu to 'Use custom Wine" and pointed it to my OS-provided one (wine-3.16). I ran winecfg and changed it to Windows 10 (have also tried Windows 8). Now when I click the Play button (after restarting the launcher) It spins for about 4 seconds and then nothing happens and the play button returns. Nothing on my terminal, and nothing in LogLite. :frowning:


(Gharim Turen) #60

Have a look in the launcherlog if the launcher has found the wine binary and started this.