EVE Launcher build 1385477 beta release for linux


(CCP Bartender) #21

@Tau_Hopper Unfortunately, Ubuntu 14.04 is not the supported Ubuntu platform on QT from 5.9 forwards: https://doc.qt.io/qt-5.11/supported-platforms-and-configurations.html

I have to compile QT from source due to problems making sure QT’s proto’s and ours are compiled with the same version of protoc. I haven’t tried compiling QT5.11 from source on 14.04 but given that it’s no longer the supported Ubuntu platform and falls under the generic “linux” platform umbrella, I see that as a route of pain.

I don’t suppose I can convince you to run a do-release-upgrade? Otherwise in your case I would suggest either running the windows launcher under wine or using steamplay.


(St Lamarque) #22

Kubuntu 18.04 all working fine :slight_smile: On OpenSUSE Tubleweed not started - errors with libraries libcrypto and libssl, as expected :frowning:


(CCP Bartender) #23

Hrm, the libssl and libcrypto libraries are now bundled, I’d expect them to work. Can you paste in the exact errors you are seeing?


(CCP Bartender) #24

Also, I think this is going well enough for me to push it to beta. Doing that in a bit.

edit: pushed


(Gharim Turen) #25

Have just build Arch packages which should compatible with the last developer build. By missing qtwebengine_locales shall these copyed from the install to the launcher directory. In the scripts i have reenabled the using of the internal wine version so its up to you now :wink:

AUR Package developer

AUR Source Package developer

After changing to this version you should update the launcher binaries to the Beta version in Menu->Settings->Version Type

@CCP_Bartender found a glitch in the tarball, you have most of the depended libs 3 times copied instead copying the lib and 2 shortened symlinks to her. Maybe wrong parameter by rsync (following symlinks instead copy symlinks). Would save space in the tarball and in the launcher directory.


EVE Installing
(Tau Hopper) #26

No, I’m afraid I still need this setup and baseline for a certain project I’m working on.

Actually, a few weeks ago I started using a custom build of Wine –rather than the one bundled with the native EVE Launcher– in order to enable DirectX11 via DXVK. So simply running the Windows version was just one small step further.

I reinstalled the client into its own Wine environment a moment ago, and after a couple of quick tweaks (i.e. disabling xaudio2_7 and setting up the Vulkan components again) it is working smoothly.

Nevertheless, thanks for your support and keep up the good work :slight_smile:


(CCP Snorlax) #27

Thanks, @CCP_Bartender for keeping the Linux version of the EVE Launcher alive. Now we just need to convince him to get the Wine version up to date as well, or switch to the Proton fork…


(Whitehound) #28

When will you make the launcher available on GitHub?

You already have WINE there, you also have rescache for managing the cache there, too. I know the OAuth2 procedure couldn’t be much of an issue since it’s public through the ESI API.

What’s stopping you from putting the launcher on GitHub, too?


(Yrael Oramara) #29

Having an issue with the new launcher on Arch Linux with Intel graphics on three separate machines.

Launcher doesn’t open at all, and gives the following error:

Could not initialize GLX
./evelauncher.sh: line 14: 17098 Aborted                 (core dumped) "$dirname/$appname" "$@"

Kernel version is 4.18.8-arch1-1
Graphics driver is KMS i915 1.6.0 2018514
Chipsets tested are Intel 500, 5500, and 620. All give the same error when trying to run the launcher.


(andrei haiducul) #30

Delete the bundled libxcb* files


(Gharim Turen) #31

If you do so, it is a solution only for her special case (and only, if it works). If i remove these libs, the launcher won’t start because missing these libs. Tested on Debian Stable by removing these libs which are in most cases 3 times installed and leave one of them in the directory.


(Yrael Oramara) #32

Delete the bundled libxcb* files

Well, it worked, so thank you :blush:
Do you know why they were causing an issue?


(Tinkerbell's Evil Twin) #33

Trying this on Kubuntu 18.04. I get the launcher launching fine, and can log in to it ok however there’s just no “play” button next to the account names like on the windows client, and if I change the settings to auto-launch on login that doesn’t happen. So the launcher loads but I can’t launch the client.

Pastebin log file because for some reason the forum thinks I’m spamming links. Bad bot. https://pastebin.com/djQXFJQG


(CCP Bartender) #34

Do you know why they were causing an issue?

I wouldn’t mind knowing the answer to this too if you know @Gharim_Turen

Bundling the libxcb files was one of those late night blind fixes. The launcher couldn’t find them so I shrugged and bundled them. I guessed at the time they might have recursive dependencies, but I would expect to see library not found errors, not a core dump.


(Gharim Turen) #35

In the past was it some trouble with the Intel drivers and QT. Maybe someone in this direction i guess.


(Gharim Turen) #36

Have the same error too. Fix by me was remove the directory

$HOME/.local/share/CCP/EVE/QtWebEngine/Default/

My guess for this is changing version from qtwebengine to a newer version. If you have in

$HOME/.cache/CCP/EVE/QtWebengine/

remove this directory too. Before you do so, leave the laucher. After a new start he creates this directories new and accessable.


(CCP Bartender) #37

@Tinkerbell_s_Evil_Twin

Not 100% sure but based on those logs my guess is that the launcher can’t download the game binaries, or can’t download a file it needs before it can decide what game binaries to download.

IO error: Unable to create IndexedDB database path: “/home/tinkerbellseviltwin/.local/share/CCP/EVE/QtWebEngine/Default/IndexedDB”

You sure the user you are running the launcher with can write to that path?


(Gharim Turen) #38

Today i have tested launcher 1385477 on Pop!_os which is an derivat from Ubuntu 18.04,
wine 3.16, nvidia driver 396.24 and gnome desktop. There was it, who i has this error which
@Tinkerbell_s_Evil_Twin has described before and i fixed it by deleting these directories, which i have written in my post before. After that no errors in this direction and eve runs :slight_smile:


(Tinkerbell's Evil Twin) #39

Thanks for the help guys. I deleted those directories and re-ran the launcher. I now get the “toggle” switch against account names after login, however still no “play” button to launch the client. Progress at least.

@CCP_Bartender I do have write access to that dir yes.

New log file: https://pastebin.com/vSSzUfgt


(Gharim Turen) #40

Maybe check your Shared Cache Folder would help. Oh and can you paste the launcher log?
Launcher logs are accessable via Menu->Show in File Browser->Launcher Logs. Beware in the launcher log your credentials!
Ok, it was a bad idea but in this log are some info, if the launcher has the client data complete downloaded and patched, if this not the case, he will not start the client.