EVE Launcher crashing on "Checking GUI Version..."

Bypass the launcher and start the game exe directly with a desktop link?

How about fix the launcher and people no longer need any dirty hacks to use it??

You’re on Linux, using hackjobs. Linux is not “officially” supported, how about offically get it supported.

This is a case of “you’re on your own” and the company hangs you out to dry, you’re a second class customer

I’ve had this thread before on Linux and the response pretty much is, if it works you’re lucky but don’t expect support, and even the ticketing system clarifies “Linux (Not supported)”

Can I have a discount on my subscription fee since I don’t have all that support windows users have??

2 Likes

You’re lucky they don’t ban hammer for just using Linux as some other companies would and file it under cheating.

READ THIS IN FULL BEFORE STARTING ANYTHING SUGGESTED

I solved this by re-building GitHub - GloriousEggroll/proton-ge-custom: Compatibility tool for Steam Play based on Wine and additional components from AUR and patching in the commit mentioned earlier for wine. Latest version of the launcher now works fine.

I’m using Manjaro with Lutris for EVE specifically, so YMMV. This should also work just fine for Arch Linux. Other users of inferior distros will have to adapt. :zipper_mouth_face:

I basically just added the adapted patch from my own gist, as proton-ge-custom has wine as a git submodule and the paths are different.

# create build dir
mkdir -p ~/build && cd ~/build
# get pkgbuild for proton-ge-custom
yay -G proton-ge-custom && cd proton-ge-custom
# download patched PKGBUILD file
curl https://gist.githubusercontent.com/TyrHeimdalEVE/a9ce15b8a3fd6cf56348e42dd4cea000/raw/8b2975fb5458a869e9943d8c0461fecee3aae872/PKGBUILD > PKGBUILD
# build and install
makepkg -sri

I also had to declare in Lutris to use the native DLL for msvcp140_1 before builtin.
(see: https://i.imgur.com/pnDaowP.png for how this is done).

Note, the above is equivalent to running:
WINEDLLOVERRIDES="msvcp140_1=n,b" path/to/proton/bin/wine eve.exe

Or if you use Steam for EVE:
WINEPREFIX=~/.steam/steam/steamapps/compatdata/8500/pfx winecfg
(see: https://i.imgur.com/1CGh5Sd.png how to set it, using winecfg)

The issue is, to my understanding - caused not only by the missing functionality in wine itself, but the builtin DLLs provided in the wine prefix doesn’t have it either (but it is bundled by CCP). This is probably why some get to the “Checking GUI Version…” screen, while others just hard crash.

If this saved your bacon, feel free to send me some iskies for PvP. :boom:

I have downloaded Wine source RPM for my Fedora 33 and manually patched it. I have rebuilt the binaries and can confirm that the patch works. Eve Launcher now starts and the game is working.

Funny how they can easily add MacOS support, but never for Linux. I’m getting annoyed at having to constantly debug the launcher just to play the game like everyone else.

Why do you need the launcher? Can’t you simply run the game exe directly?

This is a Linux thread sweetie, can’t just run an EXE

It’s running in Wine/Proton, that effectively IS Windows

Launch it with a shortcut loading it up via Wine/Proton, the Launcher has to load the game exe so skip that part and do the same thing as the launcher does

use something like?

wine exe

except instead of the launcher use the game exe

then link it in a .desktop to invoke that from the desktop

cupcake

This is the most ironic part. I’ve been in a QT desktop this entire time in KDE/Plasma! This game is complicated as hell and we can run it fine, it’s just this trite little launcher that is ruining the experience for us and keeping us from playing at all. I am paying you money CCP, please don’t absolutely wreck us like this!!

And yes, it’s absolutely a dirty workaround. Like the dirty open-source pilot you are…

Any changes with 6.2 wine?

Nope.

Thanks to Tyr for uploading, saved me a lot of time.

Annoying anyway, bad move @CCP

1 Like

Thanks for posting info about netprofm patch.
I can confirm that rebuilding wine 6.1 with patch fixed launcher for me.

Before the patch i was using wine “lutris-4.21-x86_64” to run new launcher and play.

And i also use media-libs/mesa-20.1.10 to run in DX9 without DXVK.
Then running several chars - seems more stable for me.

It seems like people forgot that there was offical Linux support.
Devblog article

you need to check this page:
https://source.winehq.org/patches/

the patch you are looking for is this:
199525 [New] netprofm: Fix connection_GetAdapterId return wrong GUID.

as you can see, it has still status “New” meaning it wasn’t yet assigned to somebody for a review. Until it is committed to Wine repository, Wine will not have the patch.

You can’t anymore because when they added the new Eden store there is something passed from the launcher to the game. At first you could but then the nes wouldn’t work and there were some weird issues in game with Plex, MCT certificates, skill injectors, etc if you didn’t use the launcher to log in.

With the recent launcher debacle I tried it again and now it flat out blocks you from logging in. It does show the old log in screen with input but then gives an error saying that log in method is not allowed and to use the launcher.

I’m also encountering the same problem, started with with the launcher update yesterday, which broke the launcher, something about the Qt5 .dll is broken. Then, I deleted EVE and reinstalled it with the newest launchers from the EVE Download page. Now the launcher is starting up, but now its stuck at Checking GUI version and is giving an almost identical long list of errors
0188:fixme:netprofm:connection_GetAdapterId 09C568A8, 0D91DAE8

true, I paid for omega but I cant even play the game… sad CCP lmao