Launcher crashes after today's update(SteamPlay Linux)

It’s the windows version of the launcher, try the linux version. Oh and btw, build wine on Debian based Distributions is a mess but not impossible :slight_smile: You must just go through the dependency-hell, nothing more :smiley:

I will give it a try. I was using the Lutris (Windows) Version. So i didnt have to install all the Wine and DXVK Thingies. That was the most interesting Challenge for me.

Update:
I used the Linux Launcher and it works without any problem.
I use Wine 6.2 Developer and had to install Winetricks and DXVK.

This was my source: Installing EVE on Linux - EVE University Wiki

P.S.: I had serious Issues to get DXVK running with EVE Online but finally it’s working now.

Nice to see, that it works finally on your system. For the problem described some posts before with no closing processes after ending the launcher itself i have written an ugly but working hack which maybe are from interest:

~/…/EVE/Launcher >>> cat evelauncher.sh

#!/bin/sh

appname=`basename "$0" | sed s,\.sh$,,`

dirname=`dirname "$0"`
tmp="${dirname#?}"

if [ "${dirname%$tmp}" != "/" ] ;then
dirname="$PWD/$dirname"
fi

LD_LIBRARY_PATH="$dirname:$LD_LIBRARY_PATH"
export LD_LIBRARY_PATH

"$dirname/$appname" "$@" &

if [ -x "$(which lsof)" ] ;then
	sleep 10
	until [ "$(lsof -t -u $(whoami) -a -c /evelauncher$/ -- \
			$HOME/.local/share/CCP/EVE/QtWebEngine/Default/IndexedDB/https_launcher.eveonline.com_0.indexeddb.leveldb/LOCK)" = "" ]
	do
		sleep 10
	done
	kill $(lsof -t -u $(whoami) -a -c /evelauncher$/)
fi

It’s a changed evelauncher.sh script which need lsof to work. lsof are used to check every 10 seconds, if evelauncher’s QtWebEngine process has accessed his database lock file. If you close evelauncher so you close the GUI and the QtWebEngine his lock file. In this case are now kill used to terminate the evelauncher processes launched by the actual user.

Disadvantage of this hack are, you cannot use “Close to Systray” anymore, but minimize the launcher window to taskbar works as always.

To those confused here with the linux/windows launcher differences…

The linux native launcher is a native linux program, but ONLY the launcher. What the linux launcher does is pull in a specific version of wine that the developers apparently greenlight, but this version of wine is extremely old, and I’m not sure if current versions of dxvk or gallium-nine work with it; this is why some report performance differences switching to the linux native launcher, it’s because it’s pulling in an OLD version of wine to run the eve client.

The bug specifically effects the LAUNCHER not the eve client that the launcher starts, so the linux native launcher is not affected by this bug. The eve client itself is NOT native; it’s being run inside of a specific wine version that the linux launcher chooses.

What this bug effects is running the WINDOWS launcher directly with wine, which many people choose to do for performance reasons. When you start the WINDOWS launcher with a modern version of wine, it also uses the same modern wine to launch the eve client.

I’ve heard it’s possible to switch the version of wine that the native linux launcher uses, but I have not tested this as I can’t get it to run at all in gentoo, though that doesn’t mean it’s impossible it’s just a lack of effort.’

Edit: The reason this thread is so large is because running the launcher with wine instead of using the linux native launcher seems to be a lot more popular. I imagine that is because the linux launcher is not very well maintained and does not work out of the box on nearly ANY system. As far as my tries go it seems to be looking for old versions of library dependencies, you might have the right QT libraries installed, but because the native launcher is so far out of date and unmaintained it fails anyway because your libraries are too new.

This was just my appraisal of the situation the last time I tried, I gave up quickly because running the windows launcher directly with wine in addition to giving better performance, is simply easier; or it was until this bug anyway. It just worked. No games needed to be played.

Edit2: I don’t want to crap too much on the linux native launcher here, I appreciate the devs effort on it, any effort towards linux native is good, but considering the lack of maintenance on it, and how difficult it seems to get running on any distribution , I think that effort is misplaced. The devs time would be better spent towards simply ensuring the launcher and the client run in modern versions of wine; which aside from this bug, they already do.

If anyone bothered to test this with wine before releasing the launcher to the wild in the update, it would have been immediately caught; and debugging it I imagine would have been easier than writing an entire native linux launcher, just to have it pull in an ancient version of wine to run the actual client. They are already ensuring the client runs in wine, and in an ancient version at that, via that linux native launcher. Not to mention the linux community here pretty much works for free debugging it anyway, we seemed to have nailed the exact problem in less than 24 hours.

I’ve been running EVE through wine using the Windows installer/launcher for years (2015), every now and then a bug like this will stop it from working…

Currently running:

  • ArchLinux
  • Nvidia vulkan dkms
  • wine-staging 6.2-1
  • msvcp140_1 override
  • wine patch 199525
  • vcrun2019
  • d3dx9 - as a backup
  • dxvk
  • libstrangle - vsync only available at interval 1 for nvidia prime sync setups at 144hz/fps for my panel… gets a bit hot when running 3 clients at 144fps and works around window freezing issues in wine under dxvk and prime sync
  • EveOnline Windows Launcher

With the following start command:

NODEVICE_SELECT=1 DXVK_HUD=0 DXVK_STATE_CACHE=0 DXVK_LOG_LEVEL=none WINEESYNC=1 WINEDEBUG=-all WINEARCH=win64 WINEPREFIX=~/Software/eve-dxvk strangle 30:20 -k wine64 /home/username/Software/eve-dxvk/drive_c/EVE/eve.exe

Launcher broke today after updating for me. I’ve tested on ArchLinux wine-staging 5.22 through to 6.2-1 all refused to start the new launcher, reverting to an older launcher works fine if you cancel the update quick enough.

Overriding the msvcp140_1 dll in winecfg got the launcher to show Failed checking GUI version error page, and when setting wine to debug level “all” the following network error printed out to the point my terminal lost any history:

039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08
039c:fixme:netprofm:connection_GetAdapterId 0E0CD318, 17C5DB08

As a few have mentioned a patch is now available for wine, however you need to know how to build it which isn’t for every linux user, wine can take a while to build and you’ll need to combine both 32bit and 64bit. Patch details:

For anyone running Linux+wine+windows-launcher on an ArchLinux based distro i’ve compiled a quick patched version, alternatively review and use the PKGBUILD if you want to run a makepkg -sri yourself:

Obviously review and use at your own risk. Feel free to hit me up about running eve on linux and any fixes/patches you know, trying to compile a new up-to-date guide.

Personally i’d rather stick with the windows launcher and fix any issues with Wine / DXVK etc unless the game was to release a linux native version entirely (not just the launcher). As a software dev I can completely understand why the ccp devs wouldn’t want to support running their software under wine, however it would be nice if they could setup a testing community program with a group of us. I’d be more than happy to report bugs to Wine and help liaise and fix issues. I dislike having to reboot into windows just to fire Eve up while trying to work on projects in the evening :sweat_smile:

Edit 1 - overriding msvcp140_1 not needed after checking on original prefix with patched wine and no override.

1 Like

Just dropping my post from the other thread, as it might be useful for those who use Manjaro/Arch Linux.

This is somewhat the same as the above, except I use Proton-GE-Custom (aka GloriousEggroll) instead of wine-staging. It’s basically Proton + wine-staging + additional fixes and has been super reliable for me.

2 Likes

The launcher works fine using Proton 5.9-8 from Glorius Eggroll instead of newer versions

1 Like

It also works on Steam using Proton Experimental - no need to install anything else.
How-to:
In Steam, install Eve Online and Proton Experimental.
Go to Eve Online in your Steam Library , click the cog in the top right corner, go to Properties → Compatibility, and tick “Force the use of a specific Steam Play compatibility tool”
From the dropdown menu,select Proton Experimental. That’s it, launch Eve
You might also want to copy your profiles from wherewer they were to the new profile folder: start the game first, and let it create those new profile folders first (mine are in /opt/SteamLibrary/steamapps/compatdata/8500/pfx/drive_c/users/steamuser/Local Settings/Application Data/CCP/EVE/z_opt_steamlibrary_steamapps_common_eve_online_sharedcache_tq_tranquility/
but yours will be where you made Steam’s library folders

1 Like

This worked for me after uninstalling and reinstalling the game. Thanks!

Slightly annoying when the launcher updates too quickly so you can’t cancel it :stuck_out_tongue:

The launcher download is quick, but after the launcher download (if you don’t cancel it) there is a 30 second timer to either install the launcher update or not. So you can still cancel during that 30 seconds, and the 30 second timer will pop up every time you open the launcher.

I’ve been out of the loop on this for a couple of weeks (unexpected hospital stay :frowning:) so I’ve rather lost track - where do we stand on this issue now ? I’m on Mint 17.3 atm, but can install either Mint 19 or Mint 21 as needed (not Steam though). What’s my simplest way to proceed ?

Still the best solution until we can get a working launcher again. BTW after the dll you mention i notice that the log started to show a network adapter error almost like if the launcher gui couldn’t find how to connect

Possible reason for this shambles - I came across this in a Reddit group about bad management. Anyone know if it’s true ?

This happened to CCP Games in Iceland…

Long story short, a single developer was tasked to code an upcoming expansion by himself. He rewrote the entire game into this expansion. Without documentating anything he did, so he would be the only one who knew how it worked. (Job security.) Said developer literally died shortly after the expansion went live. They didn’t notice for a long time, and when they did, they realized just how spaghetti stringed the code was.

It took them 2 years to figure out what he developer did and another 3 to unfuck it just enough to continue on. The game cannot be expanded on in several directions because if they touch certain lines of code everything breaks…

If anyone else is having this issue the most simple solution that I have found is to install the game using Lutris and using the runner for lutris-5.7-11-x86_64.

1 Like

Do you still have to kill any updates before they can download ?

Would like to know that too. There was another launcher upgrade a few days ago, but I still dont dare to let it run. Anybody has made some experiences with that?

By accident I let the launcher update run this morning and it reverted to a non-working launcher. I overwrote it again with the old launcher and I was back in business.

My concern is that we’re going to arrive at a point where a particular launcher update is required to work with a new server or client update. At this point the ‘load an old launcher’ strategy will no longer work, and Eve will be effectively dead to Linux users. The only viable solution would appear to be getting a new version of Wine which works with whatever it was CCP changed to break it, and I have absolutely no idea where to even start doing that…

Has happened before, will happen again.