Eve Launcher deleting itself?

True, but I hit “Cancel” till it stops.

So the op’s issue is with the launcher itself, good – that will be fixed then maybe.

I’ve run linux since slackware’s first decent release in …94? …But last 10 years or so only Debian – on the machines I work on and pay bills on. But I just do not have the time to keep up with the kid and wife and their preferences, and they stick with Windows full-time, and I myself run win on the laptop bought for eve use – though I actually feel cheapened when I do so as I still remember the days when a young programmer published pc dos, and how remarkedly close it was to Digital’s where he had only recently worked. But I a really straying from the thread, sorry.

My son’s machine is running the Clamwin av (it might collect and sell info but I know the commercial ones will, all of them). He re-installed steam twice, trying to fix the problem and as soon as he’d try to run steam, the av would lock it up – naturally in the c:.programdata… dir which was hidden to him.

I would venture a guess that the op’s issue is going to be permission-related? I have not had his problem; my current problem with the launcher is that it is remembering logins, as if it did not have the permission to alter, and and/or read all of the editable configs – it’s just a game but I’d hate to see what I have in it lost, the first time someone manages to lift my computer. So I hope it gets straightened out soon.

This has happened to me as well. I have tried to run it with admin on the install and when opening the program. It just shows the CCP logo then disappears.

Fixed my issue

  • Please press the windows key + R to open a run window.
  • Copy and paste the following into the run window and press enter.

%LOCALAPPDATA%\CCP\EVE\QtWebEngine\Default\Service Worker\

  • Right click on the folder named ‘CacheStorage’ and delete it.
  • Please press the windows key + R to open a run window.
  • Copy and paste the following into the run window and press enter.


  • Right click on the folder named ‘cache’ and delete it.
  • Start the launcher and see if the issue persists.
1 Like

I too was affected by this issue. I deleted my existing EVE installation. I downloaded the Launcher again and deployed it to a new directory. However, when I start the Launcher up, the splash screen appears for a brief instant and then disappears without a trace… So what do I do now?

I went through Steele Hawke’ solution and my launcher came up. Thanks for your timely post Steele :slight_smile:

This solution seems to be working for some but did not for me. My problem may have been AVG-related and I was too slow to recognize it.

However, thanks for posting this solution again. It’s on CCP’s Support site, but likely more visible here.

So this happened to me aswell, only WHILE i was playing. I was playing (L4 Mission - Guristas Extravaganza) and suddenly the Launcher popped in the front and started updating. 5 Secs later it closed itself, some moments later the whole game closed itself.

Frantically i try to log in again, but surprise, my desktop shortcut isn’t working, since the launcher obviously deleted itself. All the .exe files seem not to start the game on it’s own and i tried to download and install the game to a different location, but ofc now only the CCP logo shows up on launcher startup and that’s it. Haven’t been able to fix that, but my CNR will be long gone anyway.

Seriously, after coming back to this game recently, i’m ■■■■■■■ furious about investing money for 3 months omega and running from one issue into another, destroying any progress i made.

Sorry for your loss. You can perhaps petition CCP for it.

Seems these errors are antivirus-related. Something in the new update triggered. See;

In my case it was with AVG (perhaps - have to diagnose further when I get home)

The exact same thing happened to me this afternoon. I had been playing for an hour or so when suddenly the client minimized while the launcher started updating. Next, both the game and the launcher closed completely and I got an AVG message saying that the update had been flagged and aborted.

This also broke the game because “evelauncher.exe” was now gone. I ended up deleting my EVE folder and had to re-install everything. The game is working again now, and I created an exception for EVE in AVG to hopefully prevent this from happening again in the future.

The good news is this procedure worked. So thanks. 3000.

The bad news is EVERY time this happens and it’s happening at least once a month I have to
go through email verification AGAIN!

I don’t have to jump through hoops repeatedly with my banks and investment accounts!

Getting MIGHTY sick of having to do so for a GAME!

In the past I’ve had the ‘Launcher Updating’ message pop-up a few times and I wasn’t even logged into the game, most recently was last night / early morning while I was watching a movie. Upon completion the Launcher then opens automatically and does it’s normal ‘Checking Hosts’ and ‘Applying Updates’ with the green line progress bar at the bottom before listing ‘Ready’ on the list of accounts.

It’s very irritating that it automatically does an update when the Launcher is closed as well as automatically opening the Launcher afterwards. In my opinion that shouldn’t happen, it’s almost like my computer is being hacked by CCP, activating a program that I don’t want active at that time.

If only Windows installations world wide would delete itself and be quarantined by every virus scanner… now that… would be… popcorn.

Finally Mac and Linux and BSD for world domination…

I already had a false positive some weeks ago and made an exception for Eve. I also checked my Avast and from the logs it didn’t do anything today nor did it pop up. So not sure about that.

Yup my issue was caused by Avast, hopefully sorting it now.

Same here, the game launcher deleted itself. The only solution for me was to deinstall the game. Now i am downloading 17GB of game data to reinstall the game. :frowning: Why?

I hope someone at CCP is looking into this issue.

There is another thread linked here, higher up , that says this is antivirus-related. It states Avast specifically, but myself and many others have experienced the same behavior with AVG. The thread recommends downloading the most recent definitions for your antivirus, and if that doesn’t work then perhaps add an exclusion. See the thread.

Thank you so much!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.