[RESOLVED] 20211116 - Issue with Avast Antivirus and the EVE launcher

We are investigating a reported issue where Avast Antivirus may be throwing false positives about the EVE Online launcher. If you’re an Avast user and have encountered any problems please leave details in this thread.

Updates will be posted here and on the EVE Status Twitter account.

Update 18:55 UTC

Per [RESOLVED] 20211116 - Issue with Avast Antivirus and the EVE launcher - #25 by CCP_Explorer
The issue with Avast and AVG has been resolved. We ask that you please update to the latest virus definition files if you’re using this software. Thank you, and safe - virus free - flying!

14 Likes

Yes I had this issue today and got the launcher moved to the vault… Had to go through a long process to get it fixed since it didn’t allowed me to recover it but it’s finally fixed!

Had the same issue on my windows machine, did recover and created an exception for the exe file. On the imac no problems but that is other code :wink:

Yeah same here. here is the information I can gather.

Threat name IDP.Generic
Infected File QtWebEngineProcess.exe
Original Location EVE/Launcher(This is my installation folder)

I tried to restore and add to the exception but it claims the file already exists(maybe it was restored?), my EVE Launcher shortcut no longer works also, I think it deleted the thing for the launcher, evelauncher.exe is no longer in the Launcher folder, all other files that I can recognize, including the vaulted one are here.

Thats where my launcher went this morning.

I don’t have issues but I just want to say it’s nice to see information posts like these. Please more of this in the future.

REDNES

4 Likes

I now believe this was the same problem I was having all weekend;

I didn’t think to look at AVG, but this was very similar behavior, with evelauncher.exe going missing from the launcher directory. Finally got around it (after umpteen uninstall/reinstalls) by selecting “Cancel” at launcher update.

Same issue with AVG Free AV. File QtWebEngineProcess.exe was quarantined, Evelauncher.exe deleted. Not able to restore files from quarantine. Reinstalled into a new directory to solve problem.

Haven’t had any issue today following the update, yet, but I had popups from Avast after the patch on Singularity on (Edit November 3rd), mainly anytime I would log off and quit for an account. It was about Exefile.exe.
Edit: I currently see Exefile.exe in the quarantine with menace “IDP.Generic”
I confirm it is currently only for the exefile.exe in the SharedCache\sisi\bin64

I did not restart the launcher since the live updtate today. Hopefully it doesn’t break my install.

Removed offtopic postings. Please limit posts to details of AVAST issues you are experiencing

1 Like

Hi everyone,
I’ve had the same issue with Avast, having the Qtwebengineprocess.exe file moved to the quarantine vault. After having tried to scan it with other programs - and unable to - I decided to do a fresh install of the game.
I’ve tried it now to install the game two times in a row, a complete, fresh installation, but I can’t get it to work, the launcher simply won’t start… I’ve added a couple of exceptions to Avast, in order to facilitate the launcher to work but no luck so far. As such, I’m not sure what to do next… Any ideas? I’m running win10.
Hope this issue gets resolved soon :wink:

NM …

–Correcting Gadget

Same problem here - Avast quarantined the QtWebEngineProcess.exe file and would not let me restore it.

I uninstalled Avast, uninstalled Eve, re-installed Eve and all is fine.

The affected files are

Qtwebengineprocess.exe & crashpad_handler.exe

typically located in the EVE Launcher directory. Our tech team is working with Avast to determine what the issue is that’s flagging the false negative, and hope to have an answer soon!

In the meantime, you can find a previous version of the launcher here: https://www.eveonline.com/EveLauncher-1952584.exe

1 Like

Thanks for the quick reply CCP Swift!
I did try and restore the file on another pc (that was having the same problem) but Avast prevented it.
After wiping the game and reinstalling the launcher - and being unable to get it to work -, I went here:

followed every step of the instructions and clearing the cache enabled the launcher to work again.
The game is now downloading. I will post another reply here to let you know if it worked or not :wink:
Thanks again!

Hi,
Just to let you know that the game is now working :wink: And, just in case, I have added exclusions in avast for:
C:\EVE\Launcher\evelauncher.exe
and
C:\EVE\eve.exe

To add exclusions in Avast go to:
Menu
Settings
Exclusions
and browse path to relevant file

Hope this helps other players experiencing similar problems :wink:
Thanks!

Hello all

Issue happended this afternoon where the launcher just disappeared.

Tried to restart it, would try and open. CCP would show but not the launcher. (icon on the bottom right of windows 10) but when hovering the mouse over it, it just disappeared.

Did the usual Google and found this…

Which worked.

Finally, I did disable Avast to see if that helped, but no luck.

This post was flagged by the community and is temporarily hidden.

Almost a boot.ini! :wink:

Shame for the people affected and good to see there’s workarounds. I hope you will keep us updated when more details emerge on why it was flagged, from a nerd perspective that would be an interesting read - assuming that it IS a false/positive and not some actual malicious code that made its way in…

According to the Avast Customer Care Team then this issue has been resolved. Please update your Avast or AVG software to the latest virus definition files.

If you have any issues restoring the EVE Launcher then please send us a technical support request, or file a technical support request with Avast or AVG, or consult the documentation with your antivirus product.

5 Likes