Eve Launcher deleting itself?

Very weird issue today with Windows Eve;

Started the Eve Launcher. It downloads some files. It updates it cache. It asks me to hit “OK”. It restarts.

And then it crashes.

But get this; It deletes Eve/Launcher/evelauncher.exe in the process. Even my desktop icon disappears. The file is nowhere to be found, even Recycle Bin.

I’ve cleared every cache, rebooted, uninstalled, deleted, and reinstalled, etc. etc. It has done it 3 TIMES in a row now. I’ve had to uninstall/reinstall each time because the launcher exe is GONE.

I filed a ticket, but with the weekend…

Just misery looking for company, I guess.

Or maybe this is how I finally win Eve.



Thank you - made me laugh.

I do have my laptop updated, at least with the critical updates.

And just to be sure, I uninstalled and deleted all vestiges of Eve, even my LocalData this time.

Resinstalled and watched it for the 3rd time - update Launcher, OK, bye bye evelauncher.exe. Saw ithe file disappear in real time from the directory this time. I copied it out before, but can’t copy it back, even with admin rights.

Very strange.

Time for tanks, kingdoms, zombies, I guess.

Well you have company because i had the exact same thing happen have not managed to fix it yet.

i get this also

Sorry to hear that. I tried a fourth time with a clean install. This has me stumped.

Having the same issue… What the hell is going on? This isn’t another boot.ini hopefully?

Linux running Proton/Wine is immune to boot.ini :slight_smile:

Same happened to me, launchers gone, sigh I dunno, if EVE is killing itself perhaps this is some kind of message.

Eve is dying… for real?

1 Like

This exact problem happened to me two days in a row.

This worked:

Downloaded the Eve launcher from the website. Right click, Run as Administrator. When asked to use the same folder, clicked Yes. Got the launcher screen a few moments later, and now it’s doing it normal download update.

Yesterday I completely removed Eve from my computer and downloaded and installed everything again. I have a slow connection so it took all day.

Eve has had launcher problems like this for years, and if memory serves, “Run as Administrator” has worked most of the time.

Oh and I copy and pasted the evelauncher.exe to my desktop so I’ll have a backup if (when) this happens again.runasadmin

Well, it was downloading the entire thing again, over 2 GB. Pasted the evelauncher.exe into a previous Eve folder, and it’s working without the all day download.

Also had to run evelauncher.exe as Administrator.

Thanks for the tip. Unfortunately, running as administrator did not work. After it updates itself it restarts and then fails. I tried hitting “Cancel” instead of “OK” after the update and restarting the launcher manually as admin, but then I just end up in the loop.

Saw someone on Reddit having maybe the same issue. I think it’s in CCP’s court at the moment.

However, thank you for posting and trying to help.

You could run it on Linux under Proton/Wine if you have Windows launching problems. :clown_face:

An added bonus is you won’t have any boot.ini risks.

Some irony in this but… it works there.

Any chance you are running a steam flavor of eve? Just asking as recent steam update has a false positive for … i don’t recall the trojan, with the v-checker my son has; and I had to rescue his steam.exe out of quarantine, so he could access his other programs, including eve. From your description, maybe this is not the case, but I had to toss it in there on the off-chance, as his error results were not exactly as yours but similar nonetheless.

Good luck.

No Steam, but thanks for checking back.

If any virus checker was working it would flag Windows as a trojan and quarantine Windows itself.

Steam version of Eve also works fine with normal accounts and not federated Steam accounts as the login. I don’t have any false positives with it running on Linux and Proton.

If you’re getting false positives on your virus checker, perhaps consider changing it, also, be aware virus checkers on Windows tend to sell your data (especially so called free ones) and know everything you run, when you run it, and how often along with connections to sites and what processes are running (which could also leak sensitive data as to what files you’re using).

Okay, success, for now.

Uninstalled, deleted remnants of the program and user data, reinstalled, and ran Launcher as admin (5th or 6th time over 3 days).

At the Launcher has updated itself prompt I chose “Cancel” this time. Launcher continued downloading files and let me reenetr account info and log in.

It has something to do with the latest version of Eve’s launcher, so I don’t don’t how permanent this fix is.

It has something to do with the latest version of Eve’s launcher, so I don’t don’t how permanent this fix is.

You will know at the next update :slight_smile: