Eve launcher does nothing/does not start when double clicked

Like the title, Eve launcher does not open at all. When I double click the eve launcher, I see the loading icon for half a second on the mouse and nothing happens. I’m home for the holidays and had to install eve on another computer.

I tried downloading and opening through steam, I tried just opening the client outside of steam , and I tried the beta launcher. I have uninstalled them all multiple times.

Any fixes? Im like a 2 week old player and I heard we got war decced last night so apparently i need to get on and move some ships or something.

Are you using AMD graphics? Try rolling back your video driver. If that doesn’t work, see if the Eve tray icon is available - right click and open settings. Switch between release and beta - see if that makes a difference. If not, start loglite, exit and restart the launcher, submit a support ticket with the log file attached and then be patient!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.