EVE Launcher not working for Ubuntu 20.04

I recently moved from Windows to Ubuntu 20.04. I followed the guide https://wiki.eveuniversity.org/Installing_EVE_on_Linux and what i got was i finished was a bunch of errors

QObject::startTimer: Timers can only be used with threads started with QThread
/home/ataraxia/evelauncher/./evelauncher: symbol lookup error: /lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

Can someone help me? I have no programming knowledge and I am new to Ubuntu.

I managed to get it to start working with export LIBGL_ALWAYS_SOFTWARE=1
But sadly I was greeted with a black screen.

Nice to see you here. :slight_smile: Please have a look at this post EVE Installing which should solve your problem.

– fly safe o7

I am greeted with a black screen after the done processing bulk data

Be patient, it take some time after the first start. Have this too :slight_smile:

It freezes and tells me Wine is not responding

Can you put the launcher log here? Cut it from the console insert it with three back ticks ` around.

How? :sweat_smile:

Do you have discord? Then come to https://discord.gg/B4sNeQs i’ll be there.


Intel integrated graphics were used (Kaby Lake i suppose) the log says

Intel(R) UHD Graphics 620 (KBL GT2)

Maybe someone knows the error with this hardware.

One of possible reasons is downloading game assets by the client. If your internet access is slow it will be more visible. Try to set “Download the full EVE client” in the launcher settings and leave computer for a few hours. There is 20GB + to download.
I did have similar issues until I downloaded the whole client.

Having same issue:

Settings path: “/home/roman/.config/CCP/EVE.conf”
Language selected based on stored settings: “en”
QObject::startTimer: Timers can only be used with threads started with QThread
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
/home/xxxxxxx/GAMES/evelauncher/./evelauncher: symbol lookup error: /lib/x86_64-linux-gnu/libGLX_mesa.so.0: undefined symbol: xcb_dri3_get_supported_modifiers

Using Linux launcher. Ubuntu 20.04, fresh install.

Setting “export LIBGL_ALWAYS_SOFTWARE=1” is not a solution or w/a. It disables graphics driver and game runs solely on CPU.

Another beautiful example of why I hate that stupid eve uni post.

I just had the same issue. (But solved it read the last paragraph)

Linux Mint 20
CPU: 2920X
GPU: R9 390
EVE installed on Lutris using DXVK

I launched the launcher it downloaded about 1GB of updates (i havent loged in in about a week)
launched the client
wached a black screen with a rotating cycle in the bottom left for 5min
got to the carector select and selected carrector
waited 5 more minutes
got into game.

after trying DX9, different toons. I then closed and reopened the launcher and it downloaded a 500GB pach.

So if you are having trouble on linux (normally after Down Time) close and reopen your launcher.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.