Issue with Linux launcher

With evelauncher-1543721.tar.gz I see the following message. This is on Fedora 30 and I haven;t fiddled with anything, so likely really on Wayland not X, I run the launcher and see this:

[balister@mini evelauncher]$ ./evelauncher.sh
QObject::startTimer: Timers can only be used with threads started with QThread
qt.qpa.plugin: Could not load the Qt platform plugin “wayland” in “” even though it was found.
Could not initialize GLX
./evelauncher.sh: line 14: 4720 Aborted (core dumped) “$dirname/appname" "@”

I do have this working on other boxes.

Philip

To be more accurate it’s an issue running eve linux launcher on wayland. The installer package are missing some qtwayland libraries and the evelauncher try fall back to xwayland if you have this installed.
If he cannot initialize GLX means, that maybe your installation are missing opengl drivers for your graphics hardware.

I forgot, the actual version from evelauncher are 1548102 just change the version in the download link.

So you’re sayiing to just download the version you mentioned which will include the proper wayland libraries?

I’m having this same issue on Ubuntu 18.04.

That was not was i’m saying, i have just written, the actual version from evelauncher are 1548102 not 1543721 and the actual version misses the qtwayland libraries too. If you use Ubuntu 18.04 you cannot use evelauncher with wayland, only with xorg.

Are you or anyone aware of a way to get eve running with Wayland?

Just done in Starting game in launcher

HTH

PS. But not on Ubuntu 18.04 the delivered qt version are to old (version 5.6 if i remember correctly).