Eve Online Game Client won't Start

A few months ago I played Eve Online, now I’m looking into getting into it again. I’m using the steam version and open the launcher, same computer, same steam account, same eve account. I login, click play and… Nothing happens. I wait a while. Still nothing. I try again. Still nothing. I try some solutions I found online like deleting all eve online processes in task manager and trying again and verifying cache. Doesn’t work. When I click play, my cursor turns into a blue loading circle like it usually does, but then nothing happens, checking background processes shows that the Eve Online Launcher has jumped from consuming a little bandwidth to almost all, if I close the Eve Online Launcher, a new process pops up, consuming almost all of my bandwidth called CCP ExeFile or something like that. What do I do?

Sorry if I’m being stupid.

So steam is notorious for not playing well with Eve. I think there is a way to migrate your Eve account off of steam, so that might be an option. But let’s try some other stuff first.

First of all, try the steps in this article here.


Next, right click on the game in your library, select properties, and verify your game files.

If you still have problems after that, let me know, and I’ll see if I can’t help you. You might also want to file a support ticket now in order to get in line. If you end up solving the problem beforehand, you can always close it.

And do please come back and tell us what worked. Might help the next guy with the same problem.

Wow am I stupid. Guess it’s really simple as that sometimes. I had to verify the launchers files and then it worked.

\o/