Eve x Excel Add-in Version 1.7.0 Patch notes

The 1.7 patch is going out as we speak to production.

Updated static files to latest SDE and fuzzworks conversion.

New functions:

  • EVEONLINE.CHARACTER_MINING(character_id_or_entity)
    Mining ledger information for a signed in character, will return the first signed in character if the character is omitted

  • Early access functions below (raw, likely to break)

  • EVEONLINE.CORPORATION_MINING(character_id_or_entity)

  • EVEONLINE.CORPORATION_MINING_DETAILS(character_id_or_entity, observer_id)


  • .CATEGORY(id, expand_groups) can now be expanded to include the type information from the nested groups. Performance warnings from using the trigger as some categories are huge.

  • Page sizing in Excel web is now dynamically decided and will do steps of 50 until it finds the highest compatible number to allow each page of paginated lists to display to elimiate #BUSY errors in assets and other heavy functions. Will default to page 1 in Excel Web. Will lead to more mixing to display full lists inside excel web as the length is no longer fixed, but can be solved with VSTACK usage and some extra helper cells.

  • repackaged_volume is now included in all type cards (via hoboleaks)


  • Fixed endless loop bug for deprecated blueprints being input into blueprint explosion.

Yes! Mining ledger!

1 Like

how do i force the update, my excel is ttill showing 1.6?

You can try hitting CTRL+F5 after focusing the sidebar with your mouse, then restarting the client (twice sometimes works)

Otherwise the hard-reload method is as follows, listed most recently by Capt Sasen on discord so I’ll just copy paste that.

Go to File → Options.
Navigate to Trust Center → Trust Center Settings.
Select Trusted Add-In Catalogs.
Check the box that says Next time office starts, clear all previously started web add-ins cache.
Restart Excel.

ctrl+f5 worked, thanks

1 Like

Did anyone figure out how to get CHARACTER_WALLET_TRANSACTIONS working in web Office 365 after this update? Im using below formula but I keep getting #Bussy!


Hotfix is going out to fix this issue that Ezra faced, will still say 1.7 in the sidebar. Since it’s only really excel web related hotfix.

To update in excel web you might need to do right-click inspect → Network, and checkbox disable cache.

Then hit right click on the sidebar and “Reload frame”

The 5mb limit had to be lowered to 3.5mb but hopefully works now. Please note the page size might be larger or less than 200 (max 350 now) due to dynamic sizing.

Character_Assets in excel web without filtering should now work in most cases, thanks to your feedback about it not being consistent, but it’s still not recommended to use without using a type_id filter (It can crash the browser, since it’s so data heavy)

1 Like

@Hundasuupa thank you for the fix, it works now! Fetch is per 350 records. Thank you :sunglasses:

1 Like